Page 1 of 2 12 LastLast
Results 1 to 25 of 30
Like Tree2Likes
  1. Thread Author  Thread Author    #1  

    Default Google Contacts won't sync

    I can't get Google contacts to sync on my Sprint hero.
    Gmail and calendar work fine.

    But contacts won't sync...

    Any ideas. It just times out and says sync not available now.
  2. #2  
    beezy's Avatar

    Posts
    2,457 Posts
    Global Posts
    2,458 Global Posts
    ROM
    Extra Crispy

    Default

    Quote Originally Posted by Ed Hughes View Post
    I can't get Google contacts to sync on my Sprint hero.
    Gmail and calendar work fine.

    But contacts won't sync...

    Any ideas. It just times out and says sync not available now.
    Go to settings>accounts&sync>google>sync now. If that dont work uncheck/check sync contacts if it don't start to sync press sync now.If that fails reboot and it should sync.
  3. #3  

    Default

    I'm in the same boat. Not sure why contacts won't finish syncing.
  4. #4  

    Default

    Same here. Been that way since June 16. Gmail and calendar sync no problems. I'm sure a reset would fix, but I do not want to do that. I do not want to set up my phone again.
    Can't wait until November. I will be going with a EVO
  5. #5  

    Default

    Are you rooted?

    If so, use rootexplorer to navigate to /data/data. Find the directory labeled "com.android.providers.settings" and delete it. Reboot, and your Google contacts should now sync!
  6. #6  
    mouseglider's Avatar

    Posts
    429 Posts
    Global Posts
    1,090 Global Posts
    ROM
    Stock - but Rooted

    Default

    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    Thanked by 7:
    danquin25 likes this.
  7. #7  
    pkn
    pkn is offline
    pkn's Avatar

    Posts
    1 Posts

    Default thanks!

    Quote Originally Posted by mouseglider View Post
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    This worked for me! Thanks!
    Thanked by 3:
  8. #8  

    Default I've got a few steps to add

    Thanks so much for the solution. T-Mobile wanted me to do a factory reset.

    I thought I would fill in a few gaps in the menu and screen traversal

    Home/Menu/Settings/Accounts & sync
    Turn off Background data
    Home/Menu/Settings/Manage Applications/All/Contacts Storage/Clear data

    Home/Menu/Settings/Accounts & sync
    Turn on Background data

    thanks again, James
    Thanked by:
    m.jrdn 
  9. #9  

    Default

    In this step

    Home/Menu/Settings/Manage Applications/All/Contacts Storage/Clear data

    Does clear data get rid of my contacts.
  10. #10  

    Default

    this worked flawlessly. have been trying to get done for a month. thanks.
  11. #11  

    Default Re: Google Contacts won't sync

    Quote Originally Posted by mouseglider View Post
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    My problem is that the clear data button is greyed out. why can't I clear my data?
    open the "Contact Storage" and click "clear data" of "Contacts Storage"
  12. #12  
    SSHGuru's Avatar
    Banned

    Posts
    667 Posts
    Global Posts
    664 Global Posts
    ROM
    Lithium

    Default Re: Google Contacts won't sync

    I got the Bionic and everything Sync's but the gmail contacts. I can't do those steps because the options are greyed out.

    Any advice?
  13. #13  

    Default Re: Google Contacts won't sync

    Thank you MouseGlider. Your solution worked perfectly to get my contacts to sync from google to my android phone.
  14. #14  
    Vance14's Avatar

    Posts
    680 Posts
    Global Posts
    683 Global Posts

    Default Re: Google Contacts won't sync

    Mine still is having problems even after this fix. I have cleared all my data and it tries to resync everything, but then it just stops after a while and the small "syncing" spinning icon just goes still, but doesn't go away. And, new contacts from my browser UI are not synced into my phone. And, it is showing that the last sync was yesterday morning, even though it has tried numerous times since then.

    Edit: after doing this process a few times, it finally did sync and shows a new sync date and time, but for some reason, the little icon won't go away. Regardless, it finally did sync!
    Last edited by Vance; 11-01-2011 at 01:07 PM.
  15. #15  

    Thumbs up Re: Google Contacts won't sync

    Thanks for the tip. Worked great. My contacts had not synced since Jan 13, 2011.
  16. #16  

    Default Re: Google Contacts won't sync

    Mouseglider's recommendation worked perfectlt. I had Sprint do hard reset and they re-entered contacts that had been saved not realizing that Google would re-sync contacts so I ended up duplicate set of contacts. This led to Evo not wanting to sync Google contacts. Thanks again for the tip.
  17. #17  

    Default Re: Google Contacts won't sync

    FIX WORKED GREAT!!!!!
    Thanks Alot!
  18. #18  

    Default Re: Google Contacts won't sync

    Quote Originally Posted by mouseglider View Post
    Try this:

    thanks alot man
    i tried so hard to get it sync n searched the net for hours but couldnt find anything

    this forum and ppl like you rock

    thnxx again

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"
    monica18 likes this.
  19. #19  

    Talking Re: Google Contacts won't sync

    Quote Originally Posted by mouseglider View Post
    Try this:

    First, press menu and go to "settings" - click on "Accounts & snyc" - uncheck "background sync" - now use your back key to get back to the screen where you saw "Accounts & snyc" and then click on "Applications"

    Locate "Contacts Storage" - if you can't find "Contacts Storage", click menu again and select filter, then select all - open the "Contact Storage" and click "clear data" of "Contacts Storage"

    Get back to the first step above and recheck "background snyc" - it will start to snyc and take anywhere from 2 minutes to 15 minutes

    If you have problems with "calendar" and "gmail" do the same steps above to for "Calendar Storage" and "Gmail Storage"

    @mouseglider

    Thanks for the fix!!! Worked perfectly on my Samsung Captivate Glide with INC3PTION custom rom. It was the only thing not syncing after installing INC3PTION and restoring my settings from backup.
  20. #20  

    Default Re: Google Contacts won't sync

    Kudos to mouseglider for this fix. I've been struggling for a while trying to figure out why my Google contacts won't sync to my Galaxy Proclaim running GB. If I add new contacts to the phone and choose Google (instead of Phone) to save the contacts, the new contacts shows up in my Google contacts but weren't showing in my phone.

    However, if I received a call from the new contact, the contact name would show up. But maybe that's caller ID instead of my contact list providing the info.

    IAC, after following mouseglider's instructions, my contact list downloaded and I have my latest contact additions on my phone now.

    Hopefully the sync will work as expected in the future.
  21. #21  

    Default Re: Google Contacts won't sync

    You are a lifesaver! Verizon said "Do a factory reset." Thanks so much!
  22. #22  

    Default Re: Google Contacts won't sync

    Mouseglider's method does allow me to sync, but any contacts that I added to my account using my phone were wiped out because they were never synced to Google's servers.

    I noticed something that else that may be causing the issue for others as it was for me. I was using Go Contacts EX app as my contacts manager app. If I use the stock contacts app to add a contact, it syncs to Google just fine. As soon as I add one using Go Contacts EX, following sync attempts fail.
  23. #23  

    Exclamation Re: Google Contacts won't sync

    Thanks a lot for this information mouseglider. Following your clever and brilliant instructions for resolving gmail sync'ing problems with Android has caused me to lose most of my important contacts. Far from a successful sync resolution, this has caused a one-way sync from Gmail, which only had a fraction of the contacts that were on my HTC Wildfire. End result: Most of my important contacts are now deleted from my contacts list.
    Last edited by Nathan Bliss; 11-18-2012 at 06:21 PM.
  24. #24  

    Default Re: Google Contacts won't sync

    Quote Originally Posted by devo1929 View Post
    Mouseglider's method does allow me to sync, but any contacts that I added to my account using my phone were wiped out because they were never synced to Google's servers.

    I noticed something that else that may be causing the issue for others as it was for me. I was using Go Contacts EX app as my contacts manager app. If I use the stock contacts app to add a contact, it syncs to Google just fine. As soon as I add one using Go Contacts EX, following sync attempts fail.
    That's MY EXACT problem. Whenever I add a contact using Contacts EX (edit, just tried to add a contact using the default Contact app instead of Contacts EX and the problem will also occur), my sync will just fail. If I remove all contacts and try to sync again, it will all work flawlessly. If I add a contact on gmail and sync, it will bring it to my phone, but whenever I try to change something on contacts EX, it won't work and the syncing will no longer work from then on.

    That's a very serious issue and even though Contacts EX is updated, I've never had a solution to this problem. Does anyone?

    Thanks
  25. #25  

    Default Re: Google Contacts won't sync

    Hi my contact wont sync
Page 1 of 2 12 LastLast

Posting Permissions

B