Results 1 to 14 of 14
  1. Thread Author  Thread Author    #1  

    Angry problems with gmail sync

    im having problems with my gmail account syncing on my sprint htc hero.. after a couple of frustrating hard resets sprint has sent me a new one. the question i have is whether or not gtalk has to be running in order for gmail to sync. i have noticed that gmail does seem to work if i leave gtalk open(but not signed in).
  2. #2  

    Default

    Can any one tell me why my Google contacts will not sync?
  3. #3  
    alex737's Avatar

    Posts
    50 Posts
    Global Posts
    60 Global Posts

    Default

    Quote Originally Posted by markyflies View Post
    Can any one tell me why my Google contacts will not sync?
    I was having this issue last month. I had to go to sprint store. They fixed the issue in like 5 minutes.
  4. #4  

    Default

    gmail seems to have cross platform trouble.
  5. #5  

    Default

    Quote Originally Posted by alex737 View Post
    I was having this issue last month. I had to go to sprint store. They fixed the issue in like 5 minutes.
    I am currently experiencing this issue of the contacts not synching. In fact, the last successful synchronization of contacts occurred on June 25, and it hasn't worked since.

    I called Sprint Tech support and was on the phone with them for close to an hour and all they did was have me turn off the phone, take out the battery, and wait while they refreshed the network. That of course didn't fix the problem.

    What does this five minute fix involve? I hope it isn't resetting the phone.
  6. #6  

    Default

    For me resetting is not an option, unless Gmail and my calendar stop syncing.
    The great thing about Android is the fact that it is HIGHLY customizable. Resetting, which I have done once when all sync functions stopped, is a pain in the ***!!
    Customizing my Hero takes WAY too much time.

    Hoping Google or someone has the answer.
  7. #7  

    Default

    my gmail stopped syncing on my evo last night, as of 732PM PDT today its still not working, gtalk still works fine so, IDK
  8. #8  
    hotzb22's Avatar

    Posts
    47 Posts
    Global Posts
    106 Global Posts

    Default

    Yea me too no emails
  9. #9  

    Default

    Go to manage applications, then gmail and clear the data. Then go to gmail storage (also under manage applications) and clear the data there too. Seems to fix the problem for most people.
    Thanked by:
  10. #10  

    Angry

    Same problem. Primary account (personal) works just fine. The secondary gmail account (work) does not sync. Both accounts are gmail.com accounts not apps. Gmail push was working just perfectly till last night on android 2.1. The sync on secondary gmail stopped working after I upgraded it to 2.2 last night. Infact I didnt even notice the problem till I missed my meeting this morning becase the email never arrived on the phone.

    Earlier the gmail push was working *without* talk.. with ATK installed and autokilling apps... Now with 2.2 I have no autokiller.. I also tried factory reset and tried it without installing any apps and the problem still existed... I cant believe more people are not plauged with this problem...

    Here is a summary from what I have read about this issue so far.

    1) This is not isolated to HTC EVO
    2) The secondary gmail not syncing seems to be a froyo problem (there are a few threads about this for android 2.1 but they refer to all gmail not syncing. Froyo does not have the option for "gmail storage" to clear data)
    3) Factory reset does not help
    4) Adding and removing accounts does not help
    5) Same problem with any secondary account I add
    6) Its not related to a particular gmail account because they dont work the other EVO as the secondary email either.

    I currently have a workaround. I have forwarded my secondary gmail to [mysprintnumber]@messaging.sprintpcs.com

    that way I receive an SMS when email arrives in my gmail and then I manually sync in the gmail app. Works for now, but I dont want this to be a permanent solution. This is android... the least Google could do is make gmail (and its other services) work on this perfectly.

    Someone at Google, HTC or Sprint please take notice..

    Device: HTC EVO
    Carrier: Sprint
    Country: US
    OS: Android 2.2 (/w HTC Sense) - Official froyo update from sprint
  11. Thread Author  Thread Author    #11  

    Default

    I dont know if this will help anyone but i have noticed when i go to settings>applications>running services if gtalk service isnt running than my gmail services for some reason will not sync unless i do it manually.. i asked sprint about this and of course they did not know but when i leave the gtalk service running it works.
  12. #12  

    Default Might be working now...

    I think it works now... This is the first time I have gotten auto sync to work on my secondary account in 2 days since... Here are the steps I followed... hope it works for everyone...

    1. Removed all secondary accounts, leaving only the primary.
    2. Went into Applications->Gmail and removed data, then did Force Stop.
    3. Restarted Gmail app.
    4. Went into Applications->Contacts Storage and removed data.
    5. Rebooted phone (power down, power up).
    6. Added secondary accounts again in "accounts and sync"
    7. you get two options... Sync Contacts and Sync Calendar... Gmail doesnt show up here... yet!
    8. Go to Gmail app... it shows two accounts... the secondary account "not synced".
    9. Tap on the secondary account -> Menu -> Refresh
    10. Go to Menu -> Settings ->Accounts and sync -> secondary account Gmail is not selected for auto sync... Select it.
    11. Sync all

    So far it is working. I'll update the status soon.


    Quote Originally Posted by usrbingzip View Post
    Same problem. Primary account (personal) works just fine. The secondary gmail account (work) does not sync. Both accounts are gmail.com accounts not apps. Gmail push was working just perfectly till last night on android 2.1. The sync on secondary gmail stopped working after I upgraded it to 2.2 last night. Infact I didnt even notice the problem till I missed my meeting this morning becase the email never arrived on the phone.

    Earlier the gmail push was working *without* talk.. with ATK installed and autokilling apps... Now with 2.2 I have no autokiller.. I also tried factory reset and tried it without installing any apps and the problem still existed... I cant believe more people are not plauged with this problem...

    Here is a summary from what I have read about this issue so far.

    1) This is not isolated to HTC EVO
    2) The secondary gmail not syncing seems to be a froyo problem (there are a few threads about this for android 2.1 but they refer to all gmail not syncing. Froyo does not have the option for "gmail storage" to clear data)
    3) Factory reset does not help
    4) Adding and removing accounts does not help
    5) Same problem with any secondary account I add
    6) Its not related to a particular gmail account because they dont work the other EVO as the secondary email either.

    I currently have a workaround. I have forwarded my secondary gmail to [mysprintnumber]@messaging.sprintpcs.com

    that way I receive an SMS when email arrives in my gmail and then I manually sync in the gmail app. Works for now, but I dont want this to be a permanent solution. This is android... the least Google could do is make gmail (and its other services) work on this perfectly.

    Someone at Google, HTC or Sprint please take notice..

    Device: HTC EVO
    Carrier: Sprint
    Country: US
    OS: Android 2.2 (/w HTC Sense) - Official froyo update from sprint
  13. #13  

    Default

    Quote Originally Posted by canterrain View Post
    Go to manage applications, then gmail and clear the data. Then go to gmail storage (also under manage applications) and clear the data there too. Seems to fix the problem for most people.
    This seemed to do the trick for me! Thanks so much!

    For the record: My Gmail app stopped syncing with my inbox. I would still receive new e-mail notifications, but could not see the current inbox. I kept getting the "No Connection: |Retry|" button on the bottom. Google Talk worked just fine so I was unsure of what to do. I will definitely remember this solution - THANK YOU!
    Thanked by:
  14. #14  
    ectoren's Avatar

    Posts
    254 Posts
    Global Posts
    260 Global Posts

    Default

    Quote Originally Posted by johnson.joshua.11 View Post
    This seemed to do the trick for me! Thanks so much!
    This is why I looooove this forum.

    Went to the local Sprint tech dept. FOUR times & they were never able to solve the issue. They told me to leave the phone for as long as they need it to solve the issue. Could take days. Had a big argument with the manager of the store. This took almost two weeks of back and forth.

    Come to this forum. 15 minutes later. Issue has been resolved!

Posting Permissions

B