Results 1 to 20 of 20
  1. Thread Author  Thread Author    #1  

    Default Problems with myTouch 4G

    I bought my phone two days ago and I haven't been able to send a picture message to anyone. I can send them when using wi-fi, but when I'm not on wi-fi I get an error message saying, "Generic Network Failure." Has anyone else been having this problem?
  2. #2  

    Default

    Call TMO... sounds like they did not active something correctly on your account.
  3. #3  

    Default

    Is you SIM card newer? Only asking because if T-Mo can't find a problem on their end... SIM card may be something they overlook on the phone and this might cause lots of wasted time trying to track your problem down. My SIM is from the Voicestream days so I asked for a new once since I heard old ones lacking newer network info can cause a variety of problems and the phone rep confirmed this - said that was true, and when they have a variety of network problems with customers a new SIM card usually does the trick.
  4. #4  

    Default

    Actually everyone should have updated their SIM especially if they have a G2 or MT4G because the SIM was redesigned for these phones and one should have been packaged with it. My old SIM was only a year old and when I put the new SIM in this phone and activated it...it even improved reception and made it slightly faster. Technical support told me that you should use the new SIM that comes with these phones as there is much more to the 4G network than the old SIMs can handle.
  5. #5  

    Default

    Quote Originally Posted by Nissan4LIFE View Post
    Actually everyone should have updated their SIM especially if they have a G2 or MT4G because the SIM was redesigned for these phones and one should have been packaged with it. My old SIM was only a year old and when I put the new SIM in this phone and activated it...it even improved reception and made it slightly faster. Technical support told me that you should use the new SIM that comes with these phones as there is much more to the 4G network than the old SIMs can handle.
    I'm still using a VERY old SIM card... I used it in a RAZR, BB 8900, BB 9700 and now in my myTouch4g without issue.
  6. #6  

    Default

    I've been having difficulty sending mms as well, and I'm using a fairly new (about 2 months old) SIM card.
  7. #7  
    Nivek's Avatar

    Posts
    4 Posts
    ROM
    Stock

    Default

    This is what you do. got to setting>wireless & networks>mobile networks>access point names>then check t-mobile data. Not TelKila. Hope this helps
  8. #8  

    Default

    Quote Originally Posted by Nivek View Post
    This is what you do. got to setting>wireless & networks>mobile networks>access point names>then check t-mobile data. Not TelKila. Hope this helps
    Thanks!!! I spent 45 minutes chatting with cc last night and they didn't even know this!
  9. #9  
    Nivek's Avatar

    Posts
    4 Posts
    ROM
    Stock

    Default

    ^No problem
  10. #10  

    Default

    hi, i tried that but it automatically goes back to the telkila option. any other suggestions? ahhh my damn n900 didnt have picture messaging so i had to download a crappy app that sucked, now my mt4g is giving me picture messaging problems! argh
  11. #11  

    Default

    Quote Originally Posted by mysteriouscamaro View Post
    hi, i tried that but it automatically goes back to the telkila option. any other suggestions? ahhh my damn n900 didnt have picture messaging so i had to download a crappy app that sucked, now my mt4g is giving me picture messaging problems! argh
    If it won't let you choose tmobile data click on the menu button, and choose reset to default. The apn's should reset and you should be able to choose it, and it stick.

    Hope this helps
  12. #12  

    Default

    Quote Originally Posted by Nivek View Post
    This is what you do. got to setting>wireless & networks>mobile networks>access point names>then check t-mobile data. Not TelKila. Hope this helps
    thanks alot! i havent been able to send mms messages for a week!
  13. #13  

    Default

    What if T-Mobile data isn't even an option? Should I make a new one and look up the settings?
  14. #14  

    Default Re: Problems with myTouch 4G

    Hi, Please help if u can! I bought t mobile my touch 4g phone, it works on walmart family mobile sim card sim card brand new also, after using phone for couple minuts it shows Process com.android.phone not responding and optionts wait or quit, whateever u will push, the qwert keyboard stop working, only making sound but nothing typing! Does anybody know y??? Thank you and have a great day!
  15. #15  

    Default Re: Problems with myTouch 4G

    ik the feeling. After five months of tourture mine is doing the same thing. Tech support aint worth sh*t (reseting it did very little maybe u should try it) . and the sales repps just want $$$$$. I've contacted HTC about the problem and they pretty much threw my to the wolves. I think its time we get a new android device.
  16. #16  

    Default Re: Problems with myTouch 4G

    my problem is with MMS as well. unable to recieve or send. but it was working a while back. BEFORE i cleared out some data and cached in the "all applications" tab in settings. i've cleared out almost all the data and i'm pretty sure thats what's leading to my inability to send MMS and whatnot. i was wondering if any1 has a fix for this? i tried changing and fixing the APN's and reseting to default and such. i called customer service they told me the exact same thing but nothing was helping.

    HELP. and now every time someone sends me an MMS it tries to download it randomly from time to time causing a wild chain of notifications stating "generic network failure" or "unable to send after many attempts" =(
  17. #17  

    Default Re: Problems with myTouch 4G

    My phone is not working properly. It will turn itself off without the process. The screen will go out and it won't turn on unless I take the battery out.
  18. #18  

    Default Re: Problems with myTouch 4G

    i cannot set my network into 4G. Please help me.
  19. #19  

    Default Re: Problems with myTouch 4G

    Quote Originally Posted by stephenmartha975 View Post
    i cannot set my network into 4G. Please help me.
  20. #20  

    Default Re: Problems with myTouch 4G

    Hello.. Im having a problem with my HTC mytouch 4G glacier. Out of know where one day the screen on my phone went dark and i could do nothing after that.. I took out the battery and put it back in to see if that would help.. When i hit the power button to turn it on the opening screen along with a vibrate came on and then proceeded to the green circle and the my on it.. It stood on that screen for a long while.. longer that usual.. Then it went back to the dark screen again but every now and then that MY screen would pop on and then off again.. I then plugged in the charger and the charging light turned on and then went off.. I DONT KNOW WHATS GOING ON WITH MY PHONE!!! If anyone can give me some advice or know how to solve this problem i will greatly appreciate it.. thanks..

Posting Permissions

B