Results 1 to 16 of 16
  1. Thread Author  Thread Author    #1  

    Default Wi-Fi Won't connect

    I'm still sort of new to Android...with getting a Fascinate in October. Had no issues with that phone, but couldn't afford Verizon's service anymore, so I switched to T-Mobile a few weeks ago. At first I got the Nexus S and that phone wouldn't connect to any Wi-Fi...my home router, public open routers...anything. I hated the phone completely so I traded it out for the MT4G today and the Wi-Fi won't connect on this one either. I have power cycled the router in my home, my TV, laptop, and wife's BlackBerry still connects. I have been to 4 different public Wi-Fi spots today to test this and it won't work. It continuously says "connecting" for a while and then disconnects. This is the same thing that the Nexus S did. Can anyone help???
  2. #2  
    Kevin O'Quinn's Avatar
    AC Team Emeritus

    Posts
    8,720 Posts
    Global Posts
    8,897 Global Posts
    ROM
    Stock

    Default

    What kind of hotspots are they? Some aren't free.

    As for your home one is it secured? Did you enter the correct password?

    I've had no problems connecting with my phone.

    Sent from my myTouch 4G
    Kevin F.I.M.T.K. O'Quinn Esq.
  3. Thread Author  Thread Author    #3  

    Default

    Quote Originally Posted by iamlilysdad View Post
    What kind of hotspots are they? Some aren't free.

    As for your home one is it secured? Did you enter the correct password?

    I've had no problems connecting with my phone.

    Sent from my myTouch 4G
    I've been to Starbucks (free) Panera (free) and my business center at my apartment (open network). At home the password was entered in correctly, several times...Like I said, all my other devices have connected at these sames spots until I got the Nexus S and MT4G
  4. #4  

    Default

    Sounds strange... did you bring it into a T-Mobile store and have them try to connect to one of their wireless routers? They should have one at the store to test device with.
  5. #5  
    danperde's Avatar
    Not quite a noob

    Posts
    275 Posts
    ROM
    Synergy r64

    Default

    Quote Originally Posted by naitbait1 View Post
    I have been to 4 different public Wi-Fi spots today to test this and it won't work. It continuously says "connecting" for a while and then disconnects.
    I had the same issue with the first myTouch 4G that I got. It wouldn't connect for hours and when it would finally connect it would drop the connection in 10-15 seconds. My wife's (I got the 2 for 1 deal) it connected instantly and no dropped connections. I tested mine on different WI-FI networks with the same result. So....next day I exchanged the phone in the store and the new one works perfect. Instant connection, no dropped calls and clear call quality. I assume you got a bad unit like I did. My advice is to go to T-Mobile store and exchange yours too.
  6. #6  
    Droid800's Avatar
    Banned

    Posts
    3,692 Posts
    Global Posts
    3,706 Global Posts
    ROM
    Stock

    Default

    Mine is doing this too. I have a MT4G, Nexus S, and iPod Touch, and the last two connect without issues and the mytouch won't do it.
  7. #7  
    Kevin O'Quinn's Avatar
    AC Team Emeritus

    Posts
    8,720 Posts
    Global Posts
    8,897 Global Posts
    ROM
    Stock

    Default

    sounds like they might have an issue with the wifi radio in the phone on some of them. you might wanna try to get it exchanged if you can. I think you said you bought it outright from craigslist or something right?
    Kevin F.I.M.T.K. O'Quinn Esq.
  8. #8  
    Droid800's Avatar
    Banned

    Posts
    3,692 Posts
    Global Posts
    3,706 Global Posts
    ROM
    Stock

    Default

    Quote Originally Posted by iamlilysdad View Post
    sounds like they might have an issue with the wifi radio in the phone on some of them. you might wanna try to get it exchanged if you can. I think you said you bought it outright from craigslist or something right?
    T-mobile. But it started randomly working tonight. I had it hooked up to the Nexus S' wireless hotspot, and it started working fine. (after a bit of finagling) When I disconnected it from the Nexus it picked up my home wireless just fine. Maybe it just needed its WiFi cherry popped?
  9. #9  
    danperde's Avatar
    Not quite a noob

    Posts
    275 Posts
    ROM
    Synergy r64

    Default

    Quote Originally Posted by Droid800 View Post
    Maybe it just needed its WiFi cherry popped?
    That's the funniest thing ever. I can't live with the thought that my WiFi will maybe connect or maybe not (since I have no service in the bunker that I call home ). If you got it from T-mobile, why not change it with a good unit? Like I said, I had no issues doing so.
  10. #10  
    Droid800's Avatar
    Banned

    Posts
    3,692 Posts
    Global Posts
    3,706 Global Posts
    ROM
    Stock

    Default

    ...and now its not working again. Very temperamental.
  11. #11  
    Kevin O'Quinn's Avatar
    AC Team Emeritus

    Posts
    8,720 Posts
    Global Posts
    8,897 Global Posts
    ROM
    Stock

    Default

    Quote Originally Posted by Droid800 View Post
    ...and now its not working again. Very temperamental.
    Exchange it before it's too late.

    Sent from my myTouch 4G
    Kevin F.I.M.T.K. O'Quinn Esq.
  12. #12  

    Default Re: Wi-Fi Won't connect

    HTC Sensation: I have to unplug power to my wifi and plug it back in then it reconnects. Every time I am out of range it will not reconnect when back in range. Have checked my wifi router and all settings are fine. both my laptops have no problem reconnection everytime. ????? Dont think its a phone exchange issue.
  13. #13  

    Smile Re: Wi-Fi Won't connect

    i also got this same problem but i got the answer
    simply take out your phone battery and hold down power button for about 20 second
    put the battery back on, turn on the phone connect to your wifi again waaalaaa you got your internet
  14. #14  

    Default Re: Wi-Fi Won't connect

    A couple of thoughts from a fellow MT4G user. First make sure your router is set to a compatible security mode. I am using WPA-Personal (WPA2 Only) with AES Cipher type.
    For wi-fi calling it is assumed you have no (zero) signal. One bar will still have you using the network even with wi-fi calling turned on and so in a fringe area you have to go into settings>call>use internet calling and set it to "For All calls". Just remember to reset it to "only for internet calls" before returning to a coverage area.
  15. #15  

    Default Re: Wi-Fi Won't connect

    I've got a similar problem, in my Xperia Play (r800i). I used the phone at my work, in the AP for employees. For some weeks, it worked! now the phone doesn't even recognize the.router. It works in open and secure routers like the one in my home, and routers of nearby buildings, and even when i'm in the same room as the router, it doesn't show on the AP List. Any ideas'
  16. #16  
    belvey's Avatar

    Posts
    1 Posts
    ROM
    Android 2.2

    Default Re: Wi-Fi Won't connect

    I am brand new to android having just purchased my first phone a huawei X1. I am desperate to get it connected but it won't be hooked up until next week. I assumed until then I could use cafe wifi spots however after trying one today and obtaining the password from the staff the device would not connect.It picked up the open network but continually showed connecting... disabled... disconnected...connecting etc.

    Do you have to have the phone connected to a cellular network in order to access wifi or should I try a different cafe or software? I have several wifi programs installed... is it possible they are conflicting?

    Any advice appreciated.

    Regards

    Byron

Tags for this Thread

Posting Permissions

B