04-03-2017 02:30 PM
37 12
tools
  1. ajua's Avatar
    Suddenly, the phone's clock started showing a time that was offset by two hours for my local time.

    I deselected automatic time zone and auto date/time and set them manually. If I return it to automatic, it will show my precise location but the timezone and local time would be offset by two hours (earlier, not later).

    Currently, I have auto date/time and selected my time zone automatically. It shows the right date and time but the screen showing my current position still shows the clock two hours behind.

    Has anyone experienced this?
    06-26-2013 10:35 AM
  2. Dogs OfWar's Avatar
    Not on this phone, but over the years on various phones that's always been a problem that comes up from time to time. Sometimes a reboot fixes it, sometimes setting auto off then on fixes it and sometimes just the passage of time.
    SAURABH SHARMA9 likes this.
    06-26-2013 10:37 AM
  3. erintiransom's Avatar
    My HTC One back at home in Europe had the right time. I'm in the US now, in Mountain Time, the time zone is right (Mountain) but the time is off by one hour (it's 12:38 right now but my phone says 11:38). It seems like it's not taking into account the summer savings change.

    I updated to Jelly Bean 4.2.2 while in the US, a few days ago. I would have sworn that before the update the time here in the US was right, both when I flew through eastern time and after I landed in mountain time -it got the right time either from the cell tower -I'm not data roaming- or whenever I connected to a WiFi network.

    Actually I just restarted my phone and now it's showing the right time. The weird thing is that I have restarted it several times since the update. Well, whatever, I don't need help anymore, but I guess it's good to have this documented. I just remembered that yesterday my phone's battery died on me, I don't see how that could affect anything but just in case, I'm giving all the info I remember.

    Another funny thing is that Google Authenticator worked, being one hour off. Very funny...
    07-30-2013 01:46 PM
  4. Korfy's Avatar
    Exactly the same problem over here. All of a sudden the phone detects that I am in Campinas,Brasil.

    Have you found the solution yet?

    - - - Updated - - -

    Exactly the same problem over here. All of a sudden the phone detects that I am in Campinas,Brasil.

    Have you found the solution yet?
    08-17-2013 10:19 AM
  5. ajua's Avatar
    Exactly the same problem over here. All of a sudden the phone detects that I am in Campinas,Brasil.

    Have you found the solution yet?
    I have tried several times to select my time zone manually and then checkinh/unchecking to get it automatically but the problem is the same. The time zone and location are detected well but the clock is two hour behind.

    I set it manually and didn't bother again. I'm still on 4.1.2. When the 4.2.2 OTA arrives for US unlocked/dev editions I will see if it's corrected or not.
    08-17-2013 05:51 PM
  6. Korfy's Avatar
    This is happening to me on 4.2.2. It's pretty annoying
    08-18-2013 08:02 AM
  7. torrentialrain3's Avatar
    I was having this same problem this evening after doing a fresh install of my favorite ROM. The solution that I found was to turn off Wi-Fi and ensure the phone was connected to a cell tower's data. It seems that when connected to Wi-Fi, the phone tries to use not only the location from that signal, but something to determine time (which to my knowledge, only (a rough estimation of) location can be gathered from a Wi-Fi signal). After turning my phone's Wi-Fi off, I had the phone connect to my network, then toggled the auto settings for date/time and it updated correctly. Hope this helps you all!
    08-20-2013 01:42 AM
  8. ajua's Avatar
    I was having this same problem this evening after doing a fresh install of my favorite ROM. The solution that I found was to turn off Wi-Fi and ensure the phone was connected to a cell tower's data. It seems that when connected to Wi-Fi, the phone tries to use not only the location from that signal, but something to determine time (which to my knowledge, only (a rough estimation of) location can be gathered from a Wi-Fi signal). After turning my phone's Wi-Fi off, I had the phone connect to my network, then toggled the auto settings for date/time and it updated correctly. Hope this helps you all!
    I'm going to try it later. Will post if it works for me. Thanks for the suggestion.
    08-21-2013 08:57 PM
  9. jfs101's Avatar
    This is happening to me as well with an - 8 hours difference. I think it might be carrier related, as this occurred to other phones on my network around the same time I got the glitch.

    Posted via Android Central App
    08-21-2013 09:13 PM
  10. ajua's Avatar
    None of my friends with other phones are experiencing this issue. It might be a bug in Sense or Google services/apps on the One.
    08-23-2013 12:02 AM
  11. mashsatheesh's Avatar
    I'm having Galaxy S4 zoom, i'm experiencing this time zone problem. its a 4.2.2... if i put bu screen in sleep mode then the time runs very slowly.. if u can help me find a solution, plz do let me know.. i tried doing disabling wifi and auto update thro netwrok, none works,, and all sort of combinations were also tried, no improvment. tried updating the software too..
    11-05-2013 04:51 AM
  12. Dave Clark's Avatar
    I'm having Galaxy S4 zoom, i'm experiencing this time zone problem. its a 4.2.2... if i put bu screen in sleep mode then the time runs very slowly.. if u can help me find a solution, plz do let me know.. i tried doing disabling wifi and auto update thro netwrok, none works,, and all sort of combinations were also tried, no improvment. tried updating the software too..
    Wrong thread bro, try the Samsung forums. This is for the HTC One.
    11-05-2013 05:14 AM
  13. lars_nilsson's Avatar
    Same issue here, suddenly my phone says that I am in Adelaide, hours difference from Sydney where I actually am.
    11-26-2013 04:45 AM
  14. Lynn Cee's Avatar
    Same problem with my Samsung "smartie" -- even using Time Synch app from Google's Playstore. Haven't yet been able to get to the root of this issue, though I see it's a fairly common problem, particularly with Samsungs.
    I've outgrown this phone but I probably won't get another Samsung until this persistent issue is resolved. After all, if it weren't such a common problem, there would be no clock synch/fix apps for it; right? ...
    02-07-2014 11:28 PM
  15. Hubert Auguste Evrard's Avatar
    Got a Samsung S4; simply go to 'settings' / 'More' / 'date & Time' then flag 'automatic timezone' on. Hope it helps.
    Warren Kellie likes this.
    02-11-2014 02:27 AM
  16. cgardnervt's Avatar
    Got a Samsung S4; simply go to 'settings' / 'More' / 'date & Time' then flag 'automatic timezone' on. Hope it helps.
    Do that with a reboot and it should pick it right up off of the towers/network.
    AGorordo1948 likes this.
    02-11-2014 07:31 AM
  17. Humberto Orozco Cervantes's Avatar
    Thanks Hubert and cgardnervt, that solved my problem:
    1.- Got a Samsung S4; simply go to 'settings' / 'More' / 'date & Time' then flag 'automatic timezone' on. Hope it helps. (I actually disabled both: 'automatic timezone' and 'Automatic date and hour', then I defined the hour and selected time zone. Then immediately I restarted the device)
    2.- Reboot device and it should pick it right up off of the towers/network.

    After I rebooted my Samsung S4, I checked again: 'settings' / 'More' / 'date & Time', both: 'automatic timezone' and 'Automatic date and hour' was enabled, but the right hour was there.

    Thanks guys! I hope everybody resolve this issue.
    03-19-2014 03:49 AM
  18. SnowRunner99's Avatar
    Thanx it worked.

    It seems the cause of my probblem were deselected options options on the menu you mentioned ( "Settings->More->Date&Time.... ). Like Network provided options or...

    Guess it came to this situation when using Samsung S4 on some running/trek course in the rain and while trying to make photo seems many things happened.

    Thanx for the reference.
    AGorordo1948 likes this.
    04-28-2014 06:17 AM
  19. Warren Kellie's Avatar
    Got a Samsung S4; simply go to 'settings' / 'More' / 'date & Time' then flag 'automatic timezone' on. Hope it helps.
    You are a super star lol this was driving me cray cray.!
    09-30-2014 07:48 AM
  20. jlesow's Avatar
    My Moto G phone defines Eastern time as GMT-4, which is wrong. All the time zones are defined an hour off.

    This is in settings, so there's no way to change it.
    11-01-2014 07:55 AM
  21. jlesow's Avatar
    Embarrassed to say that I finally found the automatic time setting. I can only wonder why it was off by default.
    11-01-2014 08:11 PM
  22. apiratelooksatsixty's Avatar
    Suddenly, the phone's clock started showing a time that was offset by two hours for my local time.

    I deselected automatic time zone and auto date/time and set them manually. If I return it to automatic, it will show my precise location but the timezone and local time would be offset by two hours (earlier, not later).

    Currently, I have auto date/time and selected my time zone automatically. It shows the right date and time but the screen showing my current position still shows the clock two hours behind.

    Has anyone experienced this?
    03-01-2015 03:55 PM
  23. Jennifer Schlichting's Avatar
    Ever since the time change my clock has the right time but a 12 hours off so when its pm it says am, I read some of the other posts and went to my settings; time and date, I seen that my auto clock and time zone boxes where not checked, once I checked them the correct time displayed, I hope that helps.....
    Suddenly, the phone's clock started showing a time that was offset by two hours for my local time.

    I deselected automatic time zone and auto date/time and set them manually. If I return it to automatic, it will show my precise location but the timezone and local time would be offset by two hours (earlier, not later).

    Currently, I have auto date/time and selected my time zone automatically. It shows the right date and time but the screen showing my current position still shows the clock two hours behind.

    Has anyone experienced this?
    03-17-2015 05:44 PM
  24. Mark Elfering's Avatar
    Similar problem here. Both my dad & I have Motorola Droid Turbos - I just got mine yesterday. Both are saying we're in the Alaskan Time Zone, when set to Automatic Time Zone, even though we're in NE Oregon - located closer to the Mountain Zone than Alaskan. I've tried all suggestions, but it won't stay on the correct zone (Pacific) for more than a moment unless I set it manually. Ugh.
    06-23-2015 01:42 PM
  25. Cole Blakley's Avatar
    mine does the same thing and i have already factory reset and nothing has fixed not to mention the ''set time'' has something wrong with it because every time i try to change it to the correct time and push done the old time still stays there as if i didn't do anything. and the "Automatic date & time" is completely jacked. dont know what happened but just went wrong. I have the "DROID RAZR MAXX HD" ,"Android version 4.4.2" plz help.
    07-08-2015 10:58 AM
37 12

Similar Threads

  1. Clock shows wrong time zone on Nexus 7
    By Lesgreen in forum Google Nexus 7 Tablet (2012)
    Replies: 20
    Last Post: 08-01-2015, 08:50 AM
  2. Why no automatic time zone setting
    By FSchmitthammer in forum Samsung Galaxy Note 10.1
    Replies: 3
    Last Post: 01-27-2013, 11:26 PM
  3. Automatic Date/Time zone
    By eribac in forum HTC EVO 4G
    Replies: 15
    Last Post: 06-25-2011, 06:07 AM
  4. Travelling between time zones and calendar
    By spoid in forum General Help and How To
    Replies: 5
    Last Post: 03-24-2010, 10:34 AM
  5. HTC Eris clock is set to different time zone
    By jliller in forum HTC Droid Eris
    Replies: 4
    Last Post: 12-27-2009, 03:23 PM
LINK TO POST COPIED TO CLIPBOARD