1. Grizzly_Atoms's Avatar
    Hi, I am having a recurring issue with my One. At work we recently switched over from an old AT&T router to a new TP-Link router. The network SSID is hidden and it uses MAC filtering. I never had an issue on the same setup on the AT&T router, but now every single time I lock my phone it drops the connection to wifi. If I then reset my phone OR the router it logs back on normally. I have deleted and re-registered my MAC address but the same thing occurs over and over.

    I also have my iPad on the network and it has zero issues. Any ideas or can somebody suggest a fix?

    Thanks!
    08-23-2013 10:46 PM
  2. Grizzly_Atoms's Avatar
    220 views and nobody knows? C'mon tech gurus help me out!
    08-24-2013 03:46 PM
  3. FishenFool's Avatar
    Don't know about the One specifically, but on my GS3 there is a setting in WiFi that tells it not to turn WiFi off while sleeping.

    Sent from my SAMSUNG-SGH-I747 using AC Forums mobile app
    Grizzly_Atoms likes this.
    08-24-2013 03:59 PM
  4. Grizzly_Atoms's Avatar
    Don't know about the One specifically, but on my GS3 there is a setting in WiFi that tells it not to turn WiFi off while sleeping.

    Sent from my SAMSUNG-SGH-I747 using AC Forums mobile app
    Thanks for the tip, I found this setting and will give it a try.
    08-24-2013 07:26 PM
  5. Grizzly_Atoms's Avatar
    So the issue is SSID related. If the SSID is broadcasting my phone works just fine. If the SSID is hidden my phone drops the connection the second I turn off the screen. A friend in my office has a Sprint HTC One and it has the exact same issue. Very frustrating.
    08-25-2013 02:14 AM
  6. karn101's Avatar
    Did you try unchecking 'Optimize Wi-Fi'? Maybe that'll help?
    Grizzly_Atoms likes this.
    08-25-2013 04:21 AM
  7. Grizzly_Atoms's Avatar
    Did you try unchecking 'Optimize Wi-Fi'? Maybe that'll help?
    Yes it was unchecked to start, but on or off made no difference.
    08-25-2013 11:12 PM
  8. Grizzly_Atoms's Avatar
    Here is my solution:

    1. Install HiddenSSID Enabler from the Android Marketplace
    2. Enable your WiFi network to broadcast its SSID temporarily
    3. Turn on WiFi on your Android device and ensure you connect to your network successfully
    4. On your Android device, open the HiddenSSID Enabler app
    5. Enter your network/SSID name and click the Enable Hidden SSID button. There is no feedback given that anything happened. Dont panic.
    6. Turn WiFi off for your Android device
    7. Disable SSID broadcasting on your router again
    8. Turn on WiFi on your Android device and it should now connect to the hidden network
    08-27-2013 10:46 AM

Similar Threads

  1. Unable to dial in for conference call
    By Maruthi3113 in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 5
    Last Post: 02-17-2014, 08:16 AM
  2. Game lag on tab 3 8.0
    By meffie in forum Samsung Galaxy Tab 3
    Replies: 8
    Last Post: 09-08-2013, 11:04 PM
  3. Video aspect ratio problem since upgrading to android 4.3
    By David Reculver in forum Google Nexus 7 Tablet (2013)
    Replies: 5
    Last Post: 08-26-2013, 03:30 PM
  4. Switched to Verizon for Maxx
    By David Manter in forum Motorola Droid MAXX
    Replies: 8
    Last Post: 08-25-2013, 09:46 AM
  5. Storing subscribed magazines on microSD
    By Melvyn Moy in forum Barnes & Noble Nook HD / HD+
    Replies: 0
    Last Post: 08-23-2013, 09:38 PM
LINK TO POST COPIED TO CLIPBOARD