06-20-2015 05:43 AM
46 12
tools
  1. Eisenhorne's Avatar
    I am using an HTC One with Rogers. Ever since the KitKat 4.4 upgrade, my WiFi doesn't work properly. I am not able to connect to WiFi access points. Attempting to connect to any WiFi network will give me the error "Failed to connect to network". I cannot turn off the WiFi either. The button will grey out for a while, and then remain in the On state. Rebooting the phone will give me back control of WiFi for a while, but it will soon not work again.

    Also, since the 4.3 upgrade, my Google Text-to-Speech will continuously crash when I use Google Maps for navigation. Once it crashes, Maps will not be able to read out street names. I was hoping the 4.4 upgrade would fix this issue, but this is still broken. My wife's HTC One has the exact same issue.
    02-04-2014 10:01 AM
  2. Eisenhorne's Avatar
    Nobody has any wifi or TTS problems on their One?
    02-11-2014 07:29 AM
  3. cgardnervt's Avatar
    Nobody has any wifi or TTS problems on their One?
    I do not have the update yet on mine but get it a few days to settle down. If it does not change then I'd do a hard reset. Sometimes its your only option.
    02-11-2014 07:36 AM
  4. Nikhil Yalamanchi's Avatar
    hey there,

    I also carry an international version of HTC one and also facing similar problems. My wifi doesn't connect on my home network all the time and it keeps toggling on and off. Sometimes it works but sometime it doesn't , i cant turn it off and turn it on with 100 % success rate. This problem started 2 days back but not right immediately after the KITKAT update.
    02-16-2014 06:55 PM
  5. Tim Wiseman's Avatar
    I just updated to 4.4 and finally got the google apps to load . everything was fine till today , Now my wifi wont turn on . I can't tether either . The only other issue I have is that I can't send mms . Dont know if that has been since update yesterday or if its related to wifi . I have all other connectivity.. I am on a warp sequent
    02-17-2014 03:14 AM
  6. Nikhil Yalamanchi's Avatar
    i am getting frustrated right now . it just turns for brief 2 mins on boot up and then acts like a *****.
    i have done via htc support
    1. clearing the cache through recovery
    2. factory reset

    it still has the problems .
    02-17-2014 04:14 PM
  7. Kilroy13's Avatar
    My WiFi comes on by itself all the time! This only started after kitkat!

    Sent from my HTCONE using Tapatalk
    02-17-2014 04:24 PM
  8. Eisenhorne's Avatar
    Never should've updated to KitKat so early! I was perfectly happy with Jelly Bean.
    02-18-2014 07:10 AM
  9. Nikhil Yalamanchi's Avatar
    bump

    any progress? my phone is completely useless now
    02-21-2014 12:16 AM
  10. Hanana's Avatar
    Got the same problem here. Cant connect on my home wi-fi....help!
    02-22-2014 12:19 AM
  11. Nikhil Yalamanchi's Avatar
    Got the same problem here. Cant connect on my home wi-fi....help!
    just the home wifi ? can u switch on/off the wifi ?
    02-22-2014 12:21 AM
  12. Hanana's Avatar
    My problem had just solved!

    TRY this:
    WiFi - then 3 dots - WiFi Direct - 3 dots - Rename Device - HTC One.

    Hope it helps.
    02-22-2014 05:35 AM
  13. Nikhil Yalamanchi's Avatar
    i cant even click on the wifi direct
    02-22-2014 05:43 PM
  14. Belhade's Avatar
    I've also been having problems with my WiFi the post week or so, though I only loaded Kit Kat yesterday which didn't solve my problem.

    My phone will see and connect to Wi-Fi but show no signal and very little data throughput. If I'm sitting next to my wireless router it works with full bars but as soon as I leave the room it goes to no bars. Several other devices work fine anywhere in the house - my wife's iPhones, the Kindle, my Galaxy S3 from work, etc. My phone will see and connect to any wireless point, including Optimum and community Wi-Fis, but with no signal strength. It's quite infuriating. I'm afraid I'll have to send it in for a bad antenna or something.

    Posted via Android Central App
    02-22-2014 08:12 PM
  15. Belhade's Avatar
    I am using an HTC One with Rogers. Ever since the KitKat 4.4 upgrade, my WiFi doesn't work properly. I am not able to connect to WiFi access points. Attempting to connect to any WiFi network will give me the error "Failed to connect to network". I cannot turn off the WiFi either. The button will grey out for a while, and then remain in the On state. Rebooting the phone will give me back control of WiFi for a while, but it will soon not work again.
    Also, my phone had this exact issue for a few months but had been working properly until a week ago or so. I still don't know what was fixing or causing these issues.

    Posted via Android Central App
    02-22-2014 08:16 PM
  16. Aman Kalra's Avatar
    That solved my problem too....thank you so much.
    02-23-2014 01:09 PM
  17. James Jetton1's Avatar
    Thanks,
    Renaming the device to HTC One with your directions cured my problem. Great help, much appreciated.
    02-23-2014 11:03 PM
  18. Marieke de Witte's Avatar
    Wow!!

    I had exactly the same problem and due to the great tip/tutorial to rename the Wifi-Direct to HTC One, my WIFI WORKS!!!!! SOOO HAPPY!!

    thx!
    02-24-2014 04:53 PM
  19. Kilroy13's Avatar
    My WiFi direct is greyed out and I can't open it

    Sent from my HTCONE using Tapatalk
    02-25-2014 10:06 AM
  20. Kilroy13's Avatar
    Never mind, had to turn WiFi on first!

    Sent from my HTCONE using Tapatalk
    02-25-2014 10:08 AM
  21. mikeoc's Avatar
    I had this problem today and I only bought the phone (HTC One) this morning - worked fine, then 4.4 update magically appeared, of course I installed it, and have spent all afternoon trying to get the ohone to connect to wifi. Renaming the phone name in Wifi Direct didn't work for me, but a factory reset did. In fact, the phone has reset to 4.4.2, so I still have the update, but it wifi connection is now working as it should? Weird!
    02-25-2014 10:45 AM
  22. nrgreenwood's Avatar
    I'm with Vodafone in the UK and couldn't connect to WiFi after updating to Kit Kat but renaming to HTC One worked for me. Many thanks
    02-26-2014 02:12 PM
  23. sistinaSmiles's Avatar
    I am still having this problem after the kitkat update.

    since the update I have been unable to connect to my home network through wifi. it continually says: Saved, secured with wpa, then: connecting, then: Saved, secured with wpa. I have a laptop, Iphone4, ipad, and samsung tablet that all connect to the wifi just fine. I have power cycled the router. I have changed the passkey and retried, I've switched to no security - it still wouldn't connect to my wifi - it just says: saved. I can connect just fine to the wifi at the coffee shop, and to my corporate wifi which also requires a passkey. I've restarted the device with all kinds of combinations of forgeting, turning off wifi, etc. I've also done two factory resets in an attempt to reset the wifi. I'm running out of ideas. any advice would be appreciated.
    02-26-2014 06:32 PM
  24. Chris32v's Avatar
    I'm also having issues. No WiFi at all and I also noticed when I get a text the ring tone is all crackly. My battery also doesn't last as long as before. Major disappointment! I really wished I would have googled any kitkat issues before hitting update. It's so silly how well known this seems to be yet when you call HTC or tmobile they walk you through completely useless and time consuming steps that obviously do nothing. After resetting the phone my WiFi came back...for an hour then it was back to nothing. Renaming it did nothing either :/
    02-26-2014 07:51 PM
  25. kygator13's Avatar
    I was having the same issue, just started today. The rename of WiFi direct to HTC One worked for me as well, thanks.

    Posted via Android Central App with the HTC One
    02-26-2014 09:14 PM
46 12

Similar Threads

  1. sony xperia browser closes randomly and returns to home screen
    By Karen Ward in forum Sony Xperia Series
    Replies: 5
    Last Post: 08-04-2014, 07:13 PM
  2. KITKAT update?
    By sDPLP1904 in forum Verizon HTC One
    Replies: 26
    Last Post: 02-11-2014, 12:47 PM
  3. Replies: 49
    Last Post: 02-11-2014, 04:07 AM
  4. Sprint Samsung Galaxy 3s keeps shutting off after a few minutes??
    By Xander Itsraining Waffles in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 02-04-2014, 01:17 PM
  5. Odd sharing problem
    By Codger1212 in forum Motorola Droid MAXX
    Replies: 3
    Last Post: 02-04-2014, 10:57 AM
LINK TO POST COPIED TO CLIPBOARD