Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
  1. Thread Author  Thread Author    #1  

    Default wifi

    I have wifi turned off. Optimization off. everything off yet the phone still turns on wifi. What's going on ?
  2. #2  

    Default Re: wifi

    I know there is a setting in the Wi-Fi section that will automatically turn on and use Wi-Fi when the mobile network is spotty. Have you turned that off?

    Posted via Android Central App
    Quote Originally Posted by Ccota08 View Post
    I keep reading your posts in Bender's voice and it's amazing.
  3. #3  

    Default Re: wifi

    If you're with Sprint it could be their connections optimizer. You can go into phone settings and turn it off.

    Sent from my Nexus 5 using Tapatalk 2
  4. #4  

    Default Re: wifi

    What Skyway said. Plus, if you have gives an app (like maps or some location oriented thing) permission to turn on WiFi, that could be it.
  5. Thread Author  Thread Author    #5  

    Default Re: wifi

    Only thing on under advanced wifi setting is network notifications
  6. #6  

    Default Re: wifi

    If you have the at&t version make sure you have the smart wifi turned off or disabled

    Posted via Android Central App
  7. #7  

    Default Re: wifi

    Quote Originally Posted by RRHMJ23 View Post
    Only thing on under advanced wifi setting is network notifications
    Really? What carrier are you on? On my AT&T m8 I have a boatload of options. It also tells me my mac address and ip address in there

    Posted via Android Central App
    Quote Originally Posted by Ccota08 View Post
    I keep reading your posts in Bender's voice and it's amazing.
  8. Thread Author  Thread Author    #8  

    Default Re: wifi

    Im on Sprint
  9. Thread Author  Thread Author    #9  

    Default Re: wifi

    Im still having this problem. The wifi is still turning on
  10. #10  

    Default Re: wifi

    Quote Originally Posted by RRHMJ23 View Post
    Im still having this problem. The wifi is still turning on
    Did you turn off the Connections Optimizer in system settings?

    Edit to add: It's on all Sprint phones, but oops if this is a Nexus 5 forum thread, it wouldn't be on a Nexus 5 if you bought it from Google, I don't think. But Sprint may have sent an OTA update to keep your phone turning on WiFi?

    Sent from my Nexus 5 using Tapatalk 2
  11. Thread Author  Thread Author    #11  

    Default Re: wifi

    Yes. Wifi optimizer is turned off. Everything is turned off. Still comes on
  12. #12  

    Default Re: wifi

    Quote Originally Posted by RRHMJ23 View Post
    Yes. Wifi optimizer is turned off. Everything is turned off. Still comes on
    Hmm, they may have done something new because people were turning off the connections optimizer. I'd check over on the Sprint forums, they may be talking about it there. Good luck.

    Edit to add: The same thing happened on this phone when I had it on Boost Mobile, but I assumed that I couldn't disable the connections optimizer because I was on prepaid and not Sprint proper. Since the data was unusable on BM, I just decided to forget about it. But yes, it really is annoying that it couldn't be turned off.

    Sent from my LG-LG870 using Tapatalk 2
  13. Thread Author  Thread Author    #13  

    Default Re: wifi

    Anybody have ideas? Anybody else have this problem?
  14. #14  

    Default Re: wifi

    I've been having the same issue with my Sprint HTC One since the last update and have been searching forever for an answer until someone in here mentioned something that fixed it. You said Wi-Fi Optimization is off - I assume that's under the wifi settings? If you go into Mobile Data > Automatic Connections. Uncheck Wifi Optimizer. When I went back into the setting I got a long message about how it'll automatically connect to the wifi if there is a weak mobile data signal. This worked for me, and again I'm also on Sprint, so hopefully it'll work for you too.
  15. #15  

    Default Re: wifi

    Quote Originally Posted by mrsmumbles View Post
    If you're with Sprint it could be their connections optimizer. You can go into phone settings and turn it off.

    Sent from my Nexus 5 using Tapatalk 2
    This. If you're on Sprint it is definitely their connection optimizer.

    Sent from my T-Mobile Note 3 using AC Forums.
    Thanked by:
  16. #16  

    Default Re: wifi

    Quote Originally Posted by Almeuit View Post
    This. If you're on Sprint it is definitely their connection optimizer.

    Sent from my T-Mobile Note 3 using AC Forums.
    And when I was on Boost Mobile, the thing won't stay turned off. I thought it might be different though, for postpaid Sprint subscribers. :/

    Sent from my Nexus 5 using Tapatalk 2
  17. Thread Author  Thread Author    #17  

    Default Re: wifi

    Thank you. That worked. I didn't know there was a optimizer under the Mobile data settings. I only unchecked the one under Wifi advanced setting
    Quote Originally Posted by jbarker208 View Post
    I've been having the same issue with my Sprint HTC One since the last update and have been searching forever for an answer until someone in here mentioned something that fixed it. You said Wi-Fi Optimization is off - I assume that's under the wifi settings? If you go into Mobile Data > Automatic Connections. Uncheck Wifi Optimizer. When I went back into the setting I got a long message about how it'll automatically connect to the wifi if there is a weak mobile data signal. This worked for me, and again I'm also on Sprint, so hopefully it'll work for you too.

Similar Threads

  1. Verizon LG G2: WiFi Problems
    By InboundPotato in forum Verizon LG G2
    Replies: 11
    Last Post: 08-17-2014, 10:17 PM
  2. Brand new Galaxy S4 not auto connecting to Wifi
    By Joedm45 in forum Samsung Galaxy S4
    Replies: 12
    Last Post: 07-31-2014, 12:07 AM
  3. Wifi- keep deep sleep at night and on during selected day hours
    By BJB1 in forum Android 4.0 Ice Cream Sandwich
    Replies: 3
    Last Post: 04-07-2014, 09:38 PM
  4. WiFi help
    By doogan123 in forum Motorola Droid MAXX
    Replies: 2
    Last Post: 04-06-2014, 10:03 PM
  5. HTC One (M8): WiFi arrows constantly lit up
    By zipro in forum HTC One (M8)
    Replies: 6
    Last Post: 04-06-2014, 01:33 AM

Posting Permissions