1. AC Question's Avatar
    Ever since I've updated to Nougat (it was almost a month ago) I have serious connection problems whether I'm on mobile or wifi. My friend has the same problems with the same phone. We are waiting for an update, but nothing is happening.

    Anyway, the connection drops, I receive messages on whats app with huge latency, I can't open videos on instagram (sometimes I can), updates are cancelled in the middle of downloading, 90% of the time it says location unavailable on the home screen etc. etc.

    It seems it has to do something with the phone being active/inactive (screen off).
    How to solve this problem? Anyone else has it? Is the only solution waiting for an update? I don't want to do the master reset.
    03-12-2017 06:48 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try wiping the cache partition: https://support.t-mobile.com/docs/DOC-31522
    03-13-2017 03:03 AM
  3. points's Avatar
    Welcome to Android Central! Try wiping the cache partition: https://support.t-mobile.com/docs/DOC-31522
    Thanks man. (I needed to register now).
    I did it, and it seemed it was working for 1 hour, everything worked well. Now it's bugging again

    WhatsApp, Viber, messeges are not being sent/delivered/received late

    What else should I try?
    03-13-2017 06:12 AM
  4. B. Diddy's Avatar
    i'd suggest Safe Mode, but you wouldn't be able to test out your apps, since it disables all 3rd party apps that you installed.

    Android System Webivew updates sometimes mess things up. Try uninstalling the updates, either in Settings>Apps, or on the Google Play Store page for that app.
    03-13-2017 12:49 PM
  5. points's Avatar
    i'd suggest Safe Mode, but you wouldn't be able to test out your apps, since it disables all 3rd party apps that you installed.

    Android System Webivew updates sometimes mess things up. Try uninstalling the updates, either in Settings>Apps, or on the Google Play Store page for that app.
    The application doesn't exist in Settings>Apps.

    When I go to Play store, it's disabled, I keep clicking "Enable" but it doesn't enable it.
    The problem persists, I'm going crazy, it's really annoying.
    03-17-2017 09:34 AM
  6. B. Diddy's Avatar
    Oh sorry -- if you have Nougat installed, that automatically disables Android System Webview, because it's incorporated into Chrome.

    Is it only an issue with Viber and WhatsApp, or are the previous connection issues occurring? If it's pretty widespread, then Safe Mode is still worth trying, to see if the problem goes away: https://support.t-mobile.com/docs/DOC-31470
    03-17-2017 09:56 AM
  7. points's Avatar
    Every connection problem I mentioned in the first post and even more, they are still occurring.
    So I should activate Safe mode using the tutorial you gave me, and just check if I have problems?
    Then I'll come back to say what happened.

    Edit: Did it. The problem is still there, even though I was afraid I won't be able to test it since everything is disabled. But my location on home screen disappeared again. It's "location unavailable".
    Then it either appears again, either I go to weather and refresh a few times.
    This is frustrating.
    03-17-2017 12:13 PM
  8. B. Diddy's Avatar
    Since it's happening in Safe Mode, it might be a problem with the firmware. Reinstalling the firmware might fix it, but that might not be a simple thing to do. Which carrier do you have? Verizon has a Software Repair Assistant that might help: http://forums.androidcentral.com/e?l...token=06W9Mk58
    03-17-2017 12:24 PM
  9. points's Avatar
    Ah, so this is an American forum?
    I'm in Italy and Vodafone is my carrier.

    Shouldn't HTC just release a fix?
    As I said, my friend has the same problem with the same phone.
    03-17-2017 12:27 PM
  10. B. Diddy's Avatar
    We certainly have global members, but the majority of users are US. I don't know if Vodafone has a similar repair utility, but I've never heard of one.

    Chances are that it's not an HTC problem per se, if this isn't a widespread issue. It might have to do with Vodafone's tweaks. Or it could be firmware corruption.
    03-17-2017 04:27 PM
  11. points's Avatar
    The friend that I'm talking about is not using Vodafone, and the problem exists whether you are on mobile network or wifi.
    03-17-2017 06:03 PM
  12. B. Diddy's Avatar
    OK -- the point being that it could be due to the carrier's tweaks, or a corrupted firmware. Reinstalling firmware is not straightforward task -- you can read more about it here: https://forum.xda-developers.com/one...ction-t3132698. At this point, doing a factory reset may be the next thing to try, but if the firmware itself is corrupted, a factory reset won't fix it. If the factory reset doesn't help, then your friend may want to bring the phone to their carrier to see if they can help; otherwise, bring it to a repair shop and see if they can help reflash the firmware.
    03-17-2017 08:51 PM
  13. points's Avatar
    Unfortunately I do not dare to do the firmware flash on my own.
    I could do the master reset though. What are the data I am going to lose? What and how should I back up? Is there a simple solution or I have to do things one by one?
    03-18-2017 02:38 AM
  14. B. Diddy's Avatar
    The reset will wipe all locally saved data. See this guide on how best to backup data: http://forums.androidcentral.com/amb...id-device.html
    03-18-2017 10:03 AM
  15. backface's Avatar
    Points, I wonder if you have already solved the problem, I have the very same problem, all the issues are happening to me too. I would add that I don't have any notification about emails (Gmail). Have to get into them and force the app to refresh. I tried a factory reset (Settings/Backup), but the problem hasn't been solved.
    In my case, my phone is sim-free with CID HTC_001 WWE and I am in Spain, so it's supposed to have "fresh" software from HTC, without any carrier modifing it.
    03-22-2017 07:59 AM
  16. points's Avatar
    I still haven't tried the factory reset, but that was supposed to be my next step. If you say it didn't help, I'm not going to try it at all.

    My phone has an untouched HTC Android as well. The carriers don't really modify the software nowadays.

    What are we going to do?

    At first I thought that a fix will come soon from HTC, but nothing is happening.
    03-22-2017 11:35 AM
  17. backface's Avatar
    I still haven't tried the factory reset, but that was supposed to be my next step. If you say it didn't help, I'm not going to try it at all.

    My phone has an untouched HTC Android as well. The carriers don't really modify the software nowadays.

    What are we going to do?

    At first I thought that a fix will come soon from HTC, but nothing is happening.
    I think I've found the problem. Are you using the Power Safe Mode all the time? Turn it off and try if all the issues happen. I used to have the Power Safe Mode always all the time, but never had issues before until now. Something has been changed or maybe it interacts with some new Android thing that make the phone act weird. It's that easy that in Instagram, you disable PSM from the notification bar, and videos start playing, and same happens with other problems, like Gmail notifications. Hope this helps you to have the phone back to normal.
    Chloe_87 and B. Diddy like this.
    03-24-2017 06:19 AM
  18. Chloe_87's Avatar
    Thankyou! I was having these exact problems and this solved it
    03-27-2017 06:32 AM
  19. points's Avatar
    Wow, thanks man, it really fixed the problem immediately. I will miss the Power saver mode though! Any chance they will realise that the problem exists and solve it with an update?
    Now I'll always have to set the screen brightness manually...
    03-30-2017 04:12 AM
  20. himay4577's Avatar
    i'd suggest Safe Mode, but you wouldn't be able to test out your apps, since it disables all 3rd party apps that you installed.

    Android System Webivew updates sometimes mess things up. Try uninstalling the updates, either in Settings>Apps, or on the Google Play Store page for that app.
    THANK YOU! I ended up here after googling a problem with my phone since the Nougat update. My Gmail wouldn't sync and the Play store didn't work. I went to the Android System Webview in Apps and clicked Disable, and instantly the Play store came back and my Gmail synced.
    03-30-2017 03:07 PM
  21. B. Diddy's Avatar
    Thanks @backface for the solution! I'm always a little suspicious of power-saving modes, because it's hard to know exactly how they work.
    03-30-2017 03:38 PM
  22. oneeyecarpenter's Avatar
    Thanks to those who discovered the fix!

    I think I read where Doze is more aggressive than previously employed. But turning off power save may be a good idea before updating too. After updating everyone should check Battery Optimization to see which apps are "NOT" optimized, which means they will still operate in the background. Also, you should enable "All Apps" when checking, so as to see which system apps you may want excluded from doze. I'll be sure to pass along the fix mentioned above.
    03-30-2017 06:20 PM
  23. Balaam's Avatar
    Thanks to those who discovered the fix!

    I think I read where Doze is more aggressive than previously employed. But turning off power save may be a good idea before updating too. After updating everyone should check Battery Optimization to see which apps are "NOT" optimized, which means they will still operate in the background. Also, you should enable "All Apps" when checking, so as to see which system apps you may want excluded from doze. I'll be sure to pass along the fix mentioned above.


    I tried turning off the PSM , restarting, disabling play store ,clearing cache. But it can't seem to help. It's really getting frustrating.
    05-07-2017 07:59 PM

Similar Threads

  1. motoe2 slowing down after rooting
    By Nikhil Raj Verma in forum Moto E (2015)
    Replies: 1
    Last Post: 03-14-2017, 09:35 PM
  2. Replies: 1
    Last Post: 03-13-2017, 03:06 AM
  3. Video played back once after recording and now wont play at all. ....
    By frustratedlowie in forum Samsung Galaxy S7 edge
    Replies: 1
    Last Post: 03-12-2017, 12:51 PM
  4. What to know when replacing smartphone motherboard?
    By j591 in forum Ask a Question
    Replies: 2
    Last Post: 03-12-2017, 11:20 AM
LINK TO POST COPIED TO CLIPBOARD