Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 14 of 14
  1. Thread Author  Thread Author    #1  

    Default this adb not working is driving me insane!!! H=e=l=p!!!

    this has been a problem after problem situation the whole way through trying to knock my HTC one out of this softbrick state it is currently trapped in.

    long story short. currently at point where trying to sideload rom to phone... past flashing twrp.img... and if its not one error its the next.

    1) adb will refuse to start.. it will just stick on:
    C:\adb>adb start-server
    * daemon not running. starting it now on port 5037

    2) C:\adb>adb devices
    * daemon not running. starting it now on port 5037 *
    ADB server didn't ACK
    * failed to start daemon *
    error: cannot connect to daemon

    3) last error type, everything will be running smoothly then as after the 'adb sideload ROM.zip' or should it be this,'adb sideload Desktop/ROM.zip' dont know but it shoots back "error: closed"

    FIX THIS PLEASEEEEEEEEEEEE!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  2. #2  
    Golfdriver97's Avatar

    Posts
    30,452 Posts
    Global Posts
    30,943 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    I was under the impression you had to kill-server before you could start-server.
  3. #3  
    benny3's Avatar
    Flashoholic!!

    Posts
    2,223 Posts

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Do you have Java installed?
  4. Thread Author  Thread Author    #4  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by benny3 View Post
    Do you have Java installed?
    i believe so.. its always popping up asking for something. i usually click whatever the decline button is... maybe it needs updating? would that be effing with this whole adb ish?
  5. Thread Author  Thread Author    #5  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by Golfdriver97 View Post
    I was under the impression you had to kill-server before you could start-server.
    im sure i tried it in every order.. i think i was killing the exe from task manager.
  6. #6  
    benny3's Avatar
    Flashoholic!!

    Posts
    2,223 Posts

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Are you putting the zip file in the adb/fastboot folder?
  7. Thread Author  Thread Author    #7  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by benny3 View Post
    Are you putting the zip file in the adb/fastboot folder?
    i put the rom in the fastboot folder on my desktop and tried that way, i also tried with the rom in the adb folder on my c drive
  8. #8  
    benny3's Avatar
    Flashoholic!!

    Posts
    2,223 Posts

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by TacoGobbler View Post
    i put the rom in the fastboot folder on my desktop and tried that way, i also tried with the rom in the adb folder on my c drive
    adb and fastboot should be in the same folder. Are opening the command prompt from that same folder?
    download this and extract it to your desktop. Put the rom.zip in it, Hold the shift key down, right click that folder and the run command from here
    https://dl.dropboxusercontent.com/u/45848000/adb.zip
  9. Thread Author  Thread Author    #9  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by benny3 View Post
    adb and fastboot should be in the same folder. Are opening the command prompt from that same folder?
    download this and extract it to your desktop. Put the rom.zip in it, Hold the shift key down, right click that folder and the run command from here
    https://dl.dropboxusercontent.com/u/45848000/adb.zip
    dog **** still aint work. so i installed the HTC drivers from your other post (though nothing happens really when exe is clicked)
    then i download this file and did as directed, cmd replied:
    C:\Users\Gateway\Desktop\adb>adb devices
    adb server is out of date. killing...
    * daemon started successfully *
    ** daemon still not runningerror: cannot connect to daemon

    C:\Users\Gateway\Desktop\adb>adb kill-server

    C:\Users\Gateway\Desktop\adb>adb usb
    * daemon not running. starting it now on port 5037 *
    ADB server didn't ACK
    * failed to start daemon *
    error: cannot connect to daemon

    C:\Users\Gateway\Desktop\adb>

    other people are saying to copy adb files to folder on c drive and launch from there. they also say launch cmd from installed adb location...what where the first set of files you had me install? the driver in my list of devices says Google nexus ADB interface driver but i cant find its location. shouldnt i move the rom.zip there and lunch there??? why is this such a ******* struggle. thank you for helping seems the rest of the android community just reads random troubleshooting posts for no reason other than entertainment... most unhelpful forum ever.
  10. Thread Author  Thread Author    #10  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by Golfdriver97 View Post
    I was under the impression you had to kill-server before you could start-server.
    HELP ME SOMEBODY PLEASSEEEEEEEEEEEEEEE!!!!!
    Quote Originally Posted by benny3 View Post
    adb and fastboot should be in the same folder. Are opening the command prompt from that same folder?
    download this and extract it to your desktop. Put the rom.zip in it, Hold the shift key down, right click that folder and the run command from here
    https://dl.dropboxusercontent.com/u/45848000/adb.zip
    dog **** still aint work. so i installed the HTC drivers from your other post (though nothing happens really when exe is clicked)
    then i download this file and did as directed, cmd replied:
    C:\Users\Gateway\Desktop\adb>adb devices
    adb server is out of date. killing...
    * daemon started successfully *
    ** daemon still not runningerror: cannot connect to daemon

    C:\Users\Gateway\Desktop\adb>adb kill-server

    C:\Users\Gateway\Desktop\adb>adb usb
    * daemon not running. starting it now on port 5037 *
    ADB server didn't ACK
    * failed to start daemon *
    error: cannot connect to daemon

    C:\Users\Gateway\Desktop\adb>

    other people are saying to copy adb files to folder on c drive and launch from there. they also say launch cmd from installed adb location...what where the first set of files you had me install? the driver in my list of devices says Google nexus ADB interface driver but i cant find its location. shouldnt i move the rom.zip there and lunch there??? why is this such a ******* struggle. thank you for helping seems the rest of the android community just reads random troubleshooting posts for no reason other than entertainment... most unhelpful forum ever.
  11. #11  
    Golfdriver97's Avatar

    Posts
    30,452 Posts
    Global Posts
    30,943 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Unfortunately, I am not very strong with ADB command lines. What PC are you using? Windows 8?
  12. Thread Author  Thread Author    #12  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by Golfdriver97 View Post
    Unfortunately, I am not very strong with ADB command lines. What PC are you using? Windows 8?
    i am using windows 7. i cant get the daemon tool to run for some reason. i either get: daemon started successfully * daemon still not running * error: cannot connect to daemon OR adb server didnt ACK * failed to start daemon

    i am launching the cmd from the platform-tools folder. sync is NOT installed... WHAT COULD BE THE ISSUE? ive flashed roms to several devices before.. this one included, but now it wont work.

    when i submit the 'android devices' commaand in the windows task manager a second instance of adb.exe shows up. is this supposed to happen?

    Is there a more responsive forum that i could go to about ADB issues?
  13. #13  
    Golfdriver97's Avatar

    Posts
    30,452 Posts
    Global Posts
    30,943 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    Quote Originally Posted by TacoGobbler View Post
    i am using windows 7. i cant get the daemon tool to run for some reason. i either get: daemon started successfully * daemon still not running * error: cannot connect to daemon OR adb server didnt ACK * failed to start daemon

    i am launching the cmd from the platform-tools folder. sync is NOT installed... WHAT COULD BE THE ISSUE? ive flashed roms to several devices before.. this one included, but now it wont work.

    when i submit the 'android devices' commaand in the windows task manager a second instance of adb.exe shows up. is this supposed to happen?

    Is there a more responsive forum that i could go to about ADB issues?
    The only one I can think of is XDAdevelopers.
  14. #14  

    Default Re: this adb not working is driving me insane!!! H=e=l=p!!!

    I had similar problems i ended up buying a Micro USB OTG to USB 2.0 Adapter ... changed my life when adb wasnt working. just remember in the recovery mode you have to mount it.

    alsp twrp and cw gave me problems so i installed philz_touch_6.48.4-m7spr.img and i was back up and running fast

Similar Threads

  1. Replies: 2
    Last Post: 04-29-2015, 11:18 AM
  2. Which USB charger works on S4 in a LifeProof Fre case?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-05-2014, 10:49 PM
  3. Looking for this calendar widget....Help!
    By thomasmayne in forum Ask a Question
    Replies: 3
    Last Post: 08-05-2014, 08:34 PM
  4. What happened to my photos apps on my Nexus 5?
    By Cassie_RVT in forum Google Nexus 5
    Replies: 2
    Last Post: 08-05-2014, 08:14 PM
  5. Replies: 11
    Last Post: 08-05-2014, 06:51 PM

Posting Permissions