1. himenohogosha's Avatar
    I went back and exchanged my One S for a new one. The person at the counter backed up all my contacts to the SIM card before switching me over. Now that I'm running on the new phone, it seems all my contacts were synced to my google account, and now I have a bunch of duplicates in the SIM card. I can't find a way to delete them off the card though. I downloaded an app but it didn't actually delete anything. Is there a setting I'm missing or something?
    05-22-2012 02:14 PM
  2. joenorwood77's Avatar
    I think this will help you possibly:

    Click on "contacts" and then upper left hand click "phonebook". Make sure check mark is only on one you want to currently manage. Now upper right click menu, and then select "delete" to get rid of which you want to.

    Another option is you can just uncheck the sources of contacts under phonebook you no longer want to show under your contacts.

    I personally logged onto mylifecontacts on T-Mobile and deleted everything off of there after I copied all contacts to my gmail account. Now I am using gmail as my source of all contacts and managing everything related to contacts on gmail (mailing addresses, email addresses, and phone numbers).

    I hope my information is helpful.
    05-26-2012 04:54 PM
  3. Esam AlQaed's Avatar
    Thank you very much, that was really helpful.
    12-21-2012 12:14 AM
  4. ASNoel's Avatar
    Okay here's my issue. When I select GMAIL only from the dropdown, and go back to see my gmail contacts, the dropdown links still stated Phonebook. Should it say GMAIL?
    06-06-2013 11:26 AM
LINK TO POST COPIED TO CLIPBOARD