1. kare's Avatar
    Two days back upgraded my phone from ver 4.0.4 to 4.1.1, which came a big rescue as my phone was having "helicopter glitch" , means during incoming/outgoing or GPRS activation, all home pages start showing helicopter view and bottom buttons stops functioning till the time i restart the phone. After upgradation this all solved and my phone starts function smoothly but despite showing wifi connectivity or GPRS or internet pass through PC , internet is not working
    .
    Any help as now its really painful, previously internet connection via wifi or internet pass through was perfect
    12-27-2012 11:08 AM
  2. Scott Rodger's Avatar
    have the same problem too, please help HTC or Andoid
    12-31-2012 09:10 AM
  3. carpetmaven2000's Avatar
    which Hboot do you have and carrier are you on?
    01-02-2013 08:35 PM
  4. OmnislashVince's Avatar
    I have the same problem too!! What is Hboot? I have an unlocked HTC, but my carrier is Orange! I feel like I have tried everything...any solutions?! Thanks
    01-03-2013 07:30 PM
  5. Jonathan Tweddle's Avatar
    Hi, I also have this problem with my one s. I completed the upgrade yesterday and now I have no access to the net. WiFi says 'connected' but nothing works. All OK when I drop the WiFi and go back to mobile network. Does anyone know a solution? thanks in advance .
    01-10-2013 06:31 AM
  6. tumbleweed99's Avatar
    I had the same problem as you are describing. Just found this on another forum and it worked! Give it a try.

    Settings > Wifi > Menu > Advanced

    At the bottom of the screen you will probably have a check next to "DLNA auto-IP". Uncheck it and wait a bit. If it still doesn't work bounce Wifi.

    I did this on with my WiFi off, unchecked the setting outlined above, waited a bit, then connected my WiFi and I could browse the internet again! Hope it helps!
    Spragga Dagga likes this.
    01-12-2013 08:24 AM
  7. BluFurya's Avatar
    Just updated this Sunday from 4.0.4 to 4.1.1 - no more internet acess since then, via wi-fi... it ruined a very good phone that was running without a single fault....

    Ive reported this to HTC support... I hope that they solve this problem....
    01-22-2013 10:38 AM
  8. PHomero's Avatar
    My HTC has the same symptoms described above, but only with my 3G Router (ZTE MF60 re-branded by Optimus (Pt)), it get's an WiFi connection, though no internet access. I have no problem whatsoever with other WiFi's.
    And unlike the thread OP I can access the same internet connection while sharing it through my laptop by USB.
    Already checked with HTC support, nothing, useless, ZTE the same... I'm really hopping someone here can find a solution.
    01-22-2013 12:39 PM
  9. BluFurya's Avatar
    It appears that this is only ocurring with some wi-fi routers... the first two i've tried gave the same simptoms, but then Ive tied with more access points and the internet acess thrugh wi-fi was fine... then tried the same at home and no Internet acess again....

    Damn update....
    01-23-2013 12:09 PM
  10. PHomero's Avatar
    Got mine to work.
    It's a crappy routine, but somehow it works, it must be some kind of bug.


    Each time I connect to said router with the usual symptoms (Wifi connected, no internet access)
    wi-fi setting, > Advanced > disable "best Wifi performance" >back > Advanced Wi-fi settings > Enable "best Wifi performance"

    And Voil, Internet access.
    If you repeat it enough times you'l be able to do it without looking... a widget capable of repeating this routine would be a godsend for me!
    02-15-2013 02:08 PM
  11. BluFurya's Avatar
    PHomero,

    That "crappy" routine also manages to put my cellphone to access the internet again through wi-fi!

    ...of course, if I disconnect from the wi-fi network and reconnect again, I have to do the same routine again.

    So far My HTC has problems with ADB routers [SAPO ADSL], ALL OFF THEM SO FAR... and probably some other models too ( with Android 4.0.4 every thing was fine)

    Its been a nightmare to deal with the Tech support so far ...

    Thanks PHomero!!!
    02-18-2013 01:14 PM
  12. PHomero's Avatar
    So might this be a thing with Portuguese ISP's?
    I got my HTC from Optimus, unlocked it to use Vodafone Portugal, and the router in question is on Optimus 3g...

    You're welcome, though I don't consider this a solution, it gets it to work.

    Ps. I also reported this to HTC support so they might correct this bug, but was quickly ignored
    02-18-2013 01:28 PM
  13. BluFurya's Avatar
    No, my One S works fine with ZON routers, and with others also. So far I have problems with about 25% of the wi-fi networks I usually access. But I do not know all the routers (models) to which I try to connect.

    Yeah...HTC support has been very keen to help solving the problem (NOT).

    I also reported your "temporary solution" to HTC. They better solve this.
    02-18-2013 01:40 PM
  14. BluFurya's Avatar
    Same answer from HTC... "We are very sorry for your trouble - bla bla bla, bla bla bla, buy a new router...."

    ....And they say Android 4.1 is incompatible with some wifi routers.... well, if thats the case, why on earth does the "fix" PHomero found puts the damn thing working again???

    And, suppose I buy a new router for my house...what will I do about the OTHERS WERE THE DAMN THING HAS PROBLEMS???

    Its pretty damn stupid having a very expensive smartphone that has problems where budget smartphones have no problems...

    Till now, the only thing I think about the "S" for "One S" is: One "Sh*t"...
    02-19-2013 01:45 PM
  15. Ryandroid86's Avatar
    HTC doesnt want to admit this but it is there fault. It depends on what hboot you have. and considering you upgraded your phone (not rooted) most likely updated the hboot.
    This is even an issue with the sense ROMs (rooted)

    there is not much you can do unless HTC decides to fix the problem.
    to make it easy to understand... its the security on the phone is too tight. (for example unlocking your bootloader. and trying to flash ROMs cannot happen unless you use fastboot method from your PC and your command promt, and adb, etc etc)

    everyone will tell you... HTC sucks when it comes to security issues.
    this is why I rooted and now have vanilla android 4.1.2 (the way it was intended) with no issues at all. I love it now.
    02-19-2013 06:18 PM
  16. PHomero's Avatar
    Unlike most "power users", I love Sense, and love my phone, it's perfect as it is (except for the issue in discussion), my last hope is a widget capable of turning best wifi on/off, if not i'll have no choice but to ROOT, it's not a JB issue, I have other devices with no problem whatsoever, HTC is ignoring both the problem and the solution, and since this was probably the last OTA update i don't expect a solution from them, they manufacter great devices but they'r support is shameful.

    There aren't many portable Wifi 3g Routers on the market (at least in Portugal), and they are not cheap, so now I have to ask for a Compatibility Test Trial for any router before buying? Can we identify a range of Sense+ bug free routers?
    02-21-2013 06:36 AM
  17. BluFurya's Avatar
    HTC support insists that its an incompatibility of the firmware of the routers... Even with a video that I've sent to them, showing that the One S can be put to work with "incompatible" wifi routers - ah, by the way, PHomero, you only need to turn off and then on the option "better wifi perfomance", not needing to go back.

    The Fix that PHomero found, has proven very useful for me. HTC produces very good phones, but their support just isnt at the same level...so far...

    I have, to the moment, no problems at all with Cisco products, 3 Com and Thompson...

    I gess that the inexpensive range of routers can be problematic with the One S (Android 4.1.1)...
    02-21-2013 01:33 PM
  18. Dario Correnti's Avatar
    Hi everyone,
    I had the same problem and I solved it just sharing my PC connection with HTC through USB (via HTC Sync Manager). Once I disconnected the phone from the PC, Internet started working via WiFi.

    I hope it can help you.

    Cheers!
    02-28-2013 03:50 AM
  19. Ladislao Delgado's Avatar
    After spending 2hrs on my own, calling HTC and spending an hour I read this post and unchecked the DLNA auto - IP setting and disconnected and reconnected the wifi on the phone and it works like a champ now. I have to say I am UNIMPRESSED with the update to Jelly Bean. All I see difference wise is now my folders on my home screen are black for a few seconds after rebooting until the phone resyncs them the shortcuts to the original apps. Seems like it has slowed the phone down when it refreshes the desktop.
    03-23-2013 01:30 PM
  20. Spragga Dagga's Avatar
    OMG thank you sooooooooooo much for this, i did wat u said and it works
    04-17-2013 09:08 AM
  21. PHomero's Avatar
    Just a heads up, download the power toggles apk and you'l have access to a shortcut to advanced wifi settings on the notification bar.
    04-29-2013 02:58 AM
  22. Daniel Loney's Avatar
    This worked great man thank you! I too turned off my WiFi before unchecking the DLNA auto-IP. Left it for 1 minute and then connected to my network and bob's your uncle!

    05-29-2013 11:53 AM
  23. edwin cp's Avatar
    Two days back upgraded my phone from ver 4.0.4 to 4.1.1, which came a big rescue as my phone was having "helicopter glitch" , means during incoming/outgoing or GPRS activation, all home pages start showing helicopter view and bottom buttons stops functioning till the time i restart the phone. After upgradation this all solved and my phone starts function smoothly but despite showing wifi connectivity or GPRS or internet pass through PC , internet is not working
    .
    Any help as now its really painful, previously internet connection via wifi or internet pass through was perfect
    08-04-2013 01:22 AM
  24. ns444's Avatar
    tumbleweed99, I have been searching for solution to this for months. Disabling DLNA solved the problem on my HTC oneX. I can now use the WIFI on my phone once again. thank you.
    09-09-2013 08:27 PM

Similar Threads

  1. no internet connection after upgrade
    By Zman1001 in forum Motorola Xoom
    Replies: 6
    Last Post: 11-08-2011, 10:45 AM
  2. Bricked Captivate after upgrading from 2.1 to 2.2...
    By bbguy6749 in forum AT&T Captivate
    Replies: 0
    Last Post: 07-28-2011, 08:56 PM
  3. Android Blackberry kept Internet connection after tether removed
    By bfigueroa in forum General Help and How To
    Replies: 0
    Last Post: 06-24-2011, 04:20 PM
  4. Trouble getting internet connection after root..
    By KSChris in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 04-21-2011, 03:17 PM
  5. Please Help - No network internet connectivity
    By geoffd in forum Verizon Droid Incredible
    Replies: 9
    Last Post: 05-21-2010, 10:04 AM
LINK TO POST COPIED TO CLIPBOARD