Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread Author  Thread Author    #1  

    Default Anyone using HTC ONE S on Simple Mobile?

    I suddenly am having trouble using the HTC ONE S via Simple Mobile. It has been working flawlessly for many months, and yesterday I lost data services.

    When I tried to use the internet, it tries to go to the URL I entered but immediately gets redirected to u.web2go.com/upsell...with a page saying "T-MOBILE 4G Better access, less congestion" and "Your data plan does not work on this device. Click here to sign up for a new data plan."

    So somehow T-Mobile is blocking me. Now I know that Simple Mobile uses T-Mobile towers, somehow they think I am a T-Mobile user?

    So I did a few tests.

    Tried different browsers - Firefox, Chrome, Opera Mini, same problem. Tried a POP3 email client, same problem.
    Tried different locations - home, office, on the road, no difference.
    Tried powering down and back up, removed and reinserted SIM card, no difference.
    Deleted my APN, created a new one with same settings, no difference. Checked their web site and looked up latest APN settings, looks fine.
    I have a family member with same HTC ONE S, bought at the same time, same Android version (4.1.1), same settings, and he has no problem at all. Yet, I can call, text but no data.
    Yesterday was the day my last payment period ends, and a new monthly cycle kicks in. I already paid, and checked with customer service and they confirmed my account is in good standing, no issue, and not exceeded any data usage limits and not throttled in any way.
    So, I decided to switch SIM card with my family member. He put his SIM into my phone, I put my SIM into his phone. Restarted both phones and MY SIM in his phone does not work, his SIM in my phone works. Makes no sense.
    The one thing I was wondering is, my HTC ONE S is a T-Mobile phone. I have never unlocked it. I was told if you are on SimpleMobile and since SM is using T-Mobile, I don't need to unlock the phone, plus it has been working for over six months. However, when I go to my APNs, I see three APNs defined, as shown below.

    Anyone using HTC ONE S on Simple Mobile?-htc1s-apns.jpg

    I don't know if I need to unlock the phone and to get rid of the two T-Mobile built in APNs. But I created a new SimpleMobile APN, selected it and it had worked so I never bothered to unlock it. Is it possible it is just now catching up with me six months later? Here are my SimpleMobile APN settings in case it may be relevant.

    Anyone using HTC ONE S on Simple Mobile?-htc1s-sm-apn-config1.pngAnyone using HTC ONE S on Simple Mobile?-htc1s-sm-apn-config2.png

    Oh, yes I did call SimpleMobile Customer Service, and spoke to them about 30 minutes, they passed me to Tech Support, spoke to them about 1 hour, was put on hold multiple times, talking to someone with broken English. Then they gave up and created a trouble ticket, says to call me back in 24 hours with another department. Then the next day someone called, and that person is from Tracphone and has little idea why she needs to call me, and after I explained things, she said I need to talk to customer service or someone else. It's been a spinning circle since. They kept asking me to delete and recreate new APNs, and power down and restart my phone.

    Any thoughts?
  2. #2  

    Default Re: Anyone using HTC ONE S on Simple Mobile?

    I'm on Iphone5 and on simple mobile and have the exact same problem ,
    it started yesterday for me and correspond to the new 4G roll-out .
    Same experience with customer support : went through same process as you basically ...
    and still stuck ...

    any help from anybody on any network with any phone I will take !!

    going GAGA over here !!!
  3. #3  

    Angry Re: Anyone using HTC ONE S on Simple Mobile?

    SimpleMobile support is pretty horrible. They asked for phones model. Although I said E2001 (I have one purchased from ebay which used to work perfectly), the fellow actually disconnected the session. It sounds like a T-mobile trick to force SimpleMobile (etc) customers to join them. I used to get many automated calls to join them which I ignored.
  4. #4  

    Default Re: Anyone using HTC ONE S on Simple Mobile?

    This is not a connection issue. Some server (T-mobile? or simple mobile?) is serving different content than requested and looking at the time when problem starts, this does look like intentionally created trouble. If the device is not compatible, how did they send the other content then? May be some settings goof up from simple mobile or intentional blockage by T-mobile to deny services to simple mobile customers.
    Last edited by Shishir Mondal; 04-14-2014 at 08:11 PM.
  5. #5  

    Default Re: Anyone using HTC ONE S on Simple Mobile?

    i have the same problem. still stuck. started on april 13th as soon as my new cycle kicked in. i have factory unlocked iPhone 5. can make calls/texts but no data
  6. #6  

    Smile Re: Anyone using HTC ONE S on Simple Mobile?

    To those who are using iphone, I have the same problem today but I fixed it.

    No harm in trying it might work on your device!

    Power off your iphone for at least 2 minutes then power back on

    Go to settings, then look for cellular, then go to cellular data network - make sure under cellular data the APN must say SIMPLE.

    Restart your iphone - PROBLEM solved i hope!

    Have a great day and Good Friday to all!
  7. #7  

    Default Re: Anyone using HTC ONE S on Simple Mobile?

    I am also facing same problem in my windows phone Nokia Lumia 720...............Any solution??
  8. #8  

    Smile Re: Anyone using HTC ONE S on Simple Mobile?

    I had the same error and after many, many hours on the phone with simple mobile technical support, they were able to resolve it. They had to speak to T-mobile to reset the billing information on the account.

    I don't know if it will help anyone else, but I was given Notification Number 126 818 4608 for my issue.

Similar Threads

  1. [Closed] Win one of 10 Speck CandyShell cases for Galaxy S5!
    By Phil Nickinson in forum Android Central Contests
    Replies: 52
    Last Post: 04-18-2014, 02:44 AM
  2. Have you ever used an app that can automatically tag your photos location?
    By RebeccaFU in forum General News & Discussion
    Replies: 5
    Last Post: 04-15-2014, 07:53 AM
  3. Wallpaper cuts off on right side in landscape mode
    By Lorenzo White in forum Google Nexus 7 Tablet (2012)
    Replies: 3
    Last Post: 04-11-2014, 12:40 PM
  4. Replies: 2
    Last Post: 04-11-2014, 10:13 AM

Posting Permissions