1. kangyooni's Avatar
    Hello,

    I have HTC One V international (GSM) version, unlocked, targeted to NL/BE/Lux (Europe).

    Struggling from a big issue - when going abroad from the Netherlands to some countries, eg. Poland, receiving loads of text messages like SMS from 2-digit numbers, over 50 per minute. This isn't in fact SMS, but a cell broadcast with local dating offers etc. Additionally, a pop up appears every few minutes with base station location. Doesn't matter it is my Dutch simcard (KPN) in roaming, or a local T-Mobile sim.

    Normally, all phones have cell broadcast off by default and you can opt-in for these messages.

    On my HTC Cell Broadcast in Call settings is always active, grayed-out so can't disable (see picture #1). Pre-selected chanels 519 & 919 (NL-Alert) - also can't delete, but phone receives other channels too (that crappy messages are chan. #20-49 and those pop-ups are on #50).

    Escalated to HTC NL - first they ignored me, then after nagging on their facebook - called me back first saying "I cannot disable CB", and later that I can in the settings. I tried and cannot cause it's grayed-out as mentioned - take a look at the picture below.

    Any advice? How about rooting the phone? Or need a new ROM? Actually I cannot use the phone abroad due to that spam and if can't fix it, will return it. But first wanna look for some solution, hope there is...

    Thanks
    Attached Thumbnails Cannot switch off channel broadcast - critical issue (int'l version)-_scf9668.jpg   Cannot switch off channel broadcast - critical issue (int'l version)-_scf9669.jpg   Cannot switch off channel broadcast - critical issue (int'l version)-_scf9667.jpg  
    09-20-2012 05:36 PM
  2. frankgs's Avatar
    Those CB messages are indeed a real PITA!

    You probably did but have you tried press and hold on each channel item? I get a popup allowing me to edit or delete the channel item (on my S2). I know it's obvious but I find the Android UI not always intuitive.
    11-09-2012 04:46 AM
  3. friendatin's Avatar
    Hi
    You can switch off the Cell Broadcast MSG (CB) by going to Settings --> Calls --> deselect the Cell Broadcast option. Done enjoy
    03-15-2013 08:05 AM
  4. Prakash chandra's Avatar
    Hi,

    I deselected all the options , restarted the phone (S2) . But still I am getting CB Msg ......... Its so irritating. Can you suggest some other solution ?
    05-06-2014 10:00 AM
  5. Prakash chandra's Avatar
    Hi ,

    I am getting CB Msg even after deselecting all the options and restarting. Can someone please guide me how can i stop getting CB messages ?
    05-06-2014 10:02 AM
  6. Pooja_Singh's Avatar
    This same happened with me, but now I got the solution.
    Go to Settings-> Call -> select the slot in which SIM u getting the msgs -> uncheck broadcast msgs option and done
    Hope this will help you.
    10-06-2015 02:47 PM

Similar Threads

  1. Help head off any potential WAF issues...
    By Suntan in forum Motorola Xoom
    Replies: 16
    Last Post: 03-30-2011, 09:40 AM
  2. You can Switch off LTE using phone menu
    By project.in.process in forum Verizon HTC Thunderbolt
    Replies: 0
    Last Post: 03-18-2011, 10:11 AM
  3. Bluetooth Switching Off
    By pauldroidr2d2 in forum Motorola Droid X
    Replies: 1
    Last Post: 03-15-2011, 03:06 PM
  4. Replies: 5
    Last Post: 01-08-2011, 04:53 PM
  5. GPS switched off, but location still avaliable!
    By yungwunn911 in forum HTC EVO 4G
    Replies: 12
    Last Post: 08-16-2010, 04:39 PM
LINK TO POST COPIED TO CLIPBOARD