11-04-2012 09:49 AM
65 123
tools
  1. lucidlyseen's Avatar
    man, I got home from work today (where wifi seemed to work great) and it is just issue after issue... FIrst it says my router is out of range, then it has trouble connecting, then it connects but with a very weak signal. I have speedtest.net app installed and that even has trouble finding a server close to me, almost like my gps is all screwed up too. It takes several attemps to find a server and then it's not even the closest server to me by far!

    So when I finally run the test it will time out a few times and when it does run it is slooooow, I mean really slow. Even with wifi turned off and running speedtest it has the same problems.

    I don't know what is going on here, but I hope it is all related to whatever bug they are aware of, because my phone is hardly usable at home...
    05-07-2012 07:05 PM
  2. anon(153966)'s Avatar
    Remember, you can always turn your WIFI off! But, more importantly, read previous posts, and try using 2.4GHZ, versus the auto setting on the One X (WIFI settings \ advanced)

    man, I got home from work today (where wifi seemed to work great) and it is just issue after issue... FIrst it says my router is out of range, then it has trouble connecting, then it connects but with a very weak signal. I have speedtest.net app installed and that even has trouble finding a server close to me, almost like my gps is all screwed up too. It takes several attemps to find a server and then it's not even the closest server to me by far!

    So when I finally run the test it will time out a few times and when it does run it is slooooow, I mean really slow. Even with wifi turned off and running speedtest it has the same problems.

    I don't know what is going on here, but I hope it is all related to whatever bug they are aware of, because my phone is hardly usable at home...



    Sent from my iPad using Tapatalk
    05-07-2012 07:40 PM
  3. lucidlyseen's Avatar
    ya, I am using 2.4 now, not auto - it's really weird, all of a sudden it was working great, then right back down to nothing again. Is anybody else experiencing the gps having trouble finding your location?
    05-07-2012 07:51 PM
  4. icebike's Avatar
    ya, I am using 2.4 now, not auto - it's really weird, all of a sudden it was working great, then right back down to nothing again. Is anybody else experiencing the gps having trouble finding your location?
    Gps workings flawlessly for me.

    Sent from my HTC One X using Tapatalk 2
    05-07-2012 08:04 PM
  5. mobilehavoc's Avatar
    I posted something over on xda with the same issues discussed here.

    Link http://forum.xda-developers.com/showthread.php?p=25685052

    Sent from my HTC One X using Tapatalk 2
    05-07-2012 08:24 PM
  6. sparkomatic's Avatar
    Having the wifi not disconnecting issue like others in this thread. Hopefully a fix will be coming out soon.

    Using an Apple router FWIW. Hmmm...maybe the Apple router has "detected" an Android device and that's why this is happening! haha
    05-08-2012 12:20 AM
  7. nokia4life's Avatar
    lawd i pray that my phone arriving today now does not have this issue if so i hope HTC takes a page from nokia and get this crap fixed asap and give out some credits this is nuts lets see it took nokia a week to get it fixed these guys better get with it i shouldn't have to go hacking it to fix it.
    05-08-2012 12:23 AM
  8. snovguy's Avatar
    lawd i pray that my phone arriving today now does not have this issue if so i hope HTC takes a page from nokia and get this crap fixed asap and give out some credits this is nuts lets see it took nokia a week to get it fixed these guys better get with it i shouldn't have to go hacking it to fix it.
    I have one as well and am hoping for a fix. I simply cannot get a stable wifi connection at either home or work.

    The only thing that does work is a kludge is an old 802.11b airport express daisy chained off my router
    05-08-2012 03:03 PM
  9. lotalota's Avatar
    Weird issue now. I can connect to my home wifi, but now my laptop won't connect when the One X has connected first. Go figure?
    05-10-2012 09:43 PM
  10. anon(153966)'s Avatar
    Bazaar, try rebooting the router...

    Failing that either:
    1. Give your laptop a static IP
    2. Check your router settings to make your DHCP is set to give more than 10 IP addresses

    I hope that helps...

    Weird issue now. I can connect to my home wifi, but now my laptop won't connect when the One X has connected first. Go figure?



    Sent from my iPad using Tapatalk
    05-11-2012 04:32 AM
  11. jspidey's Avatar
    Count me in on the list of those having WiFi issues. I don't notice any "looping" as you say, but my Wifi will appear connected but it's not passing any data - it cannot hit any host on the network nor the gateway. I just turn WiFi off/on and it recovers right away.
    05-12-2012 12:41 AM
  12. nubianepiphany's Avatar
    Hey!

    Don't know if you've solved the issue or not, but I had the same problem. Just fixed it.

    Instead of setting the security to WPA/WP2K, set it to WEP. Once I did that, my Samsung SGHT589 started to pick up a signal. Granted, it's not an "excellent" signal, just "fair", but it does work.

    Good Luck
    08-21-2012 10:46 AM
  13. icebike's Avatar
    Hey!

    Don't know if you've solved the issue or not, but I had the same problem. Just fixed it.

    Instead of setting the security to WPA/WP2K, set it to WEP. Once I did that, my Samsung SGHT589 started to pick up a signal. Granted, it's not an "excellent" signal, just "fair", but it does work.

    Good Luck
    Not everyone is free to change the router's security settings. And wep is pretty easy to crack.

    Sent from my HTC One X using Tapatalk 2
    08-21-2012 10:56 AM
  14. myrddincox's Avatar
    I, for one, have not noticed any issues with WiFi. Jumped from iPhone 4 to HOX about 3 weeks ago or so, and WiFI strength has been almost identical to what I was getting. I do have issues occasionally on my work WiFi - but everyone in the bldg has the same (iPhones and various android devices included). The router is extremely old and due for replacement... No problems whatsoever at home.
    08-21-2012 05:12 PM
  15. 1ota1ota's Avatar
    Hi!

    Here is the solution:

    Choose (WPA) Algorithms = TKIP+AES in your router's wireless security settings

    (I spent two days sorting this problem out and just wanted to share the trick. cheers!
    11-04-2012 09:49 AM
65 123
LINK TO POST COPIED TO CLIPBOARD