09-04-2012 03:59 PM
26 12
tools
  1. snappjay's Avatar
    I love the new phone. Came from an iPhone 4 for a couple years, then used a Galaxy Note for a few weeks (too damn big) and traded it in for the HTC One X. I'm also a big fan of Google Voice. It worked perfectly on the iPhone 4 and Galaxy Note.

    I turn on the phone and the first thing I do is install GV. Get to the "Setup Voicemail" step and click "Configure". I then have the option between "My Carrier" and "Google Voice". Of course, I select Google Voice. The error I'm getting is "Failed to retrieve and save current forwarding number settings. Do you want to switch to the new provider anyway?" I click Yes. Next error is "Forwarding number change unsuccessful. Please contact your carrier if this problem persists." The only thing to click now is "OK" and go through the voicemail setup process again.

    It's odd because I never had a GV voicemail issue on the iPhone 4 or Galaxy Note. Is anyone else having issues with their HTC One X and Google Voice Voicemail?
    05-07-2012 07:41 PM
  2. jess.hickey's Avatar
    Go into the settings at voice.google.com and deactivate your phone and reactivate it. The deactivate step will give a code to enter in your phone...skip that. Next, click on activate this phone and it will give you a string to dial...something like *004*yourgooglevoicenumber# or something like that. That should fix ya up.
    lsutigers03 likes this.
    05-07-2012 08:24 PM
  3. pheltzer's Avatar
    I'm having the same problem on my One S. I've activated/deactivated using the code from google and I still can't get it to accept GV as my voicemail on my phone. Any other thoughts?
    05-07-2012 10:34 PM
  4. Kevin OQuinn's Avatar
    I'm having the same problem on my One S. I've activated/deactivated using the code from google and I still can't get it to accept GV as my voicemail on my phone. Any other thoughts?
    I also did this and it didn't fix the problem.
    05-07-2012 10:47 PM
  5. ndc's Avatar
    Add me to the g-voicemail-less line and frustrated...

    UPDATE: I tried it again and it seems to have worked.
    05-08-2012 02:32 AM
  6. jess.hickey's Avatar
    Using that code will still show as my carrier under your voicemail settings but your calls should be forwarded to your google voice...give yourself a test call
    05-08-2012 04:39 AM
  7. lsutigers03's Avatar
    Go into the settings at voice.google.com and deactivate your phone and reactivate it. The deactivate step will give a code to enter in your phone...skip that. Next, click on activate this phone and it will give you a string to dial...something like *004*yourgooglevoicenumber# or something like that. That should fix ya up.
    This worked for me. I tested it and got a text notification a few seconds after I left a message and I was able to hear my message.
    05-08-2012 09:36 AM
  8. shane.green's Avatar
    I'm not sure it worked for me yet, but I did learn that--at least in my case--dialing any of the codes to enable/disable GV gave an error message *when* connected to wifi (i.e., WiFi calling in effect). The same codes gave no errors when I turned off wifi; in fact they indicated success.
    05-11-2012 09:07 PM
  9. bikeracer4487's Avatar
    Well this WORKS in that it sets the Call Forwarding for busy and unanswered incoming calls to your google voice number, and then the Google Voice app will notify you when you have a voicemail, but it just bypasses the phone's voicemail, because the phone still thinks you're using AT&T's service. I've heard elsewhere that HTC blocks users from changing the answering service...not sure if there's way around it...
    05-16-2012 03:54 PM
  10. live4nyy's Avatar
    The voicemail settings in Android is confusing. The part most people should worry about is "Call forwarding". That is where the numbers need to be correct for calls to go to your GV. Just entering the "*004*..." code works to remedy that.

    As far as the actual "Voicemail settings" in the menu, that is to tell the phone what to call when you are checking your voicemail, eg. pressing and holding #1. If you happened to have the GV app then this is not a problem but for people who like to call in to listen to their voicemails then I have found that if you enter the MMI code and the call forwarding settings have changed correctly then you can go to "Voicemail settings" and when you select "Google Voice" immediately press the "Home" button. That should make it stick, just go back and take a look to see if it did. Hope this helps.
    05-16-2012 04:29 PM
  11. bikeracer4487's Avatar
    Well, immediately pressing the home button prevents the error message from appearing, but when I go back to the settings it's still set to "My carrier"
    05-16-2012 04:31 PM
  12. live4nyy's Avatar
    Well, immediately pressing the home button prevents the error message from appearing, but when I go back to the settings it's still set to "My carrier"
    Is this after you had already gone through the "Setup" in the GV app and after you have successfully changed the "Call forwarding" settings using the *004* code?

    Try it a couple of times. It has worked for me on my last 4 phones (Atrix, Skyrocket, Note, and One X)
    05-16-2012 04:34 PM
  13. bikeracer4487's Avatar
    Yeah. And I can actually seem to change call forwarding numbers at will through the settings menu, though *004* works as well...
    05-16-2012 04:35 PM
  14. sniffs's Avatar
    One thing I noticed is that I was also receiving this error when it was on LTE.

    My phone suddenly dropped into HSPA+ and for some reason when I tried after the failed message, it stuck! now it seems to be working..


    EDIT: NM, it seemed to stick, but a few minutes later I went in and it was back to My Carrier.

    So what does "deactivate/activate" mean.. delete the # entirely from the list and add new?
    05-16-2012 04:38 PM
  15. bikeracer4487's Avatar
    Huh...well I ended up hitting home when I got the FIRST error message and that made the Google Voice option stick, but when I press and hold #1 it still dials the AT&T mailbox so I don't think the setting ACTUALLY stuck
    05-16-2012 04:47 PM
  16. live4nyy's Avatar
    Yeah. And I can actually seem to change call forwarding numbers at will through the settings menu, though *004* works as well...
    One thing I noticed is that I was also receiving this error when it was on LTE.

    My phone suddenly dropped into HSPA+ and for some reason when I tried after the failed message, it stuck! now it seems to be working..


    EDIT: NM, it seemed to stick, but a few minutes later I went in and it was back to My Carrier.

    So what does "deactivate/activate" mean.. delete the # entirely from the list and add new?
    Sorry I couldn't be more help, it works for me everytime.

    05-16-2012 04:48 PM
  17. bikeracer4487's Avatar
    Also, I'm able to change the voicemail number......seems ridiculous that I can't make the phone recognize the google voice app if I'm able to change all the settings it's trying to change anyway... Incidentally, does anyone know a way to find the AT&T voicemail number after removing it from your phone?
    05-16-2012 04:55 PM
  18. live4nyy's Avatar
    Also, I'm able to change the voicemail number......seems ridiculous that I can't make the phone recognize the google voice app if I'm able to change all the settings it's trying to change anyway... Incidentally, does anyone know a way to find the AT&T voicemail number after removing it from your phone?
    Here is a couple links to the same list:

    Voicemail Access Numbers

    Voicemail pilot numbers (a.k.a. local access or 'backdoor' numbers)
    05-16-2012 05:04 PM
  19. wraith404's Avatar
    Take it back, it has multitasking issues anyway because of the CrapSense. Or is it SenseCrap?
    05-16-2012 05:56 PM
  20. Siberianhusky's Avatar
    I have setup GV fine and the messages come to the phone, but are you guys getting sound notifications that the message was left or even that there is a message in the box. I have to check manually after a missed call. I have checked all the notification settings in the app
    05-16-2012 07:42 PM
  21. jspidey's Avatar
    I had the same issue. I walked through the setup through the GVoice app twice and it said it failed both times. However, despite the messages that it failed, my voice mails are indeed going to GVoice.
    05-17-2012 07:46 AM
  22. stoned2676's Avatar
    This won't get rid of the error message, but it will get google voice working.

    go to 'settings' > 'calls' > 'call forwarding'

    change all of the numbers to your google voice number, include country code and area code.
    05-22-2012 03:32 PM
  23. oldmanjenkins's Avatar
    I have gotten errors messages when it tries to get the voicemail settings. "If this problem persists......."

    Sent from my HTC One X using Android Central Forums
    05-24-2012 12:09 PM
  24. Ethere's Avatar
    I know this is an old thread, but has anyone found out how to get this to actually work? I know it "technically" still works as far as voicemails coming through to GV, but what about it showing correctly in the settings?
    09-04-2012 07:58 AM
  25. loraque's Avatar
    Go to your Google Voice page on a computer.

    Click on the GEAR for settings. Right there on the first page is a button to activate the phone (or deactivate if already working). Will give you the dialcode to enter on your phone.

    This works perfect, but the app will not be able to read the settings and set it up from the phone. Must do from a computer.
    09-04-2012 09:51 AM
26 12
LINK TO POST COPIED TO CLIPBOARD