1. myrddincox's Avatar
    Folks - I recently noticed Maps eating up my battery, even when I was not using the Maps app. After some poking around, I saw this showing up in a variety of forums, and it did not necessarily seem to be restricted to the HOX.

    However, I did pin the issue down on my HOX, and thought I would pass my experience along. I managed to figure out that it was the "enable location" option in the stock browser that would cause the GPS to run incessantly (showing up as "Maps"). I was able to narrow it down because I normally use Chrome, and happened to fire up the stock browser right before the issue appeared. After some trial and error, I was able to verify the connection.

    Hope this helps somebody!
    08-12-2012 03:32 PM
  2. Lanhoj's Avatar
    Cool, thanks!

    In case the drain isn't H0X-specific I just disabled it on my GNex.


    Sent from my Galaxy Nexus using Android Central Forums
    08-12-2012 03:52 PM
  3. icebike's Avatar
    However, I did pin the issue down on my HOX, and thought I would pass my experience along. I managed to figure out that it was the "enable location" option in the stock browser that would cause the GPS to run incessantly (showing up as "Maps").
    Great find, but its not the whole answer. I have that option turned on, and always have, and NEVER have I seen any significant battery use by maps.

    So there must be some other issue combined with that setting that is causing battery use.

    In Settings / Location, I have all buttons checked. Is that what you have as well?

    Do you exit your browser with it sitting on a page that tracks location or uses location? Especially if that page might refresh in the background.

    (Google News does both, as do others. To see the sites that do this, open the browser and go to Menu / Settings / Privacy / Enable Location. Check or uncheck the sites you allow, or turn the feature off totally).

    Some say the stock HTC Clock/Weather app uses this as well if it is set incorrectly.
    08-12-2012 05:13 PM
  4. myrddincox's Avatar
    Yes - all four of the options under the Settings/Location are checked.

    I went through a bunch of apps that I thought might be trying to track location before tying it to the browser. It was actually via the Android Central app (where I clicked some link) that started the stock browser initially. Don't remember exactly what the site was, but I would guess that you are probably right that it was some site that was the culprit.

    AllI know for sure was that disabling the "enable location" in the browser immediately cleared up the issue.
    08-12-2012 08:31 PM
  5. rnich120's Avatar
    You need to make sure that its taken out of your recent apps menu because thats what drains your battery as it seems to be one of the apps that doesnt have an issue about being put into the background.

    It will continue to keep your position up to date so make sure its completely closed.
    08-13-2012 01:38 PM
  6. Gekko's Avatar
    or just leave GPS off and only toggle it on when you need it.

    i do that with WIFI, GPS, BT, and LTE.
    08-14-2012 05:44 AM
  7. hc_1540's Avatar
    It was actually via the Android Central app (where I clicked some link) that started the stock browser initially. .
    Don't want to derail the topic but I see this every so often when browsing AC using Chrome on my One S. I'll click on a news item and the stock browser loads. Anyone know why this is??
    08-14-2012 06:07 AM
  8. myrddincox's Avatar
    Don't want to derail the topic but I see this every so often when browsing AC using Chrome on my One S. I'll click on a news item and the stock browser loads. Anyone know why this is??
    I have noticed several apps that default to the stock browser when any sort of link is clicked. I haven't found a way to set a default browser yet (haven't really looked too hard), but it is weird that this would happen from Chrome.

    Check that: Settings/App Associations... changes the default browser.
    08-14-2012 07:55 AM
LINK TO POST COPIED TO CLIPBOARD