1. quicksilver53's Avatar
    Hi all. I have a problem with my one x. Recently whewindow the asks for connection type does not come up on my phone's screen. Instead "usb debugging on" comes up in the status bar. I have tried doing a factory reset, but this did not fix it. At no time did I check the box indication don't ask again. This causes problems when trying ti transfer videos from my PC onto my phoe's storage. I also want to root it but I can not select charge only. Does anyone know how to fix this? Thanks.
    02-19-2013 02:24 AM
  2. quicksilver53's Avatar
    No clue anyone? I guess maybe I'll have to contact HTC and see if they can offer any solution.

    Sent from my HTC One X using Android Central Forums
    02-20-2013 02:28 AM
  3. stormchaser407's Avatar
    Go to settings, select develop options, uncheck the usb debugging always on. That should solve the issue , Another area to check if that fails is go to settings and select connect to PC and you will see choices like default connection type etc...
    02-20-2013 02:40 AM
  4. quicksilver53's Avatar
    I keep unchecking usb debugging, but when I plug it into my PC it checks itself back on despite developer options being off. Also on my one ex I do not have the Connect to PC option listed in settings but my evo 3d does. Could this setting be gone with the Jelly Bean update? Thanks.

    Sent from my HTC One X using Android Central Forums
    02-20-2013 05:50 AM
  5. patrixl's Avatar
    Yes the option disappeared with the JB update.

    And I have the same problem with usb debugging . Considering doing a factory reset to see if it changes anything.
    02-20-2013 07:47 AM
  6. Bizzle69's Avatar
    Having debugging on isn't a bad thing, guys... on your pc, while your phone is connected, go to device manager, right click the phone and update drivers.. it will now show as a media device in My Computer, and you can access files the way you did before. I have Windows 7, and a window pops up automatically asking what I want to do>> " open as.., folder, camera, etc

    Note: this will not turn USB debugging off.. it's a good thing that it is on, gives you the opportunity to unbrick your device if it ever becomes unresponsive
    quicksilver53 likes this.
    02-20-2013 08:38 AM
  7. quicksilver53's Avatar
    Thanks Bizzle and Patrix. I spoke to HTC this afternoon and they said that the connect to pc option was left out of the JB update. I tries a factory reset and it will not change anything.

    Sent from my HTC EVO 3D X515a using Android Central Forums
    02-20-2013 02:35 PM
  8. PMRR's Avatar
    I actually think it is a pretty bad thing to have debugging always on for those of us who have rooted our phone and keep all our life and passwords on it. If anyone knows how to tweak it off so it doesn't auto-appear it will be greatly appreciated!
    05-10-2013 10:54 AM
  9. anoopmahobia_820's Avatar
    same problem with my htc desire 820s

    i am not able to open developer option in my phone without connecting it to a pc

    i am not able to poweoff aur reboot my phone

    not able to do factory reset also pls help me
    11-07-2015 01:14 AM

Similar Threads

  1. How do you turn on USB Debugging?
    By greydarrah in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 12-07-2012, 10:20 PM
  2. Replies: 1
    Last Post: 07-02-2012, 03:52 PM
  3. Usb debugging?
    By rback15 in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 09-03-2010, 09:04 PM
  4. If the USB port is on top...
    By Shadnic in forum Sprint Epic 4G
    Replies: 8
    Last Post: 07-14-2010, 12:20 PM
  5. switching usb connection types on the fly
    By hlazar in forum HTC EVO 4G
    Replies: 2
    Last Post: 06-14-2010, 09:09 AM
LINK TO POST COPIED TO CLIPBOARD