07-11-2014 07:59 PM
26 12
tools
  1. yarch's Avatar
    Rooted, S-off, TWRP2.5.0.0, Android 4.1.1, sense 4+, 3.18 firmware

    This phone has always had unsatisfactory battery life, but recently it has been downright stupid bad. I figured when I rooted I would be able to straight up remove bloat apps that I never use and see an improvement, but it wasn't that easy and I haven't gotten up to speed on custom ROMs yet and which one to use; so I used App Quarantine to freeze them. Over the past two weeks or so I've been seeing battery drain as bad as 40% in 3 hours with minimal use. I just unplugged my phone 16 minutes ago and it has used 5% of the battery - with the exception of setting an alarm, I haven't used it. Usage shows Chrome taking up 33% - fair enough, when it's awake I use the internet a lot, 2nd is Android System with 10%, then Handcent SMS with 6% and Android OS with 5%. I am really quite puzzled here; because it looks like there is nothing there that could draw that much power. The only things consistently and by choice running in my background are a screen brightness bar, gmail and handcent. I have auto update and notifications disabled for all social media bloatapps, which I never use anyway. I'm not using any widgets, either. What the hell is going on?
    02-27-2014 08:19 PM
  2. Saukrateaz's Avatar
    Were any of the apps youve "frozen" running in the background at the time you took them out? Perhaps they are stuck open, for lack of better words, causing more of a drain.
    02-28-2014 07:21 AM
  3. yarch's Avatar
    Is that even possible? The apps would stop running when I reboot the phone anyway.
    02-28-2014 10:34 PM
  4. wizzrah's Avatar
    Is that even possible? The apps would stop running when I reboot the phone anyway.
    I would suggest updating your version of TWRP and flashing Android 4.4. I personally think it has good battery life with Kit Kat.
    03-01-2014 11:17 PM
  5. yarch's Avatar
    I would suggest updating your version of TWRP and flashing Android 4.4. I personally think it has good battery life with Kit Kat.
    So I went to TWRP 2.7. Which recovery would you recommend for flashing Android 4.4?
    05-13-2014 06:09 PM
  6. wizzrah's Avatar
    So I went to TWRP 2.7. Which recovery would you recommend for flashing Android 4.4?
    2.7 has lots of problems. I use 2.6.3.0 with selinux.


    Wizzrah | AT&T HTC One XL | Tapatalk
    05-13-2014 07:00 PM
  7. yarch's Avatar
    2.7 has lots of problems. I use 2.6.3.0 with selinux.
    Noted and heeded. And which ROM?

    (edit)
    Not which ROM are you running, but what would you recommend overall for an knowledgeable user but non-developer.
    05-13-2014 07:17 PM
  8. wizzrah's Avatar
    Noted and heeded. And which ROM?

    (edit)
    Not which ROM are you running, but what would you recommend overall for an knowledgeable user but non-developer.
    I have not found the perfect 4.4 ROM yet. Right now I'm running Karbon Kat.

    Wizzrah | AT&T HTC One XL | Tapatalk
    05-13-2014 07:47 PM
  9. yarch's Avatar
    I have not found the perfect 4.4 ROM yet. Right now I'm running Karbon Kat.
    Ok. Until I find out a little more about the current 4.4 ROMS I'm running Cyanogenmod 10.2.1 (4.3.1). The extremely poor battery life issue was intermittent and odd, I'll wait and see what happens with this ROM.
    05-14-2014 07:17 PM
  10. numskull223's Avatar
    I have been having the same problem, i noticed that the battery was lasting about 4 hours. I forced closed all apps, ex facebook, weather channel app ect, and rebooted it. And it been fine for about a week now. But it does randomly shuts ofc while I talking on the phone... Haven't figured that one out yet.

    Posted via Android Central App
    05-16-2014 06:29 AM
  11. wizzrah's Avatar
    Ok. Until I find out a little more about the current 4.4 ROMS I'm running Cyanogenmod 10.2.1 (4.3.1). The extremely poor battery life issue was intermittent and odd, I'll wait and see what happens with this ROM.
    4.4 has good battery life. You probably have to adjust the CPU speed.

    Wizzrah | AT&T HTC One XL | Tapatalk
    05-16-2014 10:36 PM
  12. wizzrah's Avatar
    I have been having the same problem, i noticed that the battery was lasting about 4 hours. I forced closed all apps, ex facebook, weather channel app ect, and rebooted it. And it been fine for about a week now. But it does randomly shuts ofc while I talking on the phone... Haven't figured that one out yet.

    Posted via Android Central App
    What ROM are you running?

    Wizzrah | AT&T HTC One XL | Tapatalk
    05-16-2014 10:37 PM
  13. numskull223's Avatar
    What ROM are you running?

    Wizzrah | AT&T HTC One XL | Tapatalk
    Viper 4.2
    I'm thinking of going to CandyKat.
    Your website down?

    Posted via Android Central App
    05-17-2014 09:33 AM
  14. wizzrah's Avatar
    Viper 4.2
    I'm thinking of going to CandyKat.
    You website down?

    Posted via Android Central App
    Which one?

    Wizzrah | AT&T HTC One XL | Tapatalk
    05-17-2014 11:15 AM
  15. numskull223's Avatar
    Which one?

    Wizzrah | AT&T HTC One XL | Tapatalk
    If you mean which CandyKat, it's 4.4.2/sense 5.
    I'm making sure I can use beastmode and twrp 2.6.3

    Posted via Android Central App
    05-17-2014 11:30 AM
  16. numskull223's Avatar
    Ok. Until I find out a little more about the current 4.4 ROMS I'm running Cyanogenmod 10.2.1 (4.3.1). The extremely poor battery life issue was intermittent and odd, I'll wait and see what happens with this ROM.
    Try candykat 4.4 so for its solid

    Posted via Android Central App
    05-18-2014 07:29 AM
  17. numskull223's Avatar
    Try candykat 4.4 so for its solid

    Posted via Android Central App
    Scratch that, it has issues of freezing while changing....back to Venom 4.2 for me.

    Posted via Android Central App
    05-18-2014 01:57 PM
  18. numskull223's Avatar
    Which one?

    Wizzrah | AT&T HTC One XL | Tapatalk
    Wizzrah, A while back I had this problem, when my screen would go off, and I would turn the screen on I would not have a signal.....I went to settings>power, and unchecked the box for turning off data when its inactive. But it still shuts off the data....Is there something else I am forgetting. I went back to the 4.2 viper rom.
    05-18-2014 05:46 PM
  19. wizzrah's Avatar
    Wizzrah, A while back I had this problem, when my screen would go off, and I would turn the screen on I would not have a signal.....I went to settings>power, and unchecked the box for turning off data when its inactive. But it still shuts off the data....Is there something else I am forgetting. I went back to the 4.2 viper rom.
    Were you using the stock kernel or a custom kernel?

    Wizzrah | AT&T HTC One XL | Tapatalk
    05-18-2014 05:55 PM
  20. numskull223's Avatar
    Were you using the stock kernel or a custom kernel?

    Wizzrah | AT&T HTC One XL | Tapatalk
    Beastmode 3.5+

    Posted via Android Central App
    05-19-2014 04:06 AM
  21. numskull223's Avatar
    I think I got it. I flashed a stock kernel, then flashed beastmode again...so far so good.

    Posted via Android Central App
    05-19-2014 05:48 PM
  22. yarch's Avatar
    So the CM 10.2.1 ROM is ok but it has a couple of pretty bad flaws and support is nonexistent. When I receive a call it only plays my ringtone once, and I am having some pretty frustrating wifi issues. It won't automatically connect to a network most of the time and to manually connect I have to open the connect dialog and hit "connect" between 2 and 8 times, the connection also drops while the phone is sleeping but only sometimes. There is no pattern whatsoever to how and why. I would go to a different ROM but I do not have time to go through that process right now because life takes priority.
    06-09-2014 09:06 PM
  23. wizzrah's Avatar
    So the CM 10.2.1 ROM is ok but it has a couple of pretty bad flaws and support is nonexistent. When I receive a call it only plays my ringtone once, and I am having some pretty frustrating wifi issues. It won't automatically connect to a network most of the time and to manually connect I have to open the connect dialog and hit "connect" between 2 and 8 times, the connection also drops while the phone is sleeping but only sometimes. There is no pattern whatsoever to how and why. I would go to a different ROM but I do not have time to go through that process right now because life takes priority.
    Try TeamEOS ROM. It's worth it if you have the time to flash it. I have had no problems with this ROM.

    [ROM][KK][AOSP][TEAMEOS] OFFICIAL Evita Nightlies - xda-developers

    It has been phenomenal. You'll need TWRP 2.7 though.
    06-10-2014 01:05 PM
  24. Timmaaa's Avatar
    More specifically the unofficial TWRP 2.7.0.8 by pandasa123 on XDA, or the official TWRP 2.7.1.0 from the TWRP goo.im page.

    Sent from my Evita
    wizzrah likes this.
    06-10-2014 01:20 PM
  25. wizzrah's Avatar
    More specifically the unofficial TWRP 2.7.0.8 by pandasa123 on XDA, or the official TWRP 2.7.1.0 from the TWRP goo.im page.

    Sent from my Evita
    Spot on!

    http://forum.xda-developers.com/show....php?t=2738246
    06-10-2014 03:13 PM
26 12

Similar Threads

  1. Replies: 2
    Last Post: 03-08-2014, 06:26 AM
  2. Replies: 1
    Last Post: 03-01-2014, 09:03 PM
  3. ME172V "Temporarily avoiding poor connection"
    By brendensen in forum General Help and How To
    Replies: 4
    Last Post: 02-28-2014, 06:27 PM
  4. Do I need a new Battery
    By Kevi333 in forum Samsung Galaxy S3 Mini
    Replies: 5
    Last Post: 02-28-2014, 11:12 AM
  5. Nexus 5 Hot/Poor Battery Life? (4.4.2)
    By koreandude in forum Google Nexus 5
    Replies: 2
    Last Post: 02-27-2014, 07:25 PM
LINK TO POST COPIED TO CLIPBOARD