Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default Wlan rx wake

    Wlan rx wake-screenshot_2013-12-14-08-10-18.jpg

    So i have noticed that on standby my phone seems to losing more battery than it should overnight while on wifi. I checked my gsam and came across the attached wake lock issue.

    Any suggestions? The little research I've done suggests it's connected to wifi and possibly a router problem. But I'm not quite sure.

    Any advice is appreciated.

    Posted via Android Central App
  2. #2  

    Default Re: Wlan rx wake

    I was having the same issue and made a few changes. I set persistent IP reservations on my router for all devices, a little different than static IPs since I don't want to hard code IPs into all my devices, it basically hands out the same IP to my devices each time. The way you do this will depend on your router. On my Netgear it was in Advanced, Setup, LAN Setup, Address Reservation.

    Then I changed the phone's settings in WiFi, Advanced, "Keep Wi-Fi on during sleep" to "Only when plugged in." That made the wlan wakelocks go down to almost nothing.
  3. Thread Author  Thread Author    #3  

    Default Re: Wlan rx wake

    thanks. i have a westell dsl router, not quite seeing where i can make the adjustment. i just tried changing the wifi on the phone to static. will this make a difference? also, if i adjust the keep wifi on to only when plugged in, what does that do? and won't it simply revert to mobile data?
  4. #4  

    Default Re: Wlan rx wake

    Plug it in at night.
    HTC One (M7) Developer Edition - Android Revolution HD Google Edition ROM 4.4.2 - Elemental kernel - ATT | Google Nexus 7 - Stock ROM 4.4.2 (plus tethering) - Elemental kernel - ATT | Apple iPad 2nd Gen 7.1 - Verizon
  5. #5  

    Default Re: Wlan rx wake

    Quote Originally Posted by henryfool3 View Post
    thanks. i have a westell dsl router, not quite seeing where i can make the adjustment. i just tried changing the wifi on the phone to static. will this make a difference? also, if i adjust the keep wifi on to only when plugged in, what does that do? and won't it simply revert to mobile data?
    Your router might not support static reservations. I'm not sure it's really a great fix anyway. It was just one of the things I tried.

    Yes, setting wifi always on to only when plugged in will revert to mobile data. You can pretty easily limit mobile data usage though with the smart sync feature for mail accounts and only updating apps over wifi. But as adriandb notes just plug it in. These aren't NiCad batteries, modern phones are meant to be charged. Follow the ABCs of charging, Always Be Charging. USB chargers are cheap and abundant.

Similar Threads

  1. Power button wakes screen with delay or longpress
    By Gauhar Mahmood Azeem in forum Google Nexus 7 Tablet (2013)
    Replies: 4
    Last Post: 03-01-2014, 04:29 AM
  2. Since KitKat doesn't want to wake up from sleep
    By the gator in forum Google Nexus 10 Tablet
    Replies: 6
    Last Post: 12-24-2013, 10:16 AM
  3. Replies: 5
    Last Post: 12-15-2013, 05:23 AM
  4. Screen doesn't wake when text messages come through?!?!?
    By shaneontherocks in forum Sprint Samsung Galaxy S4
    Replies: 1
    Last Post: 12-10-2013, 10:31 PM
  5. Google Services Waking device
    By ventura726 in forum LG G2
    Replies: 0
    Last Post: 12-09-2013, 02:05 AM

Posting Permissions

B