Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  

    Question unknown aritist on Poweramp and Neutron Music Player

    Since having the HTC One M7 I've noticed more and more lately that on Poweramp i'm having the dreaded unknown artists tag issues on MP3's. this problem is getting worse and it happens more often now. the only fix is to re rip the CD's and sync but most of my music is downloaded from the internet. thing is the tags are fine and i always edit my tags on Itunes and then sync with isyncr over wifi. I had to re rip a few albums but then during syncing other albums that were fine got messed up so i resynced and now the ones i re-ripped is already messed up again. I tried other players but none are as good as Poweramp except for PlayerPro which works fine. I am trying Neutron Music Player since i read so much about it and I love it but it has the same issue as Poweramp. the stock player works fine btw. Also Rocket Player, companion to isyncr, works fine but the EQ makes be want to vomit it sounds so bad. i don't know what the problem is but read it's a common one for android since way back. so disappointing. I love Android but now i question whether i should go with Windows Phone or Iphone. but i don't think i would be as happy in a walled in OS. if a cheap MP3 player can work right why can't a $600 phone read the darn songs right? is there any fix? thanks.

Similar Threads

  1. Is the Nexus 6 still on to be announced in September?
    By Harry Wild in forum Google Nexus 6
    Replies: 25
    Last Post: 09-24-2014, 10:49 AM
  2. Replies: 3
    Last Post: 09-22-2014, 12:17 AM
  3. How much have you spent on your G3?
    By bembol in forum LG G3
    Replies: 37
    Last Post: 09-08-2014, 01:40 AM
  4. New and Considering Android: G3 vs HTC M8
    By metrix in forum General News & Discussion
    Replies: 48
    Last Post: 08-29-2014, 02:26 PM
  5. Cant turn off voice and buttons now unresponsive too!
    By lottiekins1 in forum Moto G (2013)
    Replies: 1
    Last Post: 08-18-2014, 11:13 PM

Posting Permissions