1. katelate13's Avatar
    I've looked over the other forums and have had no luck. I just switched over to my HTC Vivid last night and everything was working just fine. This morning I went to respond to a text and it came up with a clock looking icon and when I go to the status it says pending. I'm recieving messages but just can't respond and I'm super frustrated! Can someone please help!?
    09-02-2012 09:05 PM
  2. bryann22's Avatar
    I've looked over the other forums and have had no luck. I just switched over to my HTC Vivid last night and everything was working just fine. This morning I went to respond to a text and it came up with a clock looking icon and when I go to the status it says pending. I'm recieving messages but just can't respond and I'm super frustrated! Can someone please help!?
    did you try powering down, and then taking the battery out for a min or so and restarting?
    09-02-2012 09:12 PM
  3. katelate13's Avatar
    I restarted it, powered it down, took out the battery and sim card and even had it off for a few hours. no luck.
    09-02-2012 09:15 PM
  4. bryann22's Avatar
    Go to messaging. Click Menu then click Settings and uncheck "Read Reports" . This should fix it the issue

    09-02-2012 09:22 PM
  5. katelate13's Avatar
    When I gO to messages->settings-> it shows notification, sms, mms and general but I can't seem to find a reports option.
    09-02-2012 10:02 PM
  6. bryann22's Avatar
    anything in those settings?
    09-02-2012 10:05 PM
  7. katelate13's Avatar
    It was easier to take screenshots and show you what is checked and what isnt...
    09-02-2012 10:25 PM
  8. katelate13's Avatar
    I hope you can see the screen shots! Thought it was easier.
    09-02-2012 11:42 PM
  9. apoc53's Avatar
    From your screen shots, it looks like you're from the Puget Sound area, but I don't see anything really wrong. Didn't know T-Mobile was selling Vivids? Anyway, I have texting disabled through AT&T since there are free alternatives and I'm fine with texting from a number different from the one I call from. You might need to contact T-Mobile to see if they know why traffic can come in but not out.

    Sent from my HTC PH39100 using Android Central Forums
    09-03-2012 01:17 AM
  10. apoc53's Avatar
    Edited:</Stupid Question>
    Disregard -thx

    Sent from my HTC PH39100 using Android Central Forums
    09-03-2012 01:19 AM
  11. katelate13's Avatar
    It's an unlocked AT&T phone.
    09-03-2012 01:49 AM
  12. katelate13's Avatar
    Is there some update I'm missing?
    09-03-2012 01:50 AM
  13. OperationA7X's Avatar
    Is there some update I'm missing?
    Whoever or however it was unlocked, obviously forgot to set something...what was the name of it...also, did the previous owner (If any) or you ever force stop "Messages" or "Dialer Storage" or "kill" the app with a task killer? Any of these should explain why your messages aren't sending. And as for the Vivid... sounds like a bad unlock...but that's just my opinion. Any unlocked phone I've ever owned (myTouch 3G Slide, Motorola Flipside) was done from the company. Good luck.
    bryann22 likes this.
    09-03-2012 03:49 AM
  14. bryann22's Avatar
    Whoever or however it was unlocked, obviously forgot to set something...what was the name of it...also, did the previous owner (If any) or you ever force stop "Messages" or "Dialer Storage" or "kill" the app with a task killer? Any of these should explain why your messages aren't sending. And as for the Vivid... sounds like a bad unlock...but that's just my opinion. Any unlocked phone I've ever owned (myTouch 3G Slide, Motorola Flipside) was done from the company. Good luck.
    Dead on

    Sent from my DROID RAZR using Android Central Forums
    09-03-2012 07:01 PM
  15. katelate13's Avatar
    It was from unlockthatphone.
    09-03-2012 11:12 PM
  16. katelate13's Avatar
    After unlocking the phone the messaging worked! This happen after attaching my data plan ):
    09-03-2012 11:47 PM
  17. OperationA7X's Avatar
    After unlocking the phone the messaging worked! This happen after attaching my data plan ):
    Can you receive MMS messages? If you can, I need to think of something else. if you can't, then more than likely, the unlock + SIM Card are incompatible with mobile data.
    09-03-2012 11:57 PM
  18. katelate13's Avatar
    I receive them. Just can't send. Keeps saying pending and never sends.
    09-04-2012 12:10 AM
  19. katelate13's Avatar
    I was going to factory reset it. I was playing with the setting yesterday while it still worked and I don't know if I may have changed something on accident.
    09-04-2012 12:11 AM
  20. katelate13's Avatar
    Do I need to install a ROM?
    09-04-2012 12:42 AM
  21. OperationA7X's Avatar
    Do I need to install a ROM?
    If you install a custom ROM, I'm not sure if you'll lose your unlock or not...I'd say do a Factory Reset, just back up your Apps, Text Messages, and Contacts and just do it and hope it works out.
    09-04-2012 12:49 AM
  22. OperationA7X's Avatar
    By the way, nice Purple Passion HTC skin.
    09-04-2012 12:52 AM
  23. bryann22's Avatar
    I wouldn't flash a ROM especially if you don't know what your doing,if your stock just reset but BACKUP first,see if that helps

    Sent from my DROID RAZR using Android Central Forums
    09-04-2012 08:38 AM
  24. Lisa83's Avatar
    I'm having the exact same issue. Upgrade my AT&T phone yesterday, texts worked just fine all evening. This morning I can recieve texts but not send them. Did you ever find a way to correct it? I already spoke to the AT&T helpdesk, they say it's nothing on their end. They want me to take the phone back to the store because "its faulty" but if i'm not the only one having this issue how would a replacement vivid solve the problem??
    10-14-2012 04:00 PM
  25. Lisa83's Avatar
    Figured it out! have to turn of the SMS delivery reports. not capable on AT&T
    10-14-2012 04:35 PM
LINK TO POST COPIED TO CLIPBOARD