Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  
    Seth Warmen's Avatar

    Posts
    3 Posts
    Global Posts
    1 Global Posts

    Default Huawei Ascend P6 - Can't Connect To My Wi-Fi Network

    I finally got my hands on a Huawei Ascend P6 yesterday and was so excited to use it!

    The wifi worked fine until I disconnected for the first time. Since then the phone never wanted to reconnect to our private network no matter what I tried. I tried switching the wifi off and back on again. Tried switching the phone on and off again multiple times. I even tried to use a static IP address but that also didn't seem to work. I also tried switching the 'Wi-Fi optimisation' off as well as setting the 'Keep Wi-Fi on during sleep' to 'Always'.

    I'm aware that this could be an android problem instead of an Huawei problem as Android is quite well known on Google for it's wifi problems. With one of my previous phones (HTC Wildfire) I've experienced the infamous wifi-loop many times (Connecting, Fetching Ip, Connected, Disconnected, Connecting...). But I never experienced that on my Xperia S (although I have experienced different wifi problems on it (i.e., IP clashes, etc.)).

    The problem is not at the modem. The phone itself is not connecting AT ALL to the wifi.
    It is however connecting to my mobile network.

    Is there anyone that has a known solution for me? I've read so many threads (apple, windows AND android) and still haven't found a solution.

    Thank you so much for taking time out of your schedule to read and reply to this message.

    Sincerely,
    S
  2. #2  

    Default Re: Huawei Ascend P6 - Can't Connect To My Wi-Fi Network

    Hey Seth,
    I have exactly the same problem, but I have no clue what to do, and do not even find any solution yet.
    If your problem finally got fixed, please share it!
    many thanks in advance!
    J.
  3. #3  
    rfah's Avatar

    Posts
    1 Posts

    Default Re: Huawei Ascend P6 - Can't Connect To My Wi-Fi Network

    Quote Originally Posted by Seth Warmen View Post
    <clip> .... I'm aware that this could be an android problem instead of an Huawei problem as Android is quite well known on Google for it's wifi problems .... </clip>
    I have always had HUAWEI products and have been totally satisfied with price and performance ... UNTIL NOW.

    Both my wife and i decided to upgrade our Huawei G300 phones to the P6 .. as we wanted a bigger screen and the latest Android OS [JellyBean] ... but how disappointed we are!!! The continual WiFi connection problems make the phone A PAIN TO USE!!! I feel like throwing it against the wall!! ..

    Leaving an app for a few minutes and returning to it just the be told "NO NETWORK CONNECTION" while other devices connected via WiFi are working normally .. and going to the Wi-Fi settings on the P6 the connection shows up as connected!! Nothing i do can change this spasmodic behaviour!! It is DEFINITELY the device, as we have had no probs with WiFi prior to changing phones ... PLUS the same behaviour happens with BOTH new phones, which work of separate WiFi networks geographically separated!!

    We have both upgraded the firmware from B106, which the phone came with, to B111 ... the latest upgrade that is available via the system GUI! But NOTHING!! Both phones still behave the same!

    I never experience this problem with the Huawei G300!! .. it always transferred seamlessly to WiFi upon coming home and operated flawlessly while WiFi was up.

    It would appear that with the P6 there might be a hardware problem as suggested by Kris Carlton.

    However, i think that ONE CONTRIBUTOR to this issue might be the WiFi Advanced setting 'Avoid poor connections', because de-selecting this default setting (every time you change WiFi sources this defaults back to being ON) ... but from limited testing it WOULD APPEAR that the issue is improved to some degree .... however, it is still there .. and appears to occur if, after some constant use of an APP, for example Google Translate, the APP is left to 'idle' for a period of time while the phone goes to sleep .. upon waking up and activating the APP again am told that there is no connection ... EVEN THOUGH upon examining the WiFi status being told it is connected!!!

    At some point ... undeterminable ... maybe a minute or so the APP resumes normal operation OR if a different APP is loaded that uses the WiFi connection .. the connection seems to 'wake-up', even though it already appears to be connected!!

    But i cant be sure of the absolute nature of these observations as nothing seems to be reproducible with an absolute degree of certainty!

    UNLESS somebody else has been able to solve this through some combination of System Settings .. we are going to push for a full refund and change brands!!

    Has anyone been able to solve this issue???

    Frustrated & Disappointed
    Last edited by NothingIsTrue; 12-29-2013 at 02:15 AM. Reason: Removed external blog link.
  4. #4  

    Default Re: Huawei Ascend P6 - Can't Connect To My Wi-Fi Network

    I am too pissed of with this annoying wifi bug of ascend p6. I can browse in chrome but cant check gmail or any other apps, it says i am not connected to network. As someone already mention b111 version is not a help I am going to try leaked b125 version. Hope this would help. here is the link.
  5. #5  

    Default Re: Huawei Ascend P6 - Can't Connect To My Wi-Fi Network

    IT JUST WORKED FOR ME. I have updated my p6 with leaked b225 version and since then I have no problem with wifi. here is the link to download the

Similar Threads

  1. Samsung Galaxy S3 - My Download Notifications won't Clear
    By Bingette in forum Samsung Galaxy S3
    Replies: 31
    Last Post: 01-30-2014, 11:57 AM
  2. Samsung Galaxy Note 3 - Unlocked GN 3 to get
    By nokia4life in forum Samsung Galaxy Note 3
    Replies: 3
    Last Post: 11-14-2013, 04:18 AM
  3. Replies: 3
    Last Post: 11-10-2013, 07:17 PM
  4. Forwarding a single SMS to an email address?
    By Peter Moo Noi in forum Android Applications
    Replies: 0
    Last Post: 11-10-2013, 10:59 AM
  5. Samsung Galaxy SII - gti-9100 Home Key will not go to Idle screen
    By Joe Squalo in forum Samsung Galaxy S II
    Replies: 0
    Last Post: 11-10-2013, 10:40 AM

Posting Permissions

B