1. bobbob1016's Avatar
    I like most of what the Google Keyboard does, except that it insists on typing 'OK' in all caps. Even after I did the hold to save 'Ok', and 'ok'. Is there a way to correct this? Or another keyboard that uses Google's voice recognition?
    11-08-2013 08:42 AM
  2. antilles76's Avatar
    OK is the correct way to spell it.

    I like most of what the Google Keyboard does, except that it insists on typing 'OK' in all caps. Even after I did the hold to save 'Ok', and 'ok'. Is there a way to correct this? Or another keyboard that uses Google's voice recognition?
    11-08-2013 08:51 AM
  3. bobbob1016's Avatar
    I was thinking that. But I still think that the case, in text talk, implies tone. If I read someone saying OK vs ok, I imagine an exclamation mark at the end. Probably just me, but yeah, it's an annoyance.
    ffejjj likes this.
    11-08-2013 09:16 AM
  4. antilles76's Avatar
    I understand the annoyance. Have you tried going into settings for Google keyboard and adding it to the personal dictionary? It may work that way.
    11-08-2013 09:33 AM
  5. ffejjj's Avatar
    I understand the annoyance. Have you tried going into settings for Google keyboard and adding it to then personal dictionary? It may work that way.
    This ^^^

    Sent from my EVO using Android Central Forums
    11-08-2013 09:37 AM
  6. bobbob1016's Avatar
    Maybe it's a setting, but when I hit the plus, I type ok, but can't add it. I don't see how this would work with making it case sensitive though, or does it override the default? As in if I slide type it, would it prefer my 'ok' over their 'OK'?
    11-08-2013 09:48 AM
  7. antilles76's Avatar
    When you go into personal dictionary, click the + to add. Type in the ok on the Type a word line and click next. Click done to shrink the keyboard. Then click the + sign again to save. I'm not sure if it will override the default or not yet. I have not tried it out.

    Maybe it's a setting, but when I hit the plus, I type ok, but can't add it. I don't see how this would work with making it case sensitive though, or does it override the default? As in if I slide type it, would it prefer my 'ok' over their 'OK'?
    11-08-2013 09:59 AM
  8. bobbob1016's Avatar
    When you go into personal dictionary, click the + to add. Type in the ok on the Type a word line and click next. Click done to shrink the keyboard. Then click the + sign again to save. I'm not sure if it will override the default or not yet. I have not tried it out.
    I think something may be up, I did that the first time, and it didn't work. When I tap plus the second time, it still says nothing is there.
    11-08-2013 07:17 PM
  9. antilles76's Avatar
    I would try clearing cache and data in the app. Then try adding it again.

    I think something may be up, I did that the first time, and it didn't work. When I tap plus the second time, it still says nothing is there.
    11-11-2013 07:53 AM
  10. BrettAU's Avatar
    I have a question on this topic as well. Previously when typing "donts" or "thats" my phone would autocorrect by adding the appropriate apostrophe. Now, not only does it not add the apostrophe, it autocorrects to "DONT" or "THATS". Any way to fix this?
    11-12-2013 04:56 PM
  11. eronfaure's Avatar
    I have a question on this topic as well. Previously when typing "donts" or "thats" my phone would autocorrect by adding the appropriate apostrophe. Now, not only does it not add the apostrophe, it autocorrects to "DONT" or "THATS". Any way to fix this?
    I have the exact same problem after my keyboard updated to the latest version. It's terribly annoying.
    11-12-2013 11:08 PM
  12. matt grace's Avatar
    have you found a solution to this problem yet?
    11-27-2013 06:36 PM
  13. Canadian737's Avatar
    *please ignore this post! I accidentally double posted-my apologies!*
    11-28-2013 05:24 PM
  14. Canadian737's Avatar
    I have a question on this topic as well. Previously when typing "donts" or "thats" my phone would autocorrect by adding the appropriate apostrophe. Now, not only does it not add the apostrophe, it autocorrects to "DONT" or "THATS". Any way to fix this?
    This has driven me NUTS lately! Glad to see I'm not the only one. It's ridiculous. Hopefully Google takes a look at it!
    11-28-2013 05:26 PM
  15. BrettAU's Avatar
    Go to apps, google keyboard, then clear data and cache. That worked for me.
    12-01-2013 02:44 PM
  16. John Gortney's Avatar
    BrettAU's fix worked for me.

    I was also having the issue with that's being autocorrected to "THATs". Wildly annoying. Must have been a 4.4 issue (add it to the long list of annoying bugs). I had tried searching through personal dictionary on Google Keyboard and in Handscent SMS, but it was not an entry on either of those lists. Clearing the cache & data from the Google Keyboard app settings will correct this issue. In order to access this data clear feature, you will need to access the app settings from the list of all Apps, not the list of running Apps.
    12-19-2013 12:57 PM

Similar Threads

  1. Replies: 4
    Last Post: 07-21-2014, 05:24 PM
  2. Google Plus and Skype constantly crashing on Note 8
    By azkaevolution in forum Samsung Galaxy Note 10.1
    Replies: 4
    Last Post: 11-16-2013, 06:53 AM
  3. Countdown timer for Google Now?
    By NealJ777 in forum Android 4.4 KitKat
    Replies: 3
    Last Post: 11-09-2013, 02:53 PM
  4. Google Play Searches on Nexus Tablet
    By davidhayden1968 in forum Google Nexus 7 Tablet (2012)
    Replies: 2
    Last Post: 11-08-2013, 08:17 AM
  5. Google keyboard crashing constantly......
    By poppapico69 in forum Motorola Droid MAXX
    Replies: 7
    Last Post: 11-08-2013, 08:14 AM
LINK TO POST COPIED TO CLIPBOARD