Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default Has my G2's battery gone bad?

    The first time I charged it using the wall it was pretty fast and got up to 100%. Now I charge it and it's barely moving at all. For instance, it is at 22% now and this is after I've just done a factory reset, and it says it is going to take 7 hours and 2 minutes to fully charge. It took ages for that information to even come up too. Before I did the factory reset (desperate last resort) it was saying it was going to take 29 hours to fully charge. It's not on slow charge mode, it says "Charging (AC)" and I've used both the charger and cable that came with the phone and a HTC one and both are the same. I've only had it a month or two.

    I got it online from Amazon. Please tell me I can fix this and I'm not going to have to tediously exchange emails with LG and have to package and ship it to them.
  2. #2  

    Default Re: Has my G2's battery gone bad?

    Whomever is your service provider bring it to their store for deeper diagnostics.....

    Sent from my VS980 4G using AC Forums mobile app
  3. Thread Author  Thread Author    #3  

    Default Re: Has my G2's battery gone bad?

    Quote Originally Posted by Adawg1203 View Post
    Whomever is your service provider bring it to their store for deeper diagnostics.....

    Sent from my VS980 4G using AC Forums mobile app
    My service provider does not stock this phone though.
  4. #4  

    Default Re: Has my G2's battery gone bad?

    Try doing a full battery cycle which is draining it to 0% and it turns off then charge it up to 100% while turned off..it might reset it... Sometimes the indicator is inaccurate ..it may say 28% but you actually have 45% or something or say its 100% but ur actually at 12% so try that first

    Posted via Android Central App
    Thanked by:

Similar Threads

  1. Replies: 4
    Last Post: 01-01-2014, 05:49 PM
  2. Battery Life: A Handy Guide To Having Some
    By KWKSLVR in forum Moto X
    Replies: 13
    Last Post: 12-31-2013, 12:40 PM
  3. LG Optimus - I think rooting my android messed my phone up
    By hellokitty7177 in forum LG Optimus Series
    Replies: 1
    Last Post: 12-30-2013, 11:00 PM
  4. Lost imei on my galasy s3 i9300i
    By hesham_a22 in forum Samsung Galaxy S3 I9300
    Replies: 1
    Last Post: 12-29-2013, 03:22 PM
  5. Apps installed automatically on my Android devices
    By PlayForever8 in forum General News & Discussion
    Replies: 4
    Last Post: 12-29-2013, 10:35 AM

Posting Permissions

B