Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
Like Tree3Likes
  • 1 Post By SpookDroid
  • 1 Post By tazman69
  • 1 Post By kb9nvh
  1. Thread Author  Thread Author    #1  
    tazman69's Avatar

    Posts
    72 Posts
    Global Posts
    157 Global Posts

    Default How do I stop the G3 from connecting to AT&T Wifi

    I have had my G3 for just over 2 weeks and I'm really enjoying it. I always leave my Wifi, Bluetooth, etc on. The G3 constantly connects to AT&T hotspots even though:

    1) I have unchecked the Auto Connect 'Automatically connect to an available AT&T Wi-Fi HotSpot' under the Wifi option
    2) I have Disabled and Force Stopped AT&T Hot Spots app
    3) I have Disabled and Force Stopped AT&T Smart Wi-Fi

    When it does connect to 'attwifi' I try to 'Forget the Network' but it always fails with a message like 'Failed to forget network'.

    It's easy for me to turn off my wifi to work around this issue but I would prefer not to do so. I've never experienced this issue with any other AT&T phone I've had. Is there another setting I can disable, etc to prevent my phone from auto connecting to 'attwifi'?

    Thanks!
  2. #2  

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    Do you have WiFi Calling enabled? This might be causing it to recognize AT&T's hotspots automatically.
  3. Thread Author  Thread Author    #3  
    tazman69's Avatar

    Posts
    72 Posts
    Global Posts
    157 Global Posts

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    I don't have WiFi calling as an option.
  4. #4  

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    If you go Settings, Wifi, menu, Advanced Wifi, have you got Allow Wifi Scanning checked? Might just have something to do with it.

    Posted via Android Central App
  5. Thread Author  Thread Author    #5  
    tazman69's Avatar

    Posts
    72 Posts
    Global Posts
    157 Global Posts

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    I have that unchecked. The only thing I have checked on Advanced Wi-Fi is 'Battery saving for Wi-Fi'. I also have Keep Wi-Fi on when screen is off set to Yes but that shouldn't affect it.

    Thank you both for providing thoughts on the matter.
  6. #6  

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    Do you have the ATT Smart WiFi app installed? Or the hotspot one you mentioned earlier... I know you say that changing the settings doesn't affect them, but have you tried FREEZING the apps?

    UPDATE: Nevermind, I saw that you did try disabling them. Hummm...
    OK, what about forgetting the ATT hotspot while NOT connected to it?

    UPDATE 2: Found this on AT&T's site. Apparently this phone connects automatically to AT&T hotspots, no matter what. Maybe removing the SIM and trying it out so that the HotSpot doesn't recognize the device as an AT&T one? Although if it checks for the MAC address, then that wouldn't help, or if the hotspot name and connection settings are hardcoded into the phone, other than turning WiFi off, there wouldn't be a non-rooted way of doing this
    http://forums.androidcentral.com/ext...53D-4UKog8f5qd
    tazman69 likes this.
  7. Thread Author  Thread Author    #7  
    tazman69's Avatar

    Posts
    72 Posts
    Global Posts
    157 Global Posts

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    Wow... Well that sucks as the wifi is generally useless. Thank you for the information Spook.
    SpookDroid likes this.
  8. #8  

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    No problemo, we're all here to help
  9. #9  

    Default Re: How do I stop the G3 from connecting to AT&T Wifi

    From a post in XDA

    For this your phone needs to be rooted and you need Root Explorer from the Market:

    1) Open root explorer
    2) Tap on "Mount R/W" to mount the file system
    3) Navigate to /data/misc/wifi
    4) Press and hold on wpa_supplicant.conf and select "Open in Text Editor"
    5) Delete the following lines from the file:

    network={
    ssid="attwifi"
    key_mgmt=NONE
    priority=1
    }

    6) Once deleted tap on the 3 dot's in the top right hand corner of the app
    7) Tap on "Save and Exit"
    8) Reboot

    After that you will no longer be forced to connect to "attwifi"
    me75006 likes this.

Similar Threads

  1. Unfortunately contacts has stopped on Galaxy S5
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 03-08-2015, 06:31 AM
  2. Replies: 7
    Last Post: 09-27-2014, 05:57 PM
  3. LG G3 - One week on
    By peejay1977 in forum LG G3
    Replies: 9
    Last Post: 08-25-2014, 06:40 PM
  4. lg g2 says its connected to wifi but not working
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 08-25-2014, 04:19 PM
  5. S4 cannot connect to home wifi
    By Unregistered in forum Ask a Question
    Replies: 2
    Last Post: 08-25-2014, 03:44 PM

Posting Permissions