1. mike9670's Avatar
    Thanks to Drew for this method. Going to pass it on for those that need to get back to stock Sprint.

    Here are the steps necessary to flash the stock v9 recovery image.


    This is for a rooted phone running either ThunderC or Xionia CWMA recoveries:


    platform-tools.zip

    1) Download this: platform-tools.zip
    2) Inside that zip file is a folder called "platform-tools"
    3) Copy that folder to the desktop
    4) Inside the folder you copied to the desktop, there is a file called "v9recovery.img"
    5) Copy v9recovery.img to your sdcard
    6) Turn OFF USB Storage
    7) Open a command prompt (in Windows XP this is Start->Run then type "cmd" (without quotes) then hit enter
    8) In the command prompt, type "cd" (without quotes)
    9) Drag the platform-tools FOLDER from the desktop to the command prompt
    10) Make absolutely sure there is a single space between "cd" and the rest
    11) Hit enter
    12) Type "dir" followed by hitting enter
    13) One of the files listed should be adb.exe
    14) Type "adb shell" and hit enter
    15) When it connects, type "su" if it shows a dollar sign ($) and not a pound(#)
    16) Type "cd /sdcard" and hit enter
    17) Type "ls" and hit enter (that's a lowercase L followed by a lowercase S)
    18) One of the files listed should be v9recovery.img
    19) Type "flash_image recovery /sdcard/v9recovery.img" and hit enter
    20) When that finishes, type "reboot recovery" and hit enter

    Should reboot into LG stock v9 recovery.

    Then you need to get stock ROM: [How-to] Revert to LS670V9, after installing OTA LS670VC/VD, using KP500 (Diag mode)

    or

    [How-To] Simplified UNROOT and return to STOCK
    07-13-2011 11:38 AM
  2. jstntp's Avatar
    Very nice, I'm sure this guide will be very valuable.
    07-13-2011 11:43 AM
  3. uberjam545's Avatar
    wow a lot easier than the previous ways this is just like installing any other kind of recovery.
    07-13-2011 12:33 PM
  4. jondevere's Avatar
    Are the newer screen models able to use this? Or will they have issues? Just a thought and cant remember the answer
    07-13-2011 01:33 PM
  5. ManifestDrummer's Avatar
    Thanks to Drew for this method. Going to pass it on for those that need to get back to stock Sprint.

    Here are the steps necessary to flash the stock v9 recovery image.


    This is for a rooted phone running either ThunderC or Xionia CWMA recoveries:


    platform-tools.zip

    1) Download this: platform-tools.zip
    2) Inside that zip file is a folder called "platform-tools"
    3) Copy that folder to the desktop
    4) Inside the folder you copied to the desktop, there is a file called "v9recovery.img"
    5) Copy v9recovery.img to your sdcard
    6) Turn OFF USB Storage
    7) Open a command prompt (in Windows XP this is Start->Run then type "cmd" (without quotes) then hit enter
    8) In the command prompt, type "cd" (without quotes)
    9) Drag the platform-tools FOLDER from the desktop to the command prompt
    10) Make absolutely sure there is a single space between "cd" and the rest
    11) Hit enter
    12) Type "dir" followed by hitting enter
    13) One of the files listed should be adb.exe
    14) Type "adb shell" and hit enter
    15) When it connects, type "su" if it shows a dollar sign ($) and not a pound(#)
    16) Type "cd /sdcard" and hit enter
    17) Type "ls" and hit enter (that's a lowercase L followed by a lowercase S)
    18) One of the files listed should be v9recovery.img
    19) Type "flash_image recovery /sdcard/v9recovery.img" and hit enter
    20) When that finishes, type "reboot recovery" and hit enter

    Should reboot into LG stock v9 recovery.
    Im having some trouble, when I type "adb shell" I get "Device not found" can anyone help?
    07-16-2011 11:27 PM
  6. drewwalton19216801's Avatar
    Im having some trouble, when I type "adb shell" I get "Device not found" can anyone help?
    Do you have the LGLS670 drivers installed?
    07-17-2011 12:34 AM
  7. ManifestDrummer's Avatar
    Do you have the LGLS670 drivers installed?
    I finally got it to detect the device but when I access the adb shell it comes up with a pound symbol (#) instead of the dollar sign. =\
    07-17-2011 07:29 PM
  8. drewwalton19216801's Avatar
    I finally got it to detect the device but when I access the adb shell it comes up with a pound symbol (#) instead of the dollar sign. =\
    Would you happen to be running either Shell ROM or Reborn ROM? If so, that's normal.
    07-17-2011 08:13 PM
  9. Mickluvin22's Avatar
    When I type in the command "flash_image recovery /sdcard/v9recovery.img" and hit enter, it says permission denied........what the heck
    07-17-2011 09:45 PM
  10. viper59's Avatar
    I am geting same problem.
    09-30-2011 01:22 AM
  11. Jessicalt1's Avatar
    Are you rooted?
    09-30-2011 08:01 AM
  12. twisteddan's Avatar
    Little trouble with this. I could use some help.
    I have followed the directions exactly.....no problems until I put in the last command....
    I get this error.
    "sh: flash_image: command not found"
    I have tried it several times so I know that I am inputting it correctly.....Any ideas what I'm doing wrong?
    And yes the flash v9recovery file is on my sdcard where it should be.

    Sent from my LS670 using Tapatalk
    10-04-2011 11:30 AM
  13. beezy's Avatar
    Little trouble with this. I could use some help.
    I have followed the directions exactly.....no problems until I put in the last command....
    I get this error.
    "sh: flash_image: command not found"
    I have tried it several times so I know that I am inputting it correctly.....Any ideas what I'm doing wrong?
    And yes the flash v9recovery file is on my sdcard where it should be.

    Sent from my LS670 using Tapatalk
    In a command line or terminal on phone you could download the zip attached extract the file from it to sdcard then run the following and should have stock recovery.Make sure you have the recovery and flash_image file on root of sd..
    Code:
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock5 /system
    
    # cat /sdcard/flash_image > /system/bin/flash_image
    
    # chmod 755 /system/bin/flash_image
    
    # mount -o remount,ro -t yaffs2 /dev/block/mtdblock5 /system
    
    # flash_image recovery /sdcard/v9recovery.img
    
    # reboot recovery
    10-04-2011 09:42 PM
  14. G2k's Avatar
    Some thing has gone TERRIBLY wrong.

    I followed your directions and had complete success at each point.

    I flashed the v9recovery.img, and when finished I typed reboot recovery.

    The phone rebooted and goes to a blank screen. Windows xp sees GOOGLE Mass storage device and generic volume "f"...but I can't access volume "f" .

    If I repeat the cmd process when I type adb shell it says:

    -exec ' /system/bin/sh' failed: no such file or directory <2>

    So now what????
    11-27-2011 10:10 AM
  15. mike9670's Avatar
    You must have newer LCD screen which means V9 recovery has black screen. The display drivers in V9 are for older optimus phones. Android screencast is what you need.
    11-27-2011 11:47 AM
  16. G2k's Avatar
    Thank you for the quick reply, I couldn't use screencast as it needs to be launched from the phone (which I cant see).

    I managed to get it all straightened out anyway though.

    I downloaded the ZVD.cab and renamed everything accordingly. Then I simply went through the steps again and I got a working screen again.

    Then the usual stuff: root,xionia recovery, make backup, load new rom, tweak, make new rom backup, DONE...lol

    ALL the information that allowed me to get EVERYTHING working again came from this thread:

    ***[How-to] Revert to LS670V9, after installing OTA LS670VC/VD, using KP500 (Diag mode)

    Just thought I'd include it in case anyone else needs it.
    11-27-2011 06:55 PM
  17. Jake-Peppers's Avatar
    i'm having trouble it says when i get to the type su cd /sdcard it says su: permission denied what do i do?
    12-15-2011 09:52 PM
  18. TalonD's Avatar
    I cant get past the command promt part when typing adb shell... It just says device not found
    12-22-2011 06:12 PM
  19. jcwxguy's Avatar
    your phone needs to be in debugging mode, also you need the drivers installed for your phone first
    12-22-2011 06:27 PM
  20. geech#AC's Avatar
    Thank you for the quick reply, I couldn't use screencast as it needs to be launched from the phone (which I cant see).

    I managed to get it all straightened out anyway though.

    I downloaded the ZVD.cab and renamed everything accordingly. Then I simply went through the steps again and I got a working screen again.

    Then the usual stuff: root,xionia recovery, make backup, load new rom, tweak, make new rom backup, DONE...lol

    ALL the information that allowed me to get EVERYTHING working again came from this thread:

    ***[How-to] Revert to LS670V9, after installing OTA LS670VC/VD, using KP500 (Diag mode)

    Just thought I'd include it in case anyone else needs it.
    Im having the same issue you had can you possibly be more descriptive with the install of ZVD.cab
    03-22-2012 03:40 PM
LINK TO POST COPIED TO CLIPBOARD