1. traxxasBandit's Avatar
    Ummm... i dont evan know where to start. I went on a long hike a few days ago put my phone in my pack and didnt turn it on until a week later. Now the headset icon apears and it says its plugged in but its not. Whats happening? Any ideas on how to fix this?

    thanks.
    05-14-2012 09:42 PM
  2. Sdude1200's Avatar
    Try. Cleaning the jack out with a toothpick or needle. Sometimes debris, like lint, can get caught in there and make the phone think there are headphones in

    Sent from my LS670 using Android Central Forums
    05-15-2012 12:24 AM
  3. epidenimus's Avatar
    Canned air with the straw is also a good way to clean this out. I had a lint ball that was stopping me from using my headset jack 2 weeks ago and air fixed it about 7 seconds. Might wanna hit the microUSB port while you're at it, too.
    05-15-2012 09:40 AM
  4. traxxasBandit's Avatar
    Well iv tried that and it didnt work. Im stumped. Now it says that the headphones arnt pluged in, but when i try to play something with sound nothing happens. Iv evan changed my rom and baseband,......and nothing.
    05-15-2012 11:49 PM
  5. traxxasBandit's Avatar
    This is really pissing me off, no luck and i have no insurance on it. Im starting to think its a harware issue idk but now the battery is lasting around 10 hrs with me off the phone im starting to think its either hardware or, mabey i have a virus?? Any ideas?
    05-17-2012 12:14 AM
  6. traxxasBandit's Avatar
    Dont mean to be a noob here er but um anyone know if thiers anyway to hotfix a headphone icon?
    05-18-2012 12:45 AM
  7. drewwalton19216801's Avatar
    Dont mean to be a noob here er but um anyone know if thiers anyway to hotfix a headphone icon?
    Explain?
    05-18-2012 09:58 AM
  8. epidenimus's Avatar
    If you are trying to override the headset indicator, you can do so in CM7 as follows:

    Menu >> Settings >> Cyanogen Mod Settings >> Interface >> Status Bar Tweaks >> [Scroll to bottom] uncheck Show Headset Icon
    05-18-2012 10:09 AM
  9. traxxasBandit's Avatar
    just Read my problem my phone ifs stuck in headset mode.is their any way to manually overide this?
    05-18-2012 01:12 PM
  10. twtippets's Avatar
    Alright, it would seem that your problem is not software related. From a hardware perspective there is a "switch" somewhere in the headphone jack. Currently that "switch" is in the on position. You need to find a way to turn it off. I'm no hardware engineer, but it would make sense that if you were to dissect your headphone port you would find the switch and be able to cut whatever is linking the I/O of that switch. If you are brave you could open up the phone and find the wires from the headphone jack to the motherboard and sever them so that no signal is recognized in or out thus preventing the phone from thinking the headphones are plugged in.

    From a software perspective somewhere in what I would think is the kernel is a bit of code that tells the OS when the "switch" is on thereby turning off the external and ear speakers. If you could find that little bit of code and disable it you could effectively remove the problem of the OS thinking that your headphones are plugged in. It would however be your luck (unfortunately) that this code is probably interwoven into many different aspects of the kernel.

    I am no dev and have no idea even where to begin looking for such a thing, but someone who has experience with kernels may have a better idea on where to look. But if I had to guess, on the CM7 that Kraven did, there is a Handset Mic Fix, This was a patch that he made to turn the handset mic on after headphones were plugged in and everything else was turned off. That may lead you down a path towards your final goal hopefully.

    Best of luck and hopefully someone can help you out more that just give a brief explanation of what most others are probably thinking.
    05-18-2012 09:59 PM
  11. traxxasBandit's Avatar
    ummm no thanks i dont feel like cutting wires The one think that i dont get is the fact that once i actually plug in headphones sound doesnt come out of them either? huh??
    05-19-2012 02:09 AM
  12. drewwalton19216801's Avatar
    ummm no thanks i dont feel like cutting wires The one think that i dont get is the fact that once i actually plug in headphones sound doesnt come out of them either? huh??
    Blow out your headphone jack. It's possible that some conductive material has found its way in there.

    Or your jack is busted. But try blowing it out first.
    05-19-2012 07:02 AM
  13. twtippets's Avatar
    ummm no thanks i dont feel like cutting wires The one think that i dont get is the fact that once i actually plug in headphones sound doesnt come out of them either? huh??
    Either there is something in your headphone port, or the wires connecting the headphone to the mother board have come loose or broken. One of the wires if it is loose is probably touching the "switch" causing a short circuit and always registering as on. So, the choices are cut the connection to the headphone port or find someone who can alter your kernel to fix the problem from a software point of view.
    05-19-2012 02:15 PM
  14. traxxasBandit's Avatar
    Well i took it apart and i cant figure out how to get to the jack, pffff im in a pickle
    05-20-2012 12:42 AM
  15. PatrickAkridge's Avatar
    Well i took it apart and i cant figure out how to get to the jack, pffff im in a pickle
    I know this is kind of a rookie response, but try looking it up on Google..

    HOLD ON. I have two more suggestions..

    First, no-one else has posted this, but revert back to stock ZVD or ZVH and see if it is a Software problem. If you get back to stock Android AND Recovery, and it still isn't working, try all of the other responses.

    You could..

    Clean the port, Cut the wires, or lots of other things. But I think the easiest way to go would be to see the second option.

    See below..

    2 - Or, if you have Insurance on the phone with Sprint (or whoever you are using), put it back together, make sure that it charges, so fourth. If it still isn't working, take it to a retail store and tell them that the headphone jack stopped working when you went hiking... If you have the option, exchange the phone for another Android (look up one with better specs on Google.. Get at least an Android phone with an ARMv7 or ARMv8, look up something like "ARMv7 or ARMv8 Android phones on Sprint") or if you can't do that, just ask them to replace it with the same phone or get the one you have fixed. You will have to pay an Insurance deductible of I think it is $50, or so my mom says... Get it fixed or replaced and if they get it back in, or while you are there working out your problem, ask them if they ever get back results on what was wrong with it, tell them to let you know. You will probably be curious.

    PLEASE like and thanks my post before you go..

    Best of luck and have a good day.
    traxxasBandit likes this.
    05-20-2012 08:44 PM
  16. traxxasBandit's Avatar
    I dont have insurance. And i have changed back and forth from zvd to zvh to zv9 and so on i think that the port shorted out. So im screwed but i think i'll take it to mobile madness, its a store here that can fix your phone for cheap lol.
    05-20-2012 11:18 PM
  17. PatrickAkridge's Avatar
    I dont have insurance. And i have changed back and forth from zvd to zvh to zv9 and so on i think that the port shorted out. So im screwed but i think i'll take it to mobile madness, its a store here that can fix your phone for cheap lol.
    Careful with those services though. They may be more of a liability than an asset (in other words, more problem causing than problem solving)...
    05-21-2012 09:36 AM
  18. vernotzy21's Avatar
    The S's headphone Jack is surface mounted to the circuit board so their is no wires to cut IV had trouble with the Jack as well it seems to be the S's weakness

    Sent from my LS670 using Android Central Forums
    06-06-2012 11:40 AM
  19. vernotzy21's Avatar
    Something has to be jammed in there unless the headphone detection switch is broken then I do belive it would be software or a defective audio processor however idk if the audio processor is integrated in the qualcom system on a chip thing or seperate either way there wouldn't be a fix....see if the Jack wiggles a tiny bit if so that means its a bad soldering job if so it just needs resoldered
    ...micro soldering surface mounted. If that's the case take it to the repair store(they should have the right tools)

    Sent from my LS670 using Android Central Forums
    06-06-2012 11:50 AM
  20. vernotzy21's Avatar
    But don't let them rip you mouth out if you got the right tools its a super easy fix

    Sent from my LS670 using Android Central Forums
    traxxasBandit likes this.
    06-06-2012 11:53 AM
  21. bweb's Avatar
    when you went back to ZVD, what rom were you using? this sounds vaguely familiar (i think i had an issue like this forever ago) half of me wants to say it was due to some old version of cm7, and half of me wants to say it was just dust like some people are saying.

    does it still fail with zvd stock/reborn or some stock variation?
    06-08-2012 06:19 PM
  22. traxxasBandit's Avatar
    Yah it stiil doent work, with any rom.

    Sent from my LS670 using Tapatalk 2
    06-09-2012 01:58 AM
  23. epidenimus's Avatar
    Yah it stiil doent work, with any rom.
    My Scooby Sense says it's a physical obstruction or a hardware issue. (...and who the hell wears an orange turtleneck with a skirt? F$&*ing hipsters.)
    06-09-2012 06:49 PM
  24. Lewixzy's Avatar
    Ummm... i dont evan know where to start. I went on a long hike a few days ago put my phone in my pack and didnt turn it on until a week later. Now the headset icon apears and it says its plugged in but its not. Whats happening? Any ideas on how to fix this?

    thanks.
    I have the same issue...mine I just hardware base I use a Samsung S5 and my eariece got broken in the earphone jack tried removing it but it's already clicked...tried using a ball pen to pull it out too..didn't work..I need help please as I am dying of not being able to listen to music or play Voice notes , I can barely receive calls..I have to place it on speaker phone...it's horrible...HELP!!!
    08-27-2016 01:59 AM
LINK TO POST COPIED TO CLIPBOARD