03-17-2014 08:31 PM
409 1234 ...
tools
  1. hlxanthus's Avatar
    @thewrath420 what's your github? I might try tinkering too and would like to see where you are

    Sent from my Nexus 7 using Tapatalk 2
    11-11-2013 07:37 PM
  2. thewraith420's Avatar
    @thewrath420 what's your github? I might try tinkering too and would like to see where you are

    Sent from my Nexus 7 using Tapatalk 2
    It's the same as my name here, thewraith420 but currently it's the same as Androidarmv6's because I haven't pushed any changes.... I actually still have to learn to do that

    Tapatalk'n Squid style! Android 4.2.2 JBC on my VM670 running LS670ZVJ firmware
    11-11-2013 11:18 PM
  3. hlxanthus's Avatar
    It's the same as my name here, thewraith420 but currently it's the same as Androidarmv6's because I haven't pushed any changes.... I actually still have to learn to do that

    Tapatalk'n Squid style! Android 4.2.2 JBC on my VM670 running LS670ZVJ firmware
    Which device tree are you using as I notice it isn't already in the androidarmv6 github (synced via their manifest)
    11-12-2013 11:21 AM
  4. thewraith420's Avatar
    i used device and vendor folders from thekraven's github
    11-12-2013 11:38 AM
  5. ANDROIDRAZRM's Avatar
    Ya'll had any luck so far?
    11-12-2013 06:37 PM
  6. ANDROID9274's Avatar
    Which device tree are you using as I notice it isn't already in the androidarmv6 github (synced via their manifest)
    i used device and vendor folders from thekraven's github
    Ya'll had any luck so far?
    I'm getting close. I don't have an Opti S so someone will need to be a guinea pig. Unfortunately, I'm building on my backup PC because an experiment is running on my main rig so this might take awhile to produce if I run into any hiccups.

    Edit: Looks like the new Android Runtime (ART) has compiling problems on ARMv6. Trying some workarounds now.
    11-12-2013 07:52 PM
  7. thewraith420's Avatar
    I'm getting close. I don't have an Opti S so someone will need to be a guinea pig. Unfortunately, I'm building on my backup PC because an experiment is running on my main rig so this might take awhile to produce if I run into any hiccups.

    Edit: Looks like the new Android Runtime (ART) has compiling problems on ARMv6. Trying some workarounds now.
    That's where I made it to...

    Edit:come to think of it... I have a file that might help you. I found an armv6 compatible atomic.h... It seems to get past where I was stuck on armv7 errors but spits up a new problem I couldn't get past... maybe it'll make more sense to you. Also if you need a tester I'd be glad to to.

    Tapatalk'n Squid style! Android 4.2.2 JBC on my VM670 running LS670ZVJ firmware
    11-12-2013 11:03 PM
  8. Anino4's Avatar
    If you need another person to test I'd be glad to help !

    Posted via Android Central App
    11-13-2013 02:11 PM
  9. williek113's Avatar
    Post something and you'll get many, many testers...

    Sent from my LG-LS670 using AC Forums mobile app
    Anino4 likes this.
    11-13-2013 06:25 PM
  10. weriov's Avatar
    Oh yeah. I can help too!
    11-13-2013 08:04 PM
  11. BarakaBalls's Avatar
    I have no problem testing.

    Posted via Android Central App
    11-14-2013 02:23 PM
  12. ClutchX_LA's Avatar
    I still have mine. Id like to test.

    Posted via Android Central App
    11-16-2013 04:13 PM
  13. dradzanowski's Avatar
    I've got mine running Dante ROM right now for my daily driver, I will jump ship and run it if you post a flashable zip for CW Recovery to load! Can't wait for a new ROM to play with!
    11-20-2013 07:19 AM
  14. nitestalkr's Avatar
    I would test the hell out of any pre alpha builds of a Kit-Kat ROM!
    11-21-2013 03:34 AM
  15. bigsupersquid's Avatar
    my dumb landline internet is supposed to be on by this evening. it's only been two weeks since ordering it... never could get past seventy eight percent repo sync tethered.
    my new computer already arrived, overpowered and beefy.
    maybe soon I can test my generic-armv5 theory and at least have something to look at.
    11-21-2013 07:03 AM
  16. thewraith420's Avatar
    I'm getting close. I don't have an Opti S so someone will need to be a guinea pig. Unfortunately, I'm building on my backup PC because an experiment is running on my main rig so this might take awhile to produce if I run into any hiccups.

    Edit: Looks like the new Android Runtime (ART) has compiling problems on ARMv6. Trying some workarounds now.
    If your still around here... Had any luck finding a work around?

    Tapatalk'n it PAC-Rom style! Android 4.2.2 on my VM670 running LS670ZVJ firmware
    11-21-2013 10:59 AM
  17. skinbark's Avatar
    I'm also trying to build KitKat. I'll let you know how it goes.
    11-22-2013 05:09 AM
  18. dingermtb's Avatar
    I'll definitely test if there's a virgin fix

    Sent from my ZombieBean 4.2.2-VM670 using Xparent Holo Tapatalk 2
    11-22-2013 10:23 AM
  19. _alexkta's Avatar
    I'll definitely test if there's a virgin fix

    Sent from my ZombieBean 4.2.2-VM670 using Xparent Holo Tapatalk 2
    I'll test with or without one

    Sent from my LG-VM670 using Tapatalk
    11-22-2013 05:24 PM
  20. skinbark's Avatar
    I got past some errors and thought it was going to compile but then it crashed with some linkage errors which I think are due to insufficient memory. My build pc is a 2.4 ghz Core 2 Duo laptop with 3 gb ram (barely adequate for building android). I'm going to try increasing swap space from 3 to 8 gb but if that doesn't work I guess I'll have to buy more physical ram.
    11-24-2013 04:01 PM
  21. bigsupersquid's Avatar
    I got past some errors and thought it was going to compile but then it crashed with some linkage errors which I think are due to insufficient memory. My build pc is a 2.4 ghz Core 2 Duo laptop with 3 gb ram (barely adequate for building android). I'm going to try increasing swap space from 3 to 8 gb but if that doIesn't work I guess I'll have to buy more physical ram.
    got ice cream sandwich to build on a 1.8 GHz laptop with 2GB ram.
    at least 32GB swap though. figured had harddrive space but maxed out the ram.
    11-24-2013 07:15 PM
  22. skinbark's Avatar
    Well I got through a build but I had to skip over the libwebviewchromium.so library that was making my build crash. This is the new Chromium WebView for KitKat, so there's not a lot of info out there yet. Others are having similar problems with it though. I'm thinking if there's another KitKat rom out there that's built for armv6 I might be able to just stick it into /system/libs, or maybe I can get it built standalone. This is the first rom I've attempted so it may take me some time to get up to speed. It also errored out complaining that system.img was too large so I had to change the max system image size constant. System.img is probably too big to flash at this point, I'll have to find some way to trim it down. I ordered more ram for my laptop so that should make things easier.
    11-25-2013 05:47 AM
  23. thewraith420's Avatar
    Well I got through a build but I had to skip over the libwebviewchromium.so library that was making my build crash. This is the new Chromium WebView for KitKat, so there's not a lot of info out there yet. Others are having similar problems with it though. I'm thinking if there's another KitKat rom out there that's built for armv6 I might be able to just stick it into /system/libs, or maybe I can get it built standalone. This is the first rom I've attempted so it may take me some time to get up to speed. It also errored out complaining that system.img was too large so I had to change the max system image size constant. System.img is probably too big to flash at this point, I'll have to find some way to trim it down. I ordered more ram for my laptop so that should make things easier.
    Just curious, every time I tried I got stuck at art runtime with some armv7 errors. Could you point me in the right direction to get past that? Unless it was fixed upstream at Androidarmv6

    Sent from my LG-VM670 using Tapatalk 2
    11-25-2013 12:35 PM
  24. skinbark's Avatar
    Just curious, every time I tried I got stuck at art runtime with some armv7 errors. Could you point me in the right direction to get past that? Unless it was fixed upstream at Androidarmv6

    Sent from my LG-VM670 using Tapatalk 2
    I didn't get that particular error, I had issues with camera, bluetooth and the chromium thing. What did you have in your local manifest? We might be using different sources. If you run the build and send me the exact error message I might be able to help. Message me if you want.
    11-25-2013 04:10 PM
  25. thewraith420's Avatar
    My sync was with Androidarmv6's github repo and I used thekraven's 10.1 device and vendor folders made it past several problems but got stuck at the new art runtime atomic.h

    Sent from my LG-VM670 using Tapatalk 2
    11-25-2013 11:53 PM
409 1234 ...

Similar Threads

  1. iHeartRadio not working on KitKat
    By Brainerd in forum Google Nexus 5
    Replies: 43
    Last Post: 11-29-2013, 08:21 PM
  2. Sort of hoping kitkat gets delayed a little
    By zobog in forum Moto X (2013)
    Replies: 12
    Last Post: 11-07-2013, 02:05 PM
  3. Any infos in upcoming AOSP KitKat 4.4 roms?
    By Cool Jeff in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 11-06-2013, 07:18 AM
  4. Replies: 0
    Last Post: 11-05-2013, 05:46 PM
  5. Replies: 5
    Last Post: 11-05-2013, 02:26 PM
LINK TO POST COPIED TO CLIPBOARD