Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By eracet
  • 1 Post By gumbydpl
  • 1 Post By fredphoesh
  1. Thread Author  Thread Author    #1  
    eracet's Avatar

    Posts
    146 Posts
    Carrier
    Drew's CM7, Reborn 2.2.4

    Default [Solved] Internal Service Failure

    This is an issue solution that I had a few days ago and finally figured out a solution.
    So this is a thread for those that may encounter the same issue.

    When running applications such as tapatalk phone would start the application and a few seconds after using it would come up with error screen Internal Service Failure.

    This was only noticed on applications that use the amazon appstore.

    So after some nandroid restoring, data wiping and many other troubleshooting things it was still giving the error.

    Here was the Final Solution:
    Uninstall Amazon Appstore.
    Logon to Amazon and remove the registered device (your device).
    Follow instructions on adding a new device on website (same page as device listings).
    Once you re-install the amazon application you will have to verify with user/pass.
    You will have a listing as your phone on the device listings on Amazon website.

    That is all you should need and anything that was downloaded from Appstore should work fine with no crashing or pop ups.

    One thing I did is removed all my devices from the device page just to make sure I clean up any duplicates.
    lsanford2255 likes this.
  2. #2  

    Default Re: [Solved] Internal Service Failure

    I had the same problem. I just went in to the application settings and cleared the data for the Amazon app. And that fixed it.
    bhameyedoc likes this.
  3. #3  

    Default Re: [Solved] Internal Service Failure

    Thank you very much. This was driving me crazy! I tried everything I could think of, but would hae never considered the correct solution!
  4. #4  

    Default Re: [Solved] Internal Service Failure

    Actually clearing the App Store cache did not solve it.
    What did solve it was to log out of the Amazon app and the Amazon App Store app, then to log in again.
    All good after that.
    cegabq likes this.
  5. #5  
    rayjr13's Avatar

    Posts
    21 Posts
    Global Posts
    82 Global Posts
    Carrier
    2.11.605.0|2.6.35.10

    Default Re: [Solved] Internal Service Failure

    Agreed. you should be able to run amazon app without the Amazon Appstore app now if you have the new(er) Amazon app. But signing out of Amazon app and signing back in resolved it for me. I had Amazon Appstore removed so no need to signout/in of that app.
  6. #6  

    Thumbs up Re: [Solved] Internal Service Failure

    Thanks for the help! I found that I didn't have to go through as much trouble as you did. I simply uninstalled the latest update to Amazon's app and that fixed everything. When you go to the app to uninstall via settings, there's a tab that says uninstall latest update. I figured I had nothing to lose, so I gave it a shot. About 3 seconds later everything was working just fine.

    Thanks for steering me in the right direction!
  7. #7  

    Default Re: [Solved] Internal Service Failure

    Thank you. Logged out of Amazon. Logged back in. All is well.
  8. #8  

    Default Re: [Solved] Internal Service Failure

    Quote Originally Posted by fredphoesh View Post
    Actually clearing the App Store cache did not solve it.
    What did solve it was to log out of the Amazon app and the Amazon App Store app, then to log in again.
    All good after that.
    PERFECT! This is what works
  9. #9  

    Default Re: [Solved] Internal Service Failure

    Quote Originally Posted by fredphoesh View Post
    What did solve it was to log out of the Amazon app and the Amazon App Store app, then to log in again.
    All good after that.
    Oh thank goodness! I was going crazy!

Posting Permissions