Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  
    shortyjacobs's Avatar

    Posts
    446 Posts
    ROM
    Stock

    Default Battery Life Sucky?

    This is my first smart phone, so bear with me, and tell me if I'm worrying about nothing.

    My phone went from fully charged to 82% in 2 hr 3 minutes, from when I unplugged it in the morning to when I got to work. I didn't use it for more than 5 minutes total. Clicking on battery info gives me:

    Cell standby 48%
    Phone idle 46%
    Android System 5%
    Display 3%

    ThundeROM 1.4, stock kernel, stock everything else.

    Does this sound normal? 10% an hour gives me at best 10 hrs of phone life, and this is with me barely doing anything on it. Wi-Fi was turned off, GPS turned off, backlight turned off. I downloaded the NPR app over 3G and played 30 seconds of streaming radio, and that's all I've done all morning. No phone calls. No GPS. Didn't even have the screen on. No apps running in the notification window.

    Is there a better way to get a handle on what's draining my battery so fast?
  2. #2  

    Default

    It depends on how long you had the phone because it takes a couple of charges to optimized the battery. Some phones like the Evo switches to battery mode once fully charged so shortly after unpluging the battery drops to show the actual percentage. I would recommend you install juice defender...its not and app killer and it should help, it helped me.
  3. Thread Author  Thread Author    #3  
    shortyjacobs's Avatar

    Posts
    446 Posts
    ROM
    Stock

    Default

    Quote Originally Posted by kinster02 View Post
    It depends on how long you had the phone because it takes a couple of charges to optimized the battery. Some phones like the Evo switches to battery mode once fully charged so shortly after unpluging the battery drops to show the actual percentage. I would recommend you install juice defender...its not and app killer and it should help, it helped me.
    Had it for 10 days now, definitely gone through some charging cycles.

    I was looking at juice defender...maybe I'll give it a shot.

    I've also done some manual trimming by myself. I closed the Facebook, Twitter, and Calendar widgets in LauncherPro so they weren't updating. I also shut off auto-sync.

    Only lost around 3% in an hour now. Need a longer test still, but looks like those widgets and their autoupdating may have been screwing me.
  4. #4  

    Default

    probably too many widgets. I'm running 3 news + 1 weatherbug widget, and battery life is great. I'm also running tasker, which sets my phone to wifi, whenever I am home. Can get a day and a half to two days depending on the amount of usage.

    do some gaming, a lot of browsing and emails. IMO, this phone has fantastic battery life.
  5. #5  
    apinkel's Avatar

    Posts
    141 Posts
    Global Posts
    163 Global Posts

    Default

    If you are in a weak signal area it will also drain your battery very quickly.

    So far this phone has the best battery life out of all the smartphones I've owned, after 16 hours I'm typically at 60%... keep in mind that I'm not a heavy user though... few phone calls, a bit of bubble blaster 2 and reading a few emails.
  6. #6  

    Default

    Keep your PRL updated. That will reduce your TWS. Also don've things auto syncing every 5 minute. Not saying you do, but the shorter you have that set for the more the battery will go down because it is checking more often. Back out of programs properly. Some like latitude like to stay on when you don't realize it. Also it is a must that at least once a day you shut off your phone then turn it back on. Some times these devices need a short reboot to get things back in order. Programs, battery, other stuff. It all helped me.
  7. #7  

    Default

    I'm not sure if ThundeROM fixes this, but if your Time Without Signal is constantly at about 50% or so, it's due to a bug in Froyo that hasn't been fixed for us yet. Simply turn ON airplane mode then turn it off when you first boot, and you should notice TWS to be pretty much entirely eliminated.

Posting Permissions