Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread Author  Thread Author    #1  
    lobody94's Avatar

    Posts
    9 Posts
    Global Posts
    25 Global Posts

    Default Bluetooth Stuck On

    I am having an issue with my Bluetooth being stuck on. I need some help....

    I have a rooted and thundeRomed optimus S.

    I paired my Bluetooth and it worked fine. When I try to turn the Bluetooth off it reboots my phone.

    I have tried combinations of turning airplane mode on and off. didnt work.
    I have tried killing running processes. didn't work.
    I have rebooted and battery pull. didn't work.

    I rebooted to recovery, cleared all the caches... didn't work
    I rebooted to recovery, reinstalled thundeRom... didn't work
    I rebooted to recovery, factory wiped and restored my original nand backup... didn't work

    If you need more info let me know.
  2. Thread Author  Thread Author    #2  
    lobody94's Avatar

    Posts
    9 Posts
    Global Posts
    25 Global Posts

    Default

    got it fixed but it wasn't pretty....

    If anyone knows about this or an easy fix. let me know
  3. #3  
    hamagc's Avatar

    Posts
    583 Posts
    Global Posts
    608 Global Posts
    ROM
    Stock - Maybe OC Kernel

    Default

    how did you fix it?
  4. Thread Author  Thread Author    #4  
    lobody94's Avatar

    Posts
    9 Posts
    Global Posts
    25 Global Posts

    Default

    rebooted to recovery again.... wiped everything, restored google proprietary...? then I loaded thunderRom back on and fired it up.

    So far so good but I am still scared it will happen again.

    I had the tasker app running and I think that is what started the glitch. I have a profile setup so when i plug power to the USB i can choose car mode which fires up GPS, and Bluetooth, And then I have a profile to turn them off when I unplug it. When I unplugged my phone this morning that is when it went haywire.
  5. #5  
    hamagc's Avatar

    Posts
    583 Posts
    Global Posts
    608 Global Posts
    ROM
    Stock - Maybe OC Kernel

    Default

    whats interesting is you restored your nandbackup which would clear everything out of data and restore with your nandbackup. i'm assuming that any apps you had installed that would control bt, were installed after you did the nandroid. after a full restore nothing should have been controlling the bt but something obviously still was.

    is this correct?
  6. Thread Author  Thread Author    #6  
    lobody94's Avatar

    Posts
    9 Posts
    Global Posts
    25 Global Posts

    Default

    Yep that is correct. I figured my fall back was restoring the nand and was scared when that didn't work.

    I just hope it doesn't happen again. I am cautious about using tasker now.....
  7. #7  
    hamagc's Avatar

    Posts
    583 Posts
    Global Posts
    608 Global Posts
    ROM
    Stock - Maybe OC Kernel

    Default

    lol i'm stumped on this one. i can't think of anything that would get bt stuck other than a hardware issue. expecally once you restored everything back to a time before anything was done to the bt. hopefully someone with more knowledge on this can chime in.

    for the most part, if your not having issues now, it'll be hard to troubleshoot.
  8. Thread Author  Thread Author    #8  
    lobody94's Avatar

    Posts
    9 Posts
    Global Posts
    25 Global Posts

    Default

    It seems to be tasker doing it. I just tried my luck again with tasker and it did the same thing. I am glad I have titanium backup.

    I have uninstalled tasker

Posting Permissions