1. PiggyMiddle's Avatar
    Hi All,

    The new G was getting to be a mess with all the apps I was trying and uninstalling so decided to do a Factory Restore.

    All good and everything hooks up but I can't access the Play store at all. I just get a white screen with "Play Store" in the top left and the little circle-throbber in the screen middle.

    I set Sleep to 30-minutes and it has been seven minutes and still nothing.

    I can access the internet OK with YouTube app and Chrome and it is downloading Firefox as I type. At least I can get apps via a browser. Seems weird.

    Thoughts?

    Help?

    Thanks
    01-31-2014 10:55 AM
  2. VDub2174's Avatar
    Have you tried a battery pull/reboot?

    I was having trouble accessing my Play Store when I first got my Note 3. All I did was pull the battery and after it rebooted I was able to access the store.
    01-31-2014 11:01 AM
  3. alfick3's Avatar
    Have you tried a battery pull/reboot?

    I was having trouble accessing my Play Store when I first got my Note 3. All I did was pull the battery and after it rebooted I was able to access the store.
    That'd be all good, 'cept ya can't pull the battery of the Moto G. :-)

    Sent from my LG-MS770 using Tapatalk
    01-31-2014 11:08 AM
  4. VDub2174's Avatar
    That'd be all good, 'cept ya can't pull the battery of the Moto G. :-)

    Sent from my LG-MS770 using Tapatalk
    That's right, I forgot.
    alfick3 likes this.
    01-31-2014 11:12 AM
  5. PiggyMiddle's Avatar
    Thanks guys, but it is fixed - albeit by brute force.

    I used Chrome to get Firefox, then
    Firefox to get the Play store, then
    Logged in via Firefox to Google account then
    Reloaded Play Store and then
    Was asked to accept the Google conditions then
    Play store is available

    Having been a programmer for 35+ years I gotta say that some of this Google stuff seems like it has been coded by 5th graders in their Mother's kitchens.
    alfick3 and Nicole Summers like this.
    01-31-2014 11:36 AM

Similar Threads

  1. Pebble Store
    By wxrusss8 in forum Pebble Smartwatches
    Replies: 5
    Last Post: 02-11-2014, 12:09 AM
  2. Replies: 6
    Last Post: 02-06-2014, 10:14 AM
  3. Restore accounts and full settings?
    By deppi0 in forum Google Nexus 5
    Replies: 5
    Last Post: 02-03-2014, 07:24 AM
  4. Replies: 1
    Last Post: 01-31-2014, 04:11 PM
  5. S4 Mini plays ringtones but no music
    By Alina Doodnath in forum Samsung Galaxy S4 Mini
    Replies: 1
    Last Post: 01-31-2014, 06:40 AM
LINK TO POST COPIED TO CLIPBOARD