03-04-2017 03:50 AM
44 12
tools
  1. Arijitde's Avatar
    I just received my moto G 16gb last week and the 1st thing I tried was to download whatsapp. But I found the play store taking a long time to load. When I selected the 'instal' , I found no response. I thought there was net connection problem n decided to try later but faced the same problem every time. I noticed I could not download any app thereafter. I tried with WiFi too but the download starts n stops after a few seconds when I again have to manually off- re on the data to start again. I noticed if any call comes the downloading restarts temporarily.
    I contacted the customer care centre n they advised me to switch off, restart mobile/ clear cache partition/ do factory reset. I did all these but the problem is still present.
    I could however upgrade to KitKat uninterruptedly albeit bit slow. I can browse the net, but am getting lesser speed than with my previous blackberry curve on the same net plan.
    Please suggest what else can I do!
    Thanking u all in advance for ur responses.
    03-10-2014 03:45 PM
  2. mtvictor's Avatar
    I once was unable to use the playstore
    And it was because i disabled the Google service framework ..
    I don't know if that could help ^^

    Posted via Android Central App
    03-10-2014 10:31 PM
  3. nocial's Avatar
    Try downloading from your PC to phone via wifi. Check if the problem persists at another WiFi location.

    Sent from my XT1033 using Tapatalk
    03-11-2014 04:29 AM
  4. yuvarajg's Avatar
    Hi Nocial,
    I can able to download files using Wifi, but using mobile data I cannot able to download anything. Can u please suggest any solutions for this.
    03-11-2014 11:33 PM
  5. paulw3's Avatar
    Have you got "restrict background data" turned on in the Data Usage area?? I had this issue with my Nexus 4 and from memory that was the cause..
    Karthi Shady likes this.
    03-12-2014 01:12 AM
  6. Jatan Kamani's Avatar
    Even i am going through the same issue anyone can help me out.
    03-28-2014 05:22 AM
  7. Basil Benny's Avatar
    in my moto g 16 gb also loading playstore takes so much time..
    but opera is fast...
    plzz..help..
    cant download anything...
    04-28-2014 09:48 AM
  8. Viswanath Janapala's Avatar
    Hi guys....

    This thing is really killing my patience.
    One week back i bought Nokia 520 and i came to know that I cant use watsapp in that.
    So i replaced my mobile with Moto G.

    But now i m unable to download apps.

    Please help me.....
    05-28-2014 01:17 PM
  9. ColbyJvonBrown's Avatar
    It's probably because they're pushing out a new version of the Google Play store version 4.8. Any one else get the update or just me?

    Posted via Android Central App
    05-28-2014 03:27 PM
  10. Manish Singh5's Avatar
    Any Solution till date??
    06-23-2014 05:54 AM
  11. Manish Singh5's Avatar
    Having same problem :/
    06-23-2014 05:55 AM
  12. MotoEuser's Avatar
    I'm not able to download via WiFi in moto e . It keeps on loading but never completes
    07-30-2014 10:04 PM
  13. MotoEuser's Avatar
    I'm not able to download via WiFi in moto e . It keeps on loading but never completes
    08-01-2014 06:22 AM
  14. MotoEuser's Avatar
    Hey I got it working by simply restarting my mobile..
    08-01-2014 06:24 AM
  15. Pushpa Raj's Avatar
    hi sir i also have a same problem what should do sir
    08-05-2014 09:06 AM
  16. Pushpa Raj's Avatar
    i also have same problem u solve the pls to me
    08-05-2014 09:08 AM
  17. siddarth369's Avatar
    Make sure that you inserted atleast one sim in mobile. If you have not inserted sims, the apps like whatsapp unable to access your contact details and contacts info. so they will not install.
    08-28-2014 08:09 AM
  18. Sumit Jamuar's Avatar
    Hi there,
    I was facing the same problem and the below steps helped me. Please try these and see:
    Go to settings->Apps->Google Play-> Uninstall Updates

    Once the Google Play updates got uninstalled, I was able to download apps once again as before. Might have been some bug with the latest Google Play update.

    Hope this helps !
    10-19-2014 04:16 AM
  19. haikuflower's Avatar
    I just read on another forum that the problem can be due to light filters on your phone. I have Blue Light Filter installes, and in the app there is a place you can temporarily deactivate it. Do that (or force stop your other filter apps) and you should now be able to install/update the appstire, and install apps.
    10-20-2014 05:27 AM
  20. Eswaran K's Avatar
    Thanks to Sumit Jamuar #18,

    I recently purchased Moto G 16 gb (XT 1033), and facing the same problems mentioned by Arijitge #1,Yuvarajg #4. As per the instructions by Sumit Jamuar #18, I unisntalled the google play updates and the problems solved.
    10-26-2014 03:21 AM
  21. Saurabh Sood's Avatar
    I am facing the same problem with my moto g this side :|
    11-05-2014 02:52 AM
  22. Rajakrishna Reddy's Avatar
    I was able to install after uninstalling play store updates.

    Jummer #18 helped me.
    12-07-2014 10:19 AM
  23. goldfndr's Avatar
    I just read on another forum that the problem can be due to light filters on your phone. I have Blue Light Filter installes, and in the app there is a place you can temporarily deactivate it. Do that (or force stop your other filter apps) and you should now be able to install/update the appstire, and install apps.
    That only applies to the Install button, to prevent malicious automatic installs. The other posters presumably aren't yet being prompted to install.
    12-11-2014 09:48 AM
  24. Jeroz Coelho's Avatar
    I had the same issue. I did a simple task and it started working.

    Go to Settings-> Apps -> All -> Settings -> Reset app preferences.

    It started working immediately after I did this.

    Try and see. All the best.
    Stephanie Launiu likes this.
    01-09-2015 11:12 AM
  25. Abhishek k's Avatar
    I had also faced this problem and find out this solution:

    go to Settings-> App ->Google Play store

    1) do forced stop.
    2) Clear Cache


    restart your phone

    go to play store and download app. Make sure you have a valid data plan or wifi.

    It might be fix your problem.
    01-22-2015 07:08 AM
44 12

Similar Threads

  1. Best way to WOW someone with Note 3?
    By pcguys in forum AT&T Samsung Galaxy Note 3
    Replies: 22
    Last Post: 03-29-2014, 10:36 PM
  2. App to programatically delete folders
    By CP1832 in forum General Help and How To
    Replies: 5
    Last Post: 03-18-2014, 08:17 AM
  3. What happened to my PDF viewer?
    By SveinD in forum HTC One Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 03-16-2014, 05:41 AM
  4. Replies: 1
    Last Post: 03-10-2014, 10:34 PM
  5. App Needed
    By thatotherdude24 in forum General Help and How To
    Replies: 1
    Last Post: 03-10-2014, 03:15 PM
LINK TO POST COPIED TO CLIPBOARD