Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Moto G: Compass not working with Waze and Ingress

    I've had my Moto G since the first of the year and it's a great phone. Howver, I have one problem that's bugging me.

    The compass doesn't seem to work in navigation or while playing Ingress. In Ingress it ALWAYS points north and won't adjust to the compass heading, and yes I've turned the dynamic compass on. In Waze, which I use to navigate in the car it never knows which way I'm facing until I move and the GPS can detect my direction of motion.

    I downloaded a compass app just to make sure it was working, and it was fine. It also works in Google Maps.

    Has anyone else noticed this?
  2. #2  

    Default Re: Moto G Compass not working with Waze and Ingress

    I don't think the Moto G has hardware compass just the predictive GPS compass. I have the Moto X and my wife has the Moto G and none of the apps with compass features work any where as well as my Moto X.
  3. #3  

    Default Re: Moto G Compass not working with Waze and Ingress

    It does have a hardware compass. Which is easily confused by magnets in cases (including the official FLIP case).
  4. #4  

    Default Re: Moto G: Compass not working with Waze and Ingress

    Hi Brian !

    Did you get it to work ?

    Same problem here with a brand new moto g 8gb with Android 4.4.2 ...

    Compass is working fine - just not in Ingress !

    Thanks
    Tom
  5. Thread Author  Thread Author    #5  

    Default Re: Moto G: Compass not working with Waze and Ingress

    No, still not working in Ingress or Waze. Works fine in Google Maps. It's go to be something different about how it accesses the compass.

    Posted via Android Central App
  6. #6  

    Default Re: Moto G: Compass not working with Waze and Ingress

    I have the same problem! Any updates?
    Thanks
    Markus

Similar Threads

  1. are people not interested
    By david_august in forum LG G2 mini
    Replies: 5
    Last Post: 06-29-2014, 04:41 PM
  2. replaced broken screen and now colours don't display correctly - driver issue?
    By dalmore_pam in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 04-04-2014, 08:32 PM
  3. Problems with alphanumeric password & wifi
    By chri5tina in forum Samsung Galaxy S4 Active
    Replies: 1
    Last Post: 04-03-2014, 01:21 PM

Posting Permissions