Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  
    BuJ_14's Avatar

    Posts
    31 Posts
    Global Posts
    33 Global Posts

    Default Moto G Dropping T Mobile Service

    My Moto G with T Mobile Sim card just drops service once or twice a day. It says no service. I reboot it and play with the settings but the only way I've found to get it to work is so pop out the SIM Card and put it back in. Any ideas on what this is?

    Posted via Android Central App
  2. #2  

    Default Re: Moto G Dropping T Mobile Service

    It's most likely a bad T-Mobile connection in your area or a bad simcard. You could try and replace it.

    Posted via Android Central App
  3. #3  

    Default Re: Moto G Dropping T Mobile Service

    Hmm. There is a recognised problem with some phones in some areas that sounds like what you describe. Taks a look here:

    https://forums.motorola.com/posts/48fb0b8150

    Unfortunately, it's not been fixed yet (and there may be several variants), but Motorola knows about it and are trying to fix it.

    Before popping out the SIM card, have you tried:

    1) turning aeroplane mode on, then off again
    2) connecting to your network again (via Settings.. Wireless & Networks.. More.. Mobile networks.. Network operators)

    Some people have found that one or other of these helps.
  4. Thread Author  Thread Author    #4  
    BuJ_14's Avatar

    Posts
    31 Posts
    Global Posts
    33 Global Posts

    Default Re: Moto G Dropping T Mobile Service

    You were right. It seems to have been a bad SIM Card. I went to a T-Mobile store and they happily replaced it. It has worked perfectly since. Thanks!

    Posted via Android Central App

Similar Threads

  1. Moto Skip
    By benhaube in forum Moto X (2013)
    Replies: 10
    Last Post: 04-11-2014, 01:52 PM
  2. My T-Mobile Pre-order shipped
    By mackie99 in forum Samsung Galaxy S5
    Replies: 56
    Last Post: 04-10-2014, 09:42 PM
  3. My Moto G is overheating and draining battery while at it
    By Kalyan Venkatesh in forum Moto G (2013)
    Replies: 3
    Last Post: 04-10-2014, 03:41 AM
  4. Replies: 4
    Last Post: 04-09-2014, 01:44 AM
  5. Calls Extremely Silent On Moto G GPe
    By SPS828 in forum Moto G (2013)
    Replies: 1
    Last Post: 04-08-2014, 12:33 AM

Posting Permissions