1. Ivo-p's Avatar
    Hello. I have been quite anxious to receive that new 4.4.3 update that's gonna fix some bugs on the phone and improve stability
    So I kept checking manually for updates every day. However today when I try to the phone feels me I have no WiFi connection. And by posting this I do use WiFi. Switching on and off doesn't help. Neither using mobile connection. So does this mean that the servers are down and maybe getting prepped to roll out 4.4.3?
    Is it just me? This is my moto version
    As you can see its an European version.
    Attached Thumbnails No connection to Motorola's servers?-1402464218667.jpg  
    06-11-2014 12:24 AM
  2. Ry's Avatar
    Probably just down. Was down a couple weeks ago too. I wouldn't read too much into it.

    Posted via Android Central App (Moto X)
    Ivo-p likes this.
    06-11-2014 12:34 AM
  3. Gw0lgn's Avatar
    Think the update servers might have been down as mine was doing the same thing this morning.

    Posted via Android Central App
    06-11-2014 04:36 AM

Similar Threads

  1. Does weaker - but not no/barely any - signal still affect battery life?
    By icouldntpossiblycomment in forum Samsung Galaxy S5
    Replies: 13
    Last Post: 09-09-2015, 02:18 PM
  2. How to remove NO SIM NOTIFICATION
    By kchtwd09 in forum Sprint Samsung Galaxy S4
    Replies: 2
    Last Post: 07-01-2014, 03:53 PM
  3. Encrypton took 8 minutes to Encrypt
    By android_freak1 in forum Android 4.4 KitKat
    Replies: 3
    Last Post: 06-11-2014, 10:25 AM
  4. How to tell LCD Screen and Digitizer are broken?
    By bsasaki in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 1
    Last Post: 06-10-2014, 09:47 PM
  5. S4 connection to tv
    By badjujumatt in forum Verizon Samsung Galaxy S4
    Replies: 0
    Last Post: 06-10-2014, 06:33 PM
LINK TO POST COPIED TO CLIPBOARD