Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default Moto G issues connecting with home router

    Hi, I have tried searching for a few days, and not found exactly what I need answered. My husband's Moto G will not connect to our home router. He doesn't have a data plan, so this is the only way to use internet at home. It has connected elsewhere, with or without password, in no time at all.

    Yes, our wireless has a password and that is correct. The wireless works seamlessly with any and all Kindles, iPods, and my Sony tablet. I'm not sure how to list what I've adjusted; I've done so many things to the phone and the router and still no luck.

    Any and all suggestions would be great. I'm not any kind of expert, but I can follow directions well and know enough how not to screw anything up permanently.

    TIA!
  2. #2  

    Default Re: Moto G issues connecting with home router

    Welcome to Android Central! Review this guide and see if the tips help: http://forums.androidcentral.com/amb...-problems.html
  3. Thread Author  Thread Author    #3  

    Default Re: Moto G issues connecting with home router

    Just to be sure I didn't miss any steps, I re-read that article. It was one of the first ones I found. Nothing on that guide changes the connection. All the troubleshooting for the wireless modem changes nothing, nor does turning on and off the security. There is no USB port, and it isn't a dual band. The
    'avoid poor connections' and 'wifi optimizations' are not options on the phone.

    If you see the (unconnected, after forgetting) SSID for our wireless on the phone, its full strength. As soon as you try to connect, and enter the password, it drops to poor. As I noted, I've been searching and trying things from the site for a few days. I was hoping to find out if there was something I was missing.
  4. #4  

    Default Re: Moto G issues connecting with home router

    I've seen that kind of behavior before, but usually a router reboot clears it up. How about booting the phone into Recovery Mode and wiping the cache partition? The steps for the Moto G should be the same as for the Moto X: Reset: Motorola Moto X | T-Mobile Support

Similar Threads

  1. can I get texts off an s4 with a broken screen
    By Valerie Esposito in forum Ask a Question
    Replies: 1
    Last Post: 09-08-2014, 07:46 PM
  2. Something weird has happened when connecting to my PC
    By ladypatricia in forum Samsung Galaxy Note 3
    Replies: 7
    Last Post: 08-11-2014, 08:35 AM
  3. My phone does not connect to wifi!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-11-2014, 02:34 AM
  4. How would i connect my tab 3 8.0 to my tv without hdmi?
    By Onetwothreefourfivethreetwo in forum Samsung Galaxy Tab 3
    Replies: 2
    Last Post: 08-10-2014, 07:13 PM
  5. Odd behavior with Wifi Hotspot
    By fraunpetri1 in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 08-10-2014, 05:07 PM

Posting Permissions