1. PlayDLine's Avatar
    I'm having some problems when I connect the Moto X to the PC.
    Usually this is an automatic process - today (first time I tried to connect the phone to the PC) the PC could not find the proper drivers (any Motorola drivers) and simply loaded a generic MTP driver. I'm not able to access my photos, music, etc. Has anyone else had any problems of this sort?
    09-24-2013 01:45 PM
  2. TechTinker's Avatar
    Make sure its connected as MTP device, should download the drivers for you, and do you have USB debugging activated?
    Go to Settings > Developer Options (Go into your about phone and tap quickly a few times on your build number. If its not in your settings.) > Check USB Debugging.
    09-24-2013 01:58 PM
  3. PlayDLine's Avatar
    Make sure its connected as MTP device, should download the drivers for you, and do you have USB debugging activated?
    Go to Settings > Developer Options (Go into your about phone and tap quickly a few times on your build number. If its not in your settings.) > Check USB Debugging.
    Yes - everything is as it should be - just not recognizing it with any Motorola drivers. I'm thinking it should, rather than the generic MTP. Maybe this is just different from what I'm used to.
    09-24-2013 02:01 PM
  4. TechTinker's Avatar
    Yes - everything is as it should be - just not recognizing it with any Motorola drivers. I'm thinking it should, rather than the generic MTP. Maybe this is just different from what I'm used to.
    Well heres the drivers. Hm maybe try different USB ports? I found my phone connects only one 1 out of the 3 ports on my laptop.
    PlayDLine likes this.
    09-24-2013 02:05 PM
  5. PlayDLine's Avatar
    Well heres the drivers. Hm maybe try different USB ports? I found my phone connects only one 1 out of the 3 ports on my laptop.
    Thanks for the willingness to help - I'll see if this works out.
    09-24-2013 02:24 PM
  6. Navin Mamidi's Avatar
    Even i have the same problem i am not able to connect my moto x with any of the windows system.

    MTP is on and USB de bugging os off and USB drivers are there in my PC, but still i am not able to connect please help me
    06-24-2014 11:21 PM
  7. Groid's Avatar
    When I connect my X to my compter, it shows as an XT1053 in File Manager. In My Computer, it shows as XT1053, Portable Media Player. In Device Manager, it shows under Android Device as Mot Composite ADB Interface. It also shows up under Portable Devices an XT1053. I have full read/write access to internal storage (sdcard). If you don't see the same designations, try uninstalling and deleting drivers in Device Manager and let them reinstall with the correct ones.
    06-25-2014 10:53 AM

Similar Threads

  1. Samsung s3 multi windows tab grey out and refuses to enable
    By wise14life in forum Samsung Galaxy SIII I9300
    Replies: 6
    Last Post: 12-10-2013, 05:44 AM
  2. Replies: 1
    Last Post: 10-16-2013, 11:45 AM
  3. 2 US Cellular Samsung Galaxy S3 32gb, With Extras
    By c_elliott83 in forum Marketplace Archive
    Replies: 10
    Last Post: 10-13-2013, 10:08 AM
  4. I'm so jealous of all you people with working Moto X's
    By tomatosouplabs in forum Moto X (2013)
    Replies: 17
    Last Post: 09-28-2013, 08:13 AM
  5. GS4 from Iphone and imessage
    By jberts22 in forum Samsung Galaxy S4 Active
    Replies: 1
    Last Post: 09-24-2013, 10:43 PM
LINK TO POST COPIED TO CLIPBOARD