1. jcstek's Avatar
    Hey guys. Just got my Moto X and so far am enjoying it. Not sure if in gonna keep it over my G2 though.

    Anyway, for some reason my Moto X cannot connect over my Wifi. The phone connects to the network, but cannot pull down data for some reason. Every other device in my house works just fine. Any ideas??

    Posted via Android Central App
    01-06-2014 09:09 PM
  2. Golfdriver97's Avatar
    Hey guys. Just got my Moto X and so far am enjoying it. Not sure if in gonna keep it over my G2 though.

    Anyway, for some reason my Moto X cannot connect over my Wifi. The phone connects to the network, but cannot pull down data for some reason. Every other device in my house works just fine. Any ideas??

    Posted via Android Central App
    Try rebooting?

    Sent from my Nexus 5 using AC Forums mobile app
    01-06-2014 09:30 PM
  3. ETPhoneHomeT's Avatar
    If you had it paired to your home network previously, try forgetting the current pairing then repair maybe?
    Golfdriver97 likes this.
    01-06-2014 10:22 PM
  4. VAYinzer's Avatar
    Interesting and I've been wondering the same thing. I had this problem but only on a specific WiFi connection when I was back home for Christmas. My Moto X connected successfully to every other WiFi but when I went home, every time I tried connecting to my in-laws WiFi, my Moto X could not verify the network. However, my wife's Moto X worked fine and also my Nexus 10. I tried rebooting, forgetting the network and retrying but nothing worked. Is it a software issue? Any suggestions?
    01-07-2014 07:50 AM
  5. snoking's Avatar
    Did you rebooth the WiFi router? Chris

    Sent from my A200 using AC Forums mobile app
    Golfdriver97 likes this.
    01-07-2014 09:36 AM
  6. jcstek's Avatar
    Try rebooting?

    Sent from my Nexus 5 using AC Forums mobile app
    Yeah I tried that. Both my phone and the router. Nutin.

    Posted via Android Central App
    01-07-2014 08:13 PM
  7. mhunter6378's Avatar
    What brand router is it. Reason I ask is I had some connection issues in the past with a Dlink router. Turned out that the router needed a firmware update, after that no more problem.
    Golfdriver97 likes this.
    01-07-2014 08:18 PM
  8. jonovan dotson dotson's Avatar
    the router is called arris and everytime i try to sign into the wi-fi it say authenication problem any help.
    06-20-2014 07:59 AM
  9. delrey1900's Avatar
    My old Linksys was solid with my Moto X, now this new Xfinity router I have is a different story. I constantly have to turn WiFi on and off to get it to work.
    Also, make sure you don't have another connection saved in your history that is close or the same name as your home router. That happened to me once between my house and my parents house. Took me a while to figure out why my phone wouldn't connect properly to their router.
    06-20-2014 12:17 PM
  10. eric002's Avatar
    Make sure the password is correct of course the other characters and numbers in it try to reset the router again and reboot your phone once and see if that works on my brand new Cablevision/ optimum wifi router in my apartment my Moto X is fine...

    Posted via Android Central App
    06-20-2014 07:28 PM

Similar Threads

  1. My Galaxy won't Turn off?
    By Allison Eastham in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 12
    Last Post: 02-22-2015, 04:00 AM
  2. Verizon S3: Can't turn off lock screen with 4.3?
    By isabel95 in forum Verizon Galaxy S III
    Replies: 20
    Last Post: 10-11-2014, 05:51 PM
  3. Looking for a program to help organize my home screens.
    By delta7 in forum Samsung Galaxy S4
    Replies: 7
    Last Post: 01-28-2014, 09:25 PM
  4. Swiftkey disappeared when I updated to 4.3
    By isabel95 in forum Verizon Galaxy S III
    Replies: 4
    Last Post: 01-07-2014, 09:37 AM
  5. best way to charge g2
    By Josh1303 in forum LG G2
    Replies: 5
    Last Post: 01-06-2014, 08:49 PM
LINK TO POST COPIED TO CLIPBOARD