1. NealJ777's Avatar
    Anyone else having issues with "What's this song"?

    If I ask Google Now 'What's this song?' instead of listening for music it does a Google search for 'What's this song'

    I tried deleting the data and clearing the cache within Google Search but that didn't work. It still works if I do it on my Nexus 7.

    Sent from my Moto X using Tapatalk
    01-26-2014 09:32 AM
  2. ultravisitor's Avatar
    Worked fine for me last night when I asked, "Okay Google Now, what song is this?"
    01-26-2014 09:41 AM
  3. NealJ777's Avatar
    Okay, but it's not working for me.
    01-26-2014 03:53 PM
  4. ballisticn8's Avatar
    It's specifically looking for the phrase what song is this not what's this song. If you're asking it what's this song it won't work.

    sent from my thumbs...
    Ry likes this.
    01-26-2014 10:12 PM
  5. Ry's Avatar
    It's specifically looking for the phrase what song is this not what's this song. If you're asking it what's this song it won't work.

    sent from my thumbs...
    I just tested "OK Google Now" -

    - "What song is this?"
    - "What is this song?"
    - "What's this song?"

    All three queries brought up the Sound Search listening feature.

    Posted via Android Central App
    01-26-2014 11:53 PM
  6. NealJ777's Avatar
    It's specifically looking for the phrase what song is this not what's this song. If you're asking it what's this song it won't work.

    sent from my thumbs...
    Actually, "What's this song?" and "What song is this?" are both valid, although, neither one is working for me right now.

    - - - Updated - - -

    I just tested "OK Google Now" -

    - "What song is this?"
    - "What is this song?"
    - "What's this song?"

    All three queries brought up the Sound Search listening feature.

    Posted via Android Central App
    Okay. I am glad that it is working for you, but it is not working for me. I'm trying to find a solution.
    01-27-2014 06:31 AM
  7. Ry's Avatar
    Okay. I am glad that it is working for you, but it is not working for me. I'm trying to find a solution.
    My reply was to ballisticn8 who said that the phrases you're saying aren't supposed to be working.
    01-27-2014 11:06 AM
  8. NealJ777's Avatar
    Okay. I'm sorry. Just frustrated.

    Sent from my Moto X using Tapatalk
    01-27-2014 11:07 AM
  9. clankfu's Avatar
    Strange but I just tried this today while I was driving and it didn't work for me either. Like the OP, it just did a search for "What song is this".

    I've used it several times in the past but it's not working me now.

    EDIT: I just tried, "What's playing" and it worked!

    "What song is this", "What's this song", "Listen to song" or "Listen to music" do not work for me.
    02-11-2014 06:34 PM
  10. GadgetGator's Avatar
    That is strange as I used it in that time period you did and it worked fine. Maybe a temporary server error.

    Posted via Android Central App
    02-16-2014 10:18 PM
  11. clankfu's Avatar
    That is strange as I used it in that time period you did and it worked fine. Maybe a temporary server error.

    Posted via Android Central App
    It actually started working for me again so it must've been a problem on the server side like you said. Still strange though.
    02-16-2014 10:21 PM
  12. Tom in Bristol's Avatar
    'What's this song?' worked for me and I learned that T-Mo is using Lady Hawke's 'Blue Eyes' on one of their tv ads! lol
    Ry likes this.
    02-17-2014 11:02 PM
  13. Salih AW's Avatar
    I'm having the same problem using, Moto assist.
    "Okay Moto"> "What's this Song?"
    'Listening for music'>
    quickly(without listening) 'Couldn't find a match.
    Something went wrong. Try again.

    The oddest thing is that; this is a recent problem and app was working fine, the last time I tried it last month. I tried powering on/off several times, I've done a soft reset None of which helped, can anyone else suggest something? Yes, I did the correct command.
    08-21-2015 02:51 PM
  14. b_slow1's Avatar
    I'm having the same problem using, Moto assist.
    "Okay Moto"> "What's this Song?"
    'Listening for music'>
    quickly(without listening) 'Couldn't find a match.
    Something went wrong. Try again.

    The oddest thing is that; this is a recent problem and app was working fine, the last time I tried it last month. I tried powering on/off several times, I've done a soft reset None of which helped, can anyone else suggest something? Yes, I did the correct command.
    I'm having a similar issue. When I use the Touchless Control feature to ask the phone "What song is this?", I get the same error message that you get. But if I press the Google Now microphone and ask the question, it works fine.

    I swear, this is just one of many software issues that I never came across on Android 4.4.4. Only since the update to 5.1. Is it just a coincidence, or is this software buggy as hell?
    08-22-2015 12:15 AM
  15. clankfu's Avatar
    I swear, this is just one of many software issues that I never came across on Android 4.4.4. Only since the update to 5.1. Is it just a coincidence, or is this software buggy as hell?
    I'm experiencing the same error on 4.4.4.
    08-22-2015 03:18 PM
  16. Salih AW's Avatar
    I'm more bugged that I can't get a straight answer/fix from someone(voice) directly. I really haven't had too many other probs, but 1 hopping this is the same issue... In June my hangout software wouldn't connect + send.- others were having that same prob. Hangouts began working mysteriously after a day or two. A Motorola tech told me today:that widgit(What's this song) won't work if Moto Assist is on.- What?! It hasbeen working with it on before. Idk what to do...

    Actually I couldn't do as many things on 4.4 as I can now on 5.1
    08-22-2015 03:18 PM
  17. b_slow1's Avatar
    I'm more bugged that I can't get a straight answer/fix from someone(voice) directly. I really haven't had too many other probs, but 1 hopping this is the same issue... In June my hangout software wouldn't connect + send.- others were having that same prob. Hangouts began working mysteriously after a day or two. A Motorola tech told me today:that widgit(What's this song) won't work if Moto Assist is on.- What?! It hasbeen working with it on before. Idk what to do...

    Actually I couldn't do as many things on 4.4 as I can now on 5.1
    A Moto tech told me today that "What song is this?" is no longer a question that I can ask through Moto Voice because of "improvements" to the phone after Android 5.1. These people are either stupid or they're liars. I haven't decided yet.

    I'm curious: what is it that you can do on 5.1 that you couldn't do on 4.4.4?

    From my perspective, I've lost the ability to toggle cell towers on/off with Tasker, lost the ability to easily toggle Data on/off without the Settings menu popping up, lost the "wave to wake" feature, lost my Xposed Framework, this Moto Voice issue has popped up out of nowhere, and battery improvements are debatable (at best).

    In return, I obtained the ability to customize my phrase for Moto Voice, and a whole lot of pretty colors. I think I got hosed.
    08-22-2015 03:43 PM
  18. Salih AW's Avatar
    For me, I was unable to wakeup my phone via voice. I was using a Moto g phone with 4.4 and the voice app(OpenMic) I was using didn't work well.
    So all the voice commands using Openmic were fixed, including the train ones voice. When I upgraded to new Moto x(2nd) it came install with 5.1. All the voice troubles I had with 4.4 worked well with Moto Assist & 5.1 Notifications are read to me aloud, also the time and Google now info are read aloud. I'm able to send txt + email by voice- which 4.4 really didn't allow me to do. Oh another feature/s that improved is playing certain music & making calls by voice. 9 1/2 stars I give those improvements
    With this latest issue 7 1/2 stars
    btw those are pretty much the only things I use. the wave to wake thing works excellent on my phone- I haven't used Tasker?
    I just called Motorola again; "Try a soft reset.", 'I did that 2wice already', "Ok please try a full reset."
    Man, I'm not doing that- having to reinstall+redo settings to all my apps
    08-22-2015 04:33 PM
  19. b_slow1's Avatar
    For me, I was unable to wakeup my phone via voice. I was using a Moto g phone with 4.4 and the voice app(OpenMic) I was using didn't work well.
    So all the voice commands using Openmic were fixed, including the train ones voice. When I upgraded to new Moto x(2nd) it came install with 5.1. All the voice troubles I had with 4.4 worked well with Moto Assist & 5.1 Notifications are read to me aloud, also the time and Google now info are read aloud. I'm able to send txt + email by voice- which 4.4 really didn't allow me to do. Oh another feature/s that improved is playing certain music & making calls by voice. 9 1/2 stars I give those improvements
    With this latest issue 7 1/2 stars
    btw those are pretty much the only things I use. the wave to wake thing works excellent on my phone- I haven't used Tasker?
    I just called Motorola again; "Try a soft reset.", 'I did that 2wice already', "Ok please try a full reset."
    Man, I'm not doing that- having to reinstall+redo settings to all my apps
    Their solution to everything is always "do a reset". They're so full of it.

    If you have the 2014 Moto X, that explains why your "wave to wake" function works. On the 2013 model, like the one I have, it wasn't really a feature that the phone was supposed to have, but it worked on Kit Kat anyway. Now with Lollipop, it stopped working.

    It's not a BIG deal, but I'm just struggling to see what the point of this system update was. Why change things when NOTHING gets improved? And why force me to download it if I didn't want to?
    Salih AW likes this.
    08-22-2015 09:19 PM
  20. Salih AW's Avatar
    Dude, I have the Moto X (2nd Gen) 2015.- It's an awesome phone. 'ey man just let me know when & how your, 'What's this song?'. works If it will ever work for us... lol keep in touch.
    08-23-2015 11:24 AM
  21. Salih AW's Avatar
    Has anyone 'what's this song?' widgit began to work with moto assist?? If so what is the trick to get it working... smh still
    08-24-2015 08:06 PM
  22. Salih AW's Avatar
    Well, my friends I broke down and did a factory reset. Low & behold the problem was resolved. Luckily the 'T-Mobile' girl was soo cute that she persuaded me to do a factory rest. lol
    09-16-2015 03:19 PM
  23. linuxbaby03's Avatar
    I just tried the same on my moto XT1095 (Pure Edition), namely "OK Google Now, what song is this?" along with the other variants listed in this thread. It recognized the command but failed to allow google to actually listen to the song. Interestingly, I just did a massive factory reset (Had to go all the way down to kitkat to recover after a soft brick from the stagefright patch, yes, I was rooted at the time.. derp). Strangely, I'm not rooted now and this still won't work for me.
    09-25-2015 08:23 AM
  24. Salih AW's Avatar
    Hey, I tried "what's this song?", this morning, but I'm not sure if the request stop working due to an upgrade I did prior to testing, "What's this song?". It has been working since I factory reboot on 9/16. As of now( 9/25 ), it's not working.
    09-25-2015 07:17 PM
  25. Niteen Gadekar's Avatar
    This service is limited to few countries
    From version 6.12.25.21.arm64
    02-23-2017 11:01 PM

Similar Threads

  1. Xperia Z1: What camera settings do you use?
    By I Can Be Your Hero in forum Sony Xperia Z1
    Replies: 2
    Last Post: 02-22-2014, 11:12 PM
  2. Notification is no longer working
    By Peaches36 in forum T-Mobile Samsung Galaxy Note 3
    Replies: 3
    Last Post: 02-02-2014, 07:30 AM
  3. Can't get music voice control to work
    By Dansole in forum Verizon Galaxy S III
    Replies: 0
    Last Post: 01-26-2014, 08:53 AM
  4. Samsung Galaxy Note 3 not using the normal sounds for locking and unlocking
    By Tommy Sebestyen in forum Samsung Galaxy Note 3 in Canada (Bell/Rogers/Telus)
    Replies: 0
    Last Post: 01-26-2014, 08:50 AM
LINK TO POST COPIED TO CLIPBOARD