Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread Author  Thread Author    #1  

    Default Is this normal charging behavior?

    I just received my Moto X and I'm wondering if this behavior is normal.

    -When I plug in the microUSB cable, the battery icon do not show the lightning bolt to indicate its charging, I have to pull down the quick toggles to see it.
    -The phone do not make any sound when plugged in.
    -In the Settings -> Battery stats menu. The phone regarded the phone while plugged in and fully charged as still being on battery. So it added the time that the phone is fully charged into the timeline of battery used.
    -When I turn off the phone and it is plugged in, it do not have any "charging mode while powered off". Instead the phone immediately turned back on. Is this normal? Or is there supposed to be something like this, which I do not see: http://images.anandtech.com/doci/7235/MotoX-0206.jpg

    -What I've tried:
    -Factory reset
    -Using different cables
    -Phone is completely stock, unmodified

    Side issue: The "Google Play services" (GmsCore) crashes a lot, especially when just turned on. Even after a factory reset, after signing in Google account, 1 minute later it crashed.

    Not sure if all this can be fixed with a software update when it gets 4.4.2 maybe, it seems more like a software problem, but perhaps I'll use this excuse to return it and get the ebony wood color.
  2. #2  

    Default Re: Is this normal charging behavior?

    No beep is normal for the Moto X. The dark lightning bolt for the charger is hard to see if the battery is low but it should be there. You said you used different cables but did you use a different charger?
  3. Thread Author  Thread Author    #3  

    Default Re: Is this normal charging behavior?

    No lightning bolt at all. 3 different cables, original charger, Anker 2.5amp charger, and desktop. It charges and connect fine, just seems like it's missing some software component that allow it to detect it correctly and doesn't charge while powered off, but just turn back on.
  4. #4  

    Default Re: Is this normal charging behavior?

    Did you try letting it charge for a couple hours and see if it charge at all? If something like this happens I tend to just charge it for a 2-3 hours and see if the battery gets charged. I really don't mind if the phone doesn't indicate it's charging or not if it still does the job.
  5. #5  
    natehoy's Avatar

    Posts
    1,648 Posts
    ROM
    Stock

    Default Re: Is this normal charging behavior?

    Quote Originally Posted by someguy01234 View Post
    I just received my Moto X and I'm wondering if this behavior is normal.
    No, it's not.

    Part of me says "it's charging, no big deal" but to be perfectly blunt you're gonna be with this phone for a while - while it's still brandy-new I'd get it exchanged immediately if it misbehaves in any way. That way, three months down the line, the problem doesn't stand a chance of getting all fatal and you're stuck with a dud.

    If this is a freebie hand-me-down or something you bought used and can't exchange, fine, you'll probably never have a problem.

    But if you bought it new, you deserve something that acts like new.

    The "Google Play services" (GmsCore) crashes a lot, especially when just turned on.
    This is actually what concerns me the most, not odd charging behavior. This is a sign that something is very wrong somewhere. 90% chance it's just a bad flash image, but that could point to a memory fault, and you as the user should not need to be getting into re-flashing a stock image (though if it's a used one, you might try that...)
    Phones: BB 8820 -> BB 8310 -> HTC Thunderbolt -> LG Optimus G Pro -> Moto X
  6. Thread Author  Thread Author    #6  

    Default Re: Is this normal charging behavior?

    Thanks. I went a head and ask for exchange, but I have to wait for them to mail me another code to get the $100 discount.

    I asked about people who have extended warranty and what would happen when Lenovo takes over, but they didn't have anything definitive.
  7. #7  
    natehoy's Avatar

    Posts
    1,648 Posts
    ROM
    Stock

    Default Re: Is this normal charging behavior?

    Quote Originally Posted by someguy01234 View Post
    Thanks. I went a head and ask for exchange, but I have to wait for them to mail me another code to get the $100 discount.

    I asked about people who have extended warranty and what would happen when Lenovo takes over, but they didn't have anything definitive.
    Nothing will happen when Lenovo takes over in terms of warranty. Lenovo will either absorb the warranties or hire a third party to manage them. They're a solid brand with a good reputation, they aren't going to screw up warranty support on the brand they bought.

    Regardless, you bought a new phone, you deserve one that performs properly.
    Phones: BB 8820 -> BB 8310 -> HTC Thunderbolt -> LG Optimus G Pro -> Moto X
  8. Thread Author  Thread Author    #8  

    Default Re: Is this normal charging behavior?

    I got my 2nd Moto X and it had the same issue, except the the Battery stats could recognize when it's fully charged. It still didn't show lighting bolt or have powered off charging mode.

    After unlocking the bootloader (was going to do it eventually) and the second time of reflashing the 4.4 firmware and manually updating to 4.4.2, it's finally working (not recommended to downgrade Motorola phones or you may brick it, it's very different than how Nexus work). Seems to be a software issue from Motorola, wherever they put the charging animation, I think it's in one of the separate partition, it was missing before. I read people with the Moto G have the same issues, some mentioned Motorola updated the start up process through PlayStore, not sure that was the case since I had the issue on mine even fully updated. Likely which ever partition in the phone that holds the charging animation was missing it.
    Last edited by someguy01234; 02-12-2014 at 05:22 PM.

Similar Threads

  1. Heading to Switzerland this Summer.
    By aspenedelen in forum Verizon Samsung Galaxy Note 3
    Replies: 22
    Last Post: 03-26-2014, 03:26 PM
  2. PSA: Ebony Natural Moto X trim material is metal
    By Papadakis in forum Moto X (2013)
    Replies: 17
    Last Post: 02-11-2014, 09:49 AM
  3. ;) This gives me some Hope, I hope for Moto X 2 ?
    By davidnc in forum Moto X (2014)
    Replies: 18
    Last Post: 02-10-2014, 04:23 PM
  4. Chromecast only working when USB is plugged into computer?
    By omahamatt in forum Google Chromecast
    Replies: 3
    Last Post: 02-01-2014, 09:44 AM

Posting Permissions