1. anthony1117's Avatar
    So i do have T Mobile LTE in my area. BUt for some reason the Moto X, that i ordered from motorola is not getting it. I called the coustomer support and they told me just like, well, idk what to do. SO should i go down to the store and try a new sim card?
    02-09-2014 11:49 AM
  2. PapaGary's Avatar
    SO should i go down to the store and try a new sim card?
    Yes.
    02-09-2014 11:59 AM
  3. asdrew's Avatar
    I was wondering if I had the same issue then went to the other side of town to find out that LTE works there just fine. T-mobile coverage just stinks near my home & office despite their misleading coverage maps :/
    02-09-2014 02:03 PM
  4. anthony1117's Avatar
    So i went to the store and swapped my SD card. They swapped, and i had LTE, but once they activated the new sim for my number i lost it again and they told me to call tech support again. So i might switch
    02-09-2014 02:43 PM

Similar Threads

  1. T-Mobile KitKat Update - Alarm Clock
    By 2plus2equals4 in forum HTC One M7
    Replies: 20
    Last Post: 07-16-2015, 04:37 PM
  2. 4G/LTE activation for Galaxy S4 Active
    By ekendraed in forum Samsung Galaxy S4 Active
    Replies: 1
    Last Post: 02-14-2014, 04:24 AM
  3. T-Mobile paying your ETF??
    By Closingracer in forum T-Mobile
    Replies: 9
    Last Post: 02-09-2014, 02:42 PM
  4. Boost Mobile Moto G: KitKat 4.4.2
    By budweiser in forum Moto G (2013)
    Replies: 0
    Last Post: 02-09-2014, 11:45 AM
  5. Will the Samsung Galaxy Note 10.1 (2014) LTE ever show up on VZW?
    By SHIVA77 in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 1
    Last Post: 02-09-2014, 01:36 AM
LINK TO POST COPIED TO CLIPBOARD