Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 24 of 24
  1. Thread Author  Thread Author    #1  

    Default MMS pictures not displaying (AT&T)

    About 80% of the time when people send me pictures over MMS, they don't display. See my screenshots below--it appears that the pic was downloaded (because it says 174KB) but I can't do anything to see it. Forwarding it doesn't work; it gives me the same placeholder icon. It allows me to save the attachment, but then nothing gets saved.

    Normal Moto X on AT&T in New York City
    Kitkat 4.4
    Default Messaging app (not Hangouts--which I don't want to use)
    Already reset the APNs (hadn't changed anything anyway)
    MMS messages is set to automatically retrieve (except on roaming)
    Same malfunction when receiving from AT&T iPhones and from a Verizon Moto X

    Anyone have any tips or have the same problem?
    Attached Thumbnails Attached Thumbnails MMS pictures not displaying (AT&T)-screenshot_2014-02-12-11-27-55.png   MMS pictures not displaying (AT&T)-screenshot_2014-02-12-11-28-18.png  
  2. #2  
    JoeNM84's Avatar

    Posts
    487 Posts
    Global Posts
    502 Global Posts

    Default Re: MMS pictures not displaying (AT&T)

    If you turn wifi off does it work? I remember having this issue sometimes when I was on wifi on my GNex.
  3. #3  

    Default Re: MMS pictures not displaying (AT&T)

    I ordered 2 Unlocked GSM moto xs from the play store. My wife's 16 gb worked just fine, but my 32gb unit wouldn't send or receive mms on ATT I read on line and found that if you changed the APN setting for the MMS port to 8080 it worked for some people, some I found said their's was originally just 80 and once they made it 8080 it worked good....mine had nothing on that APN setting, so I put 8080 in there and it worked like a champ. I have yet to check my wife's as to what hers was set on.

    Justin
  4. Thread Author  Thread Author    #4  

    Default Re: MMS pictures not displaying (AT&T)

    Problem solved, or at least worked around. I can save the jpeg attachments from these non-displaying MMS messages. I use Astro file viewer to explore my Downloads folder, where I see the saved images. However, most image viewers (Gallery, Photos, Quickpic and Astro's built-in viewer) cannot view the jpegs--they either display an all-black image or give a "media not found" error message. Finally I found an image viewer that can display the saved jpegs; it's called Perfect Viewer. It appears to be intended for comic book viewing, but it handles normal images just fine. It's free, so now I just have it on my phone as a backup image viewer for this one purpose.

    I think the issue boils down to the MMS jpegs being corrupted (maybe when converted to MMS size by the phone that sent them?). I can connect the phone to my PC and view them in Windows. When I do, I notice a white line at the bottom of the image, and some macropixels in the lower corners. So it appears that most Android image viewers are just really picky about jpeg file integrity.
  5. #5  

    Default Re: MMS pictures not displaying (AT&T)

    My has been having this same problem. Whenever I send a picture with my HTC one on Sprint they only show up about half the time. Something happens when her sister sends a pic from her iPhone. Has anyone found a solution?

    Sent from my HTCONE using Tapatalk
  6. #6  

    Default Re: MMS pictures not displaying (AT&T)

    I have been having issues with getting pics from iphones also. Was same on my galaxy s3.
  7. Thread Author  Thread Author    #7  

    Default Re: MMS pictures not displaying (AT&T)

    I posted my workarounds here: http://forums.androidcentral.com/mot...isplaying.html

    Maybe they'll work for you too.
    Last edited by portablealpha; 02-17-2014 at 09:24 PM. Reason: Updated URL
  8. #8  

    Default Re: MMS pictures not displaying (AT&T)

    Quote Originally Posted by 4runnerbrett View Post
    I have been having issues with getting pics from iphones also. Was same on my galaxy s3.
    50/50 chance that this is Apple's issue. Apple tries to route all their traffic via the iMessage inhouse networks and people without iPhones typically get punked more often than not.
  9. #9  

    Default Re: MMS pictures not displaying (AT&T)

    I had the same issue. downloaded a different sms app as the work around. using Textra and pictures show up as they should.
  10. #10  
    sting7k's Avatar

    Posts
    531 Posts
    Global Posts
    3,451 Global Posts
    ROM
    Stock JB 4.2

    Default Re: MMS pictures not displaying (AT&T)

    Quote Originally Posted by PDT816 View Post
    50/50 chance that this is Apple's issue. Apple tries to route all their traffic via the iMessage inhouse networks and people without iPhones typically get punked more often than not.
    It's not, I am unable to receive MMS from all types of phones.

    Beamed via my Nexus 7 from the AC Forums app.
  11. #11  

    Default Re: MMS pictures not displaying (AT&T)

    Quote Originally Posted by PDT816 View Post
    50/50 chance that this is Apple's issue. Apple tries to route all their traffic via the iMessage inhouse networks and people without iPhones typically get punked more often than not.
    this.

    im in a group chat with 4 others, all of them on iphone and this happens once in awhile. the only way i noticed a "fix" was i restarted the phone and uninstalled/reinstalled hangouts.

    it has become a finger pointing game where people blame carriers, then the phones, then hangouts. but with no real solution. le sigh
  12. #12  

    Default Re: MMS pictures not displaying (AT&T)

    Quote Originally Posted by TNScrambler View Post
    I ordered 2 Unlocked GSM moto xs from the play store. My wife's 16 gb worked just fine, but my 32gb unit wouldn't send or receive mms on ATT I read on line and found that if you changed the APN setting for the MMS port to 8080 it worked for some people, some I found said their's was originally just 80 and once they made it 8080 it worked good....mine had nothing on that APN setting, so I put 8080 in there and it worked like a champ. I have yet to check my wife's as to what hers was set on.


    Justin
    Had the same issue, this worked for me as well.
  13. #13  

    Default Re: MMS pictures not displaying (AT&T)

    I just tried the 8080 thing will see if that works for me. Mine was also blank.
  14. #14  

    Default Re: MMS pictures not displaying (AT&T)

    ill take it this 8080 thing is an att thing only?
  15. #15  

    Default Re: MMS pictures not displaying (AT&T)

    Quote Originally Posted by shaytoon21 View Post
    ill take it this 8080 thing is an att thing only?
    Not sure but I am on ATT and it worked.
  16. #16  

    Default Re: MMS pictures not displaying (AT&T)

    im on verizon so i want to see if i can do the same thing? if so, how do i go about changing it?
  17. #17  

    Default Re: MMS pictures not displaying (AT&T)

    Double post
  18. #18  

    Default Re: MMS pictures not displaying (AT&T)

    Settings then go down to more then mobile networks. Click on access point names. Then click on your profile att phone or whatever yours is called and go down to the MMS port box and put in 8080
    Last edited by 4runnerbrett; 02-20-2014 at 02:44 PM.
  19. #19  

    Default Re: MMS pictures not displaying (AT&T)

    dont have that option under mobile networks unfortunately. only shows global data roaming access, network mode, access point names.
  20. #20  

    Default Re: MMS pictures not displaying (AT&T)

    Yeah access point names. Sorry forgot about that one.
  21. #21  

    Default Re: MMS pictures not displaying (AT&T)

    wont let me select mms port. its grayed out. everything is grayed out in there except apn which is set to vzwinternet.
  22. #22  

    Default Re: MMS pictures not displaying (AT&T)

    Same problem here...everything grayed out
  23. #23  

    Default Re: MMS pictures not displaying (AT&T)

    Do you have a plus at the top? Maybe try and add a new one and set it up like your other one but do the MMS port different

    Posted via Android Central App
  24. #24  

    Default Re: MMS pictures not displaying (AT&T)

    no plus at top.

Similar Threads

  1. S4 Display Smearing / Ghost Problem
    By Alextodd1 in forum Samsung Galaxy S4
    Replies: 20
    Last Post: 07-05-2014, 12:42 PM
  2. Not getting any notification at all on my Note 3
    By Ahmed Hesham in forum Samsung Galaxy Note 3
    Replies: 4
    Last Post: 02-12-2014, 11:40 PM
  3. Screen not activating
    By RawrEnzo123 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 02-12-2014, 05:47 AM

Posting Permissions