1. bobby1204's Avatar
    I got the update this morning and I am having a problem with GPS. It won't shut of it just stays on. I can turn it off in the settings but if I leave location on GPS stays running. Anyone having thus problem?

    Posted via Android Central App
    Freddy HO likes this.
    02-27-2014 09:31 AM
  2. Tom in Bristol's Avatar
    Not having that problem ( none, actually) but have you Powered down and re-started since the OTA? That often clears up some minor issues.
    02-27-2014 06:23 PM
  3. Photo_Drew's Avatar
    This was brought up in the other update thread. You need to change it from the location settings. Although I haven't noticed a battery difference leaving it on. It rarely pops on when I open some apps.

    Posted via Android Central App
    02-27-2014 06:30 PM
  4. snoking's Avatar
    Mine popped on 4.4 and now 4.4.2. Just stays on for a few seconds. You see it on the status bar. Does not seem to be hurting battery life. Chris

    Sent from my A200 using AC Forums mobile app
    02-27-2014 07:56 PM
  5. bobby1204's Avatar
    I have restarted my phone twice. But it still stays on, when I look under the battery settings it is Google services keeping it running.

    Posted via Android Central App
    02-28-2014 12:13 AM
  6. bobby1204's Avatar
    Got it fixed. Had to uninstall the most recent version of Google play services restart my phone then update Google play services. Everything seems good now.

    Posted via Android Central App
    02-28-2014 08:59 PM
  7. saptarshi's Avatar
    Google play services uninstall latest version is deactivated in my galaxy. How to activate the uninstall option.
    04-06-2014 04:04 AM
  8. vikingraid's Avatar
    glonass is broken
    04-24-2014 09:47 AM
  9. SiliconFiend's Avatar
    glonass is broken
    I'm wondering about that. I've never seen mine lock onto GLONASS satellites (numbers 65 to 96), but I didn't install a GPS test app until after I'd upgraded to 4.4.2 (which fixed the frequent loss of lock in 4.4 caused by bad AGPS).
    04-25-2014 12:29 AM
  10. vikingraid's Avatar
    I'm wondering about that. I've never seen mine lock onto GLONASS satellites (numbers 65 to 96), but I didn't install a GPS test app until after I'd upgraded to 4.4.2 (which fixed the frequent loss of lock in 4.4 caused by bad AGPS).
    I can confirm that it is a software issue with Kitkat.
    There are 3 screenshots, One shows S4 locking onto Glonass. The other shows S4 ignoring Glonass on 4.4.2 but the question I had was; could it be a breakdown of Glonass network? So I did it side by side with another Glonass capable tablet and confirmed it's a fault with the firmware.
    Click image for larger version. 

Name:	Screenshot_2014-01-05-15-25-03.jpg 
Views:	32 
Size:	170.9 KB 
ID:	114706
    Click image for larger version. 

Name:	Screenshot_2014-04-18-09-50-42.png 
Views:	32 
Size:	153.4 KB 
ID:	114707
    Click image for larger version. 

Name:	Screenshot_2014-04-18-09-50-46.jpg 
Views:	31 
Size:	171.1 KB 
ID:	114708
    04-25-2014 01:00 AM
  11. John_Cline's Avatar
    I, too, am having issues with 4.4.2 locking onto the GLONASS satellites. In my case, it is a Verizon Galaxy S4.
    05-09-2014 05:01 AM
  12. KWKSLVR's Avatar
    No issues on my MX.

    Posted via Android Central App
    Attached Thumbnails 4.4.2 update, GPS Issue?-21184.jpg  
    05-09-2014 08:17 AM
  13. KWKSLVR's Avatar
    Sorry, wrong screen shot. Bear in mind, you're only going to connect to these sats with your location set to High Accuracy (at least in my experience).

    Posted via Android Central App
    Attached Thumbnails 4.4.2 update, GPS Issue?-21185.jpg  
    05-09-2014 08:21 AM
  14. KWKSLVR's Avatar
    Could it just be overall signal strength too? Your GPS is always going to connect to the satellites it has the strongest connection to. My Garmin Nuvi is connected to the same satellites with similar strengths too.

    Posted via Android Central App
    Attached Thumbnails 4.4.2 update, GPS Issue?-21187.jpg  
    05-09-2014 08:33 AM

Similar Threads

  1. Play Store: Motorola Active Display Update (1.2.8)
    By Ry in forum Motorola Droid MAXX
    Replies: 5
    Last Post: 02-28-2014, 09:24 AM
  2. Help needed - Samsung GS3 texting issue
    By Askeptic in forum General Help and How To
    Replies: 2
    Last Post: 02-27-2014, 09:01 PM
  3. Replies: 1
    Last Post: 02-27-2014, 06:07 PM
  4. Have any of you had music problems after the 4.4.2 KitKat update?
    By matthewmcquay in forum Verizon HTC One
    Replies: 1
    Last Post: 02-27-2014, 05:27 PM
  5. LG G2: Speakerphone echo and volume issues
    By noturbizniss in forum Verizon LG G2
    Replies: 0
    Last Post: 02-27-2014, 04:21 PM
LINK TO POST COPIED TO CLIPBOARD
";