Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 19 of 19
Like Tree1Likes
  • 1 Post By readhpr
  1. Thread Author  Thread Author    #1  

    Default Is there Play Store trouble?

    Anyone else having trouble getting into Google Playstore? I keep getting a spinning wheel then "Connection Timed out. Retry." I don't know if it's the X or the Playstore?
  2. #2  

    Default Re: Is there Playstore trouble?

    Sounds like bandwidth issue. I get this while throttled and downloading somthing at the same time as acfessing google play

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 4
  3. #3  
    elvisgp's Avatar

    Posts
    657 Posts
    Global Posts
    681 Global Posts
    ROM
    Carbon Rom

    Default Re: Is there Playstore trouble?

    I haven't had this issue, but my dad using a note 2 has. We're not sure what is causing it yet.

    Posted via Android Central App
  4. Thread Author  Thread Author    #4  

    Default Re: Is there Playstore trouble?

    Quote Originally Posted by prepaidguy9081 View Post
    Sounds like bandwidth issue. I get this while throttled and downloading somthing at the same time as acfessing google play

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 4
    I have Verizon FIOS with 75/35 speed and have never had any bandwidth problems...also haven't been downloading anything else at the times I've experienced this and have no problems with any other sites. That's why I was wondering if it was the X after the 4.2.2. update?
  5. #5  
    sting7k's Avatar

    Posts
    558 Posts
    Global Posts
    3,602 Global Posts
    ROM
    Stock JB 4.2

    Default Re: Is there Playstore trouble?

    At least 25% of the time it tells me I have no connection. Even though I do have one. It's a Google problem. After I tap try again 2-3 times it works.

    Beamed via my Nexus 7 from the AC Forums app.
  6. #6  

    Default Re: Is there Playstore trouble?

    Not sure it is the connection as I have been having that problem for weeks, but only with the Play Store. It happens whether I am at home or not, and it just happened with my ASUS tablet too. The ASUS was on wifi and the home DSL router and the X was using the local 4G. So it is unlikely to be both the land line and the Cellular.

    I just keep hitting "Retry" and the third or fourth time it hooks up.

    My Moto G used to do it to.
  7. #7  

    Default Re: Is there Playstore trouble?

    This has been going on for a while. I can't get to the Play Store home screen ("Store Home") on my Moto X or my Nexus 7. Others have reported the same problem in some of the other device forums, and since it doesn't seem to be device specific I started a general thread about it a week or so. Nobody seems to have a fix for it. Removing and re-adding my Google account has not helped. Here's the main thread: Google Play Connection Timed Out Retry Error
  8. #8  

    Default Re: Is there Play Store trouble?

    I am using a HTC One on Sprint and this started happening to me after the update to Kit Kat. Every once in a while I can get to the store home page but probably 90% of the time I get the timed out message. The store works from any other page, I just can't get to the home page.

    Posted via Android Central App
  9. #9  

    Default Re: Is there Play Store trouble?

    I also have the same issue on a moto x an nexus 7..I called Asus support and Google..they are baffled !!!! Sometimes it works and some not ! The more we post or call will lead to a fix !!!!

    Posted via Android Central App
  10. #10  

    Default Re: Is there Play Store trouble?

    I have had this issue on my Moto X as well, if tapping retry a bunch doesn't work I reset and that seems to do the trick.

    Posted via Android Central App on my Moto X
    Current Device: Moto X VZW
    Previous: Galaxy Nexus, HTC Thunderbolt, Motorola Droid
    Before Android: Palm Pre, Blackberry Curve, Blackberry Pearl, iPhone (Original), Sidekick XL
  11. #11  

    Default Re: Is there Play Store trouble?

    Someone posted on another thread in one of the device forums some instructions from Google support. I just tried it and it's actually working for me, at least at the moment.

    1. Reboot the device.
    2. Sign out of Hangouts. (Open it up, go into the Settings, and you can sign out from there.)
    3. Open up Hangouts again and sign in.
    4. Go to Settings -> Apps - > All -> Google Play Store and clear the Cache.

    Open up the Play Store and cross your fingers. I initially got the timeout/connection error, but I hit Retry and it worked. I have closed and reopened the Play Store a few times (clearing it from the Task switcher), and so far all is well.
    Thanked by:
    jbarborka likes this.
  12. #12  

    Default Re: Is there Play Store trouble?

    I think I may have stumbled upon the solution.

    I normally don't bother having wifi hooked up as I have unlimited data and because of the Play Store time out issue I have been installing apps via the PC and they are then pushed to the X.

    But today, not thinking, I went to the Play Store on the X, and again got the time outs. I wondered if the wifi might be the issue so I hooked to my router wifi and so far the problem has not reoccurred.

    To me, based on this, it seems that Android/Play or whatever is trying to first access via wifi and if that fails it drops back to 3G/4G. The problem being that it must not first be checking to see if wifi is enabled and I think that's what may be causing this issue. If wifi is not enabled then it should go straight to 3G/4G but instead it tries wifi a few times and fails. After several retries is gives up and goes to 3G/4G.
  13. #13  

    Default Re: Is there Play Store trouble?

    I have had this issue for several days on my Moto X (AT&T - 4.4) and a couple times on my Nexus 7 (2013 - 4.4.2).

    My work around has been to search ANYTHING while the wheel spins and it will give you the results. then tap the back button, and the Play Store icon on the upper left of the screen will display with the drop-down menu that you can then utilize to hit "My Apps" and you're in. A bit of a pain, but everything works just fine after getting past the spinning wheel guard.
  14. #14  

    Default Re: Is there Play Store trouble?

    Under Settings/Date&Time, uncheck the "Automatic date & time - Use Network-provided Time" and "Automatic time zone - Use network-provided time zone".

    One retry for the Play Store and it's now working.

    Not ideal, but it worked for me.
  15. #15  

    Default Re: Is there Play Store trouble?

    Quote Originally Posted by MoDebt View Post
    Under Settings/Date&Time, uncheck the "Automatic date & time - Use Network-provided Time" and "Automatic time zone - Use network-provided time zone".

    One retry for the Play Store and it's now working.

    Not ideal, but it worked for me.
    I've been having this connection timed out business for the last few days and have tried EVERYTHING suggested so far. My sister surprisingly has the same problem. Just tried the date&time trick you mentioned and low and behold, it works!! It's all up and running again.

    But of course, won't work on mine. I'm so frustrated that I may just give up and wipe my whole phone.
  16. #16  
    pyroflyx's Avatar

    Posts
    6 Posts
    Global Posts
    7 Global Posts

    Default Re: Is there Play Store trouble?

    Quote Originally Posted by TRACYSRAIL View Post
    I've been having this connection timed out business for the last few days and have tried EVERYTHING suggested so far. My sister surprisingly has the same problem. Just tried the date&time trick you mentioned and low and behold, it works!! It's all up and running again.

    But of course, won't work on mine. I'm so frustrated that I may just give up and wipe my whole phone.
    I'm in the same situation as you. Wiping the phone had no effect. I've been trying to track posts mention this issue on my blog.
  17. #17  

    Default Re: Is there Play Store trouble?

    Quote Originally Posted by pyroflyx View Post
    I'm in the same situation as you. Wiping the phone had no effect. I've been trying to track posts mention this issue on my blog.
    This has been happening for me for a month, on both my Moto X and my Nexus 7 (2012). I've tried everything short of wiping the device, and nothing has worked. It's equally frustrating that there doesn't seem to be anywhere online to report technical problems to Google. Apparently you can call, but I really don't want to go through that.
  18. #18  

    Default Re: Is there Play Store trouble?

    I had some trouble downloading apps. It would just have the downloading bar FOREVER and then "Download failed" or something... Turned wifi off and used data and it worked fine.

    I'm on Verizon
  19. #19  

    Default Re: Is there Play Store trouble?

    Hey I have the same problem with my MOTO X. The problem persisted even after the Moto X OS update to Kitkat.
    When this happens, i usually force stop the Play store app in the settings>app. Then i restart the playstore. Works for me!

Similar Threads

  1. Replies: 24
    Last Post: 03-04-2014, 11:12 AM
  2. There is an update!
    By BacchusKC in forum Sprint Samsung Galaxy Note 3
    Replies: 4
    Last Post: 03-03-2014, 02:23 PM
  3. Dad, your pocket is talking
    By Rick Jacobs in forum Moto X (2013)
    Replies: 8
    Last Post: 03-02-2014, 04:10 PM
  4. Wife has s3 and is able to update in july
    By jlost in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 02-28-2014, 01:47 PM
  5. Replies: 0
    Last Post: 02-28-2014, 01:25 PM

Posting Permissions