Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default Flaky radios on the unlocked GSM Moto X?

    I had an AT&T branded Moto X that worked without any connectivity issue. I picked up a custom unlocked GSM version from Moto Maker to replace it, as ATT wouldn't agree to unlock it for a year. The radio on the unlocked version seems to have some issues. Occasionally, I drop all cellular connectivity for 30 to 40 seconds. I cannot always recreate the issue, but it is most likely to happen when I dial a number and hang up before anyone answers, then immediately attempt to dial a new number. I get the hollow zero bar symbol and a network unavailable message when I try to place the call. It never lasts long.

    Also, on the AT&T version - my LTE seemed a little more solid, but now I see the phone drop to 4G more frequently... but that may just be me looking at the phone more often (and oddly enough, a dead zone on the old AT&T phone is now connecting solidly and consistently on Edge).

    So, there is clearly something different with the radio or software controlling the radio. Anyone else noticed any of this?
  2. #2  

    Default Re: Flaky radios on the unlocked GSM Moto X?

    I was also thinking this lately. I notice the service is not as good as my galaxy s3 was in some places. I was also blaming the unlocked gsm thing.
  3. #3  

    Default Re: Flaky radios on the unlocked GSM Moto X?

    I've noticed similar issues, but in my case also switched carriers to T Mobile. I've assumed it was because of their poor coverage, but now I wonder if it is also a difference between the att radio and the unlocked gsm one :/
  4. #4  

    Default Re: Flaky radios on the unlocked GSM Moto X?

    Quote Originally Posted by asdrew View Post
    I've noticed similar issues, but in my case also switched carriers to T Mobile. I've assumed it was because of their poor coverage, but now I wonder if it is also a difference between the att radio and the unlocked gsm one :/
    hi
    i noticed the same issue i was working in a basement of a house i had no signal with my moto x i mean zero the other guy had a T-mobile samsung gallaxy 4 he had signal ,i saw it with my eyes he was surfing the web i was not able to do anything with the phone i could not believe it.
    i was very disappointed !! i taking good care of my phone i have silicone case on it never dropped it i have good signal elsewhere, no issues .

    what should i do i bought this phone for $350 and everybody says motorola has a good radio i mean i can use the phone but i wana be able to use it in a basement or places like that just like the other guy who also has t-mobile and the samsung gallaxy 4 is old how is the moto x cant compare to it .
  5. #5  

    Default Re: Flaky radios on the unlocked GSM Moto X?

    Quote Originally Posted by cd619 View Post
    I had an AT&T branded Moto X that worked without any connectivity issue. I picked up a custom unlocked GSM version from Moto Maker to replace it, as ATT wouldn't agree to unlock it for a year. The radio on the unlocked version seems to have some issues. Occasionally, I drop all cellular connectivity for 30 to 40 seconds. I cannot always recreate the issue, but it is most likely to happen when I dial a number and hang up before anyone answers, then immediately attempt to dial a new number. I get the hollow zero bar symbol and a network unavailable message when I try to place the call. It never lasts long.

    Also, on the AT&T version - my LTE seemed a little more solid, but now I see the phone drop to 4G more frequently... but that may just be me looking at the phone more often (and oddly enough, a dead zone on the old AT&T phone is now connecting solidly and consistently on Edge).

    So, there is clearly something different with the radio or software controlling the radio. Anyone else noticed any of this?
    hi
    i noticed the same issue i was working in a basement of a house i had no signal with my moto x i mean zero the other guy had a T-mobile samsung gallaxy 4 he had signal ,i saw it with my eyes he was surfing the web i was not able to do anything with the phone i could not believe it.
    i was very disappointed !! i taking good care of my phone i have silicone case on it never dropped it i have good signal elsewhere, no issues .

    what should i do i bought this phone for $350 and everybody says motorola has a good radio i mean i can use the phone but i wana be able to use it in a basement or places like that just like the other guy who also has t-mobile and the samsung gallaxy 4 is old how is the moto x cant compare to it .

    i may be getting the new sony Z2

Similar Threads

  1. Looking to get the Galaxy S4
    By bobniborg in forum Verizon Samsung Galaxy S4
    Replies: 7
    Last Post: 03-11-2014, 06:02 PM
  2. Control GN3's Radio band?
    By LimuHead in forum T-Mobile Samsung Galaxy Note 3
    Replies: 14
    Last Post: 03-09-2014, 09:23 PM
  3. [free]Spotmania - Spot the Difference!
    By playchapdev in forum Games
    Replies: 1
    Last Post: 03-09-2014, 12:05 PM
  4. Nexus 7: Need help - either the disk is damaged or it's a software glitch?
    By Snapphane in forum Google Nexus 7 Tablet (2012)
    Replies: 6
    Last Post: 03-09-2014, 01:36 AM
  5. Bluetooth headsets: Charge & use at the same time?
    By LimuHead in forum General News & Discussion
    Replies: 0
    Last Post: 03-08-2014, 02:48 AM

Posting Permissions