1. eric002's Avatar
    I don't know if anyone else has read Android Central today but as of April, Google hands announced that any Android phone running software older than kit Kat will not be able to support Google Wallet.. Now, for those users, it really does suck. This is why I'm so happy I got my Moto X with Google's services on it :-P

    Posted via Android Central App
    03-14-2014 04:48 PM
  2. TechTinker's Avatar
    I'm not sure of the issue here. All nexus devices have 4.4, (except the Galaxy Nexus owners). And all the main devices have 4.4 and usually need it because of Isis and the Carriers.
    03-14-2014 07:39 PM
  3. eric002's Avatar
    I'm not sure of the issue here. All nexus devices have 4.4, (except the Galaxy Nexus owners). And all the main devices have 4.4 and usually need it because of Isis and the Carriers.
    No I know. I was saying I'm thankful to have a moto X which is essentially Verizon's Google phone. :-D

    Posted via Android Central App
    03-14-2014 08:31 PM

Similar Threads

  1. Google Wallet Killing 2.5%
    By daehttub in forum General News & Discussion
    Replies: 2
    Last Post: 03-14-2014, 12:52 PM
  2. Google Maps from Computer to Nexus 5
    By lornaevo in forum Google Nexus 5
    Replies: 3
    Last Post: 03-14-2014, 10:25 AM
  3. Replies: 2
    Last Post: 03-14-2014, 10:18 AM
  4. MoWeather 1.1 for Android is ready on Google Play!!
    By kennywoo123 in forum General News & Discussion
    Replies: 0
    Last Post: 03-14-2014, 04:33 AM
  5. Multiple Devices how to enable Google+ Sync?
    By d-roidz31 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 03-13-2014, 10:17 PM
LINK TO POST COPIED TO CLIPBOARD