Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  
    blancoal's Avatar

    Posts
    3 Posts
    Global Posts
    11 Global Posts

    Default Gmail keep awake killing my battery

    Has anyone seen this?

    My battery life, all of a sudden went way down, and I root caused it to Gmail sync. If I disable sync, no problem. If I have it on, battery gets used up, and from the battery screens, it looks like it is piling up "keep awake" time. I have Gmail v 4.2.7, which is the latest. This screen shot shows a short experiment, but I have seen where sync on for 2 hours, turns into keep awake from Gmail of 1:57 or so. Thanks for any help.

    Gmail keep awake killing my battery-screenshot_2014-04-09-08-50-39.pngGmail keep awake killing my battery-screenshot_2014-04-09-08-50-35.png
  2. #2  
    JoeNM84's Avatar

    Posts
    487 Posts
    Global Posts
    502 Global Posts

    Default Re: Gmail keep awake killing my battery

    Have you rebooted the phone? Uninstalled & reinstalled updates to Gmail?
  3. #3  

    Default Re: Gmail keep awake killing my battery

    Try shortening the number of days to sync, especially if you're someone with a lot of messages in your inbox. Also, try clearing the cache or using something like Clean Master.

    https://play.google.com/store/apps/d...nmaster.mguard
    Droid->Droid Bionic->Galaxy S4->Moto X (black/black/yellow)->Moto X (ebony/black/yellow)
  4. #4  

    Default Re: Gmail keep awake killing my battery

    Do you have email sync set to push? Try 15 or 30 minutes. See how your results are then.

    Unrelated, but there is a notification bar setting to hide those two icons if you want to reclaim some space up there or you can change the icon to display battery percent..
  5. #5  
    KWKSLVR's Avatar

    Posts
    575 Posts
    Global Posts
    576 Global Posts

    Default Re: Gmail keep awake killing my battery

    Wipe data for the Gmail App, reboot, resync, and give it a little time to see if that helps. I've had similar issues in the past on other devices and wiping app data and resyncing always fixed it.
  6. #6  

    Default

    I just have all my email set to not sync. Also I use the email instead of gmail. But that's alot of usage for gmail in a 20 minute span.

    Posted via Android Central App

Similar Threads

  1. Replies: 8
    Last Post: Yesterday, 12:27 AM
  2. Keep losing all wi-fi saved passwords
    By Pavlos Ashiotis in forum Samsung Galaxy Note 3
    Replies: 5
    Last Post: 05-08-2014, 04:43 PM
  3. Replies: 2
    Last Post: 04-14-2014, 06:58 AM
  4. How can I tell my phone it's number?
    By Villordsutch in forum General Help and How To
    Replies: 9
    Last Post: 04-11-2014, 04:55 AM
  5. how can i restore mobile data on my sprint SGIII
    By Sheila Thurmond in forum Sprint Galaxy S3
    Replies: 12
    Last Post: 04-09-2014, 05:33 PM

Posting Permissions