Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
  1. Thread Author  Thread Author    #1  
    maraki1224's Avatar

    Posts
    7 Posts
    Global Posts
    36 Global Posts

    Default Google Chrome issue

    I've had my Moto X since December and am loving it. However, a week or 2 ago, my browser sometimes will open a web page very slowly, or not at all. Sometimes, it works great. Other times, I get a white screen and nothing opens. The last few times after getting the white screen, I opened and closed the 'setting' tab and then my page opened up. Any ideas?
  2. #2  

    Default Re: Google Chrome issue

    Welcome to Android Central! Is this on mobile data, wi-fi, or both?
  3. #3  

    Default Re: Google Chrome issue

    Chrome update just posted in Play store may have addressed this. I had similar issues. We'll see...

    Sent from my Nexus 7 using AC Forums mobile app
  4. #4  

    Default Re: Google Chrome issue

    Update is rolling out, hasn't hit my moto x yet...

    Sent from my Nexus 7 using AC Forums mobile app
  5. #5  
    weksa's Avatar

    Posts
    161 Posts
    Global Posts
    163 Global Posts

    Default Re: Google Chrome issue

    If the update doesn't fix it, I recommend clearing Chrome cache and uninstalling all updates to return to factory version. Then install the new update. An update to Chrome gave me problems, and this method fixed it.

    Sent from my XT1058 using Tapatalk
  6. Thread Author  Thread Author    #6  
    maraki1224's Avatar

    Posts
    7 Posts
    Global Posts
    36 Global Posts

    Default Re: Google Chrome issue

    Thanks for the suggestions. I cleared the cache; no improvement. My problem started before the last update. Will try uninstalling updates and installing the new update. I'll report back.
  7. #7  
    Evilnut's Avatar

    Posts
    386 Posts
    Global Posts
    395 Global Posts
    ROM
    Stock

    Default Re: Google Chrome issue

    Quote Originally Posted by maraki1224 View Post
    Thanks for the suggestions. I cleared the cache; no improvement. My problem started before the last update. Will try uninstalling updates and installing the new update. I'll report back.
    Try Chrome Beta. Just to see if it has the same problems. Then you can narrow down your issue. I've been using Chrome Beta since it came out a couple years ago.

    Posted via Android Central App from my Ebony backed Moto X
    Tim
    Droid 4
    Nexus 10
    Lapdock 500 Pro
  8. #8  

    Default Re: Google Chrome issue

    I've run into the same thing. I uninstalled the updates and it has worked without an issue. I then d/l the updates and it started again, so I uninstalled them. Still waiting for a fix.
    Thanked by:
  9. #9  
    Kilroy13's Avatar
    Banned

    Posts
    366 Posts

    Default Re: Google Chrome issue

    Mine did the same thing! I just disabled it and went with opera instead!

    SENT VIA MY LG G-FLEX ON SPRINT, POSTED BY ANDROID CENTRALS APP....LIFE IS GOOD✌
  10. Thread Author  Thread Author    #10  
    maraki1224's Avatar

    Posts
    7 Posts
    Global Posts
    36 Global Posts

    Default Re: Google Chrome issue

    OK, I did uninstall the updates and installed them again. Doing the same thing. If I get a white screen, no matter how long it stays that way, then I hit the settings options and then go back to the screen, my page opens immediately. I just don't want to have to go to the settings option in order to open my page.
    Now I'm considering a different browser. I've never done this before, so here's a dumb question. What's the difference between Opera and Opera Mini?

Similar Threads

  1. Turning on WiFi issues?
    By QueenCaoa in forum HTC One (M8)
    Replies: 3
    Last Post: 05-29-2014, 09:22 AM
  2. Otterbox Defender Series and Keyboard Issues
    By digital-g in forum HTC One (M8)
    Replies: 2
    Last Post: 05-29-2014, 05:27 AM
  3. Official Wireless Charging Kit Issue!!
    By Warcony in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 05-29-2014, 04:43 AM
  4. Google play wishlist disappeared
    By kill4food in forum General Help and How To
    Replies: 4
    Last Post: 05-28-2014, 01:18 PM
  5. Nothing Downloads from Google Play Store
    By Luke James in forum Google Play Store
    Replies: 2
    Last Post: 05-28-2014, 09:18 AM

Posting Permissions